[Linux-PowerEdge] Cannot find libsmbios-2.2.27-1908.9058.el6.x86_64

Manoel Pinho pinho at ime.eb.br
Tue Apr 26 07:27:43 CDT 2016


I have a PowerEdge with CentOS release 6.7 with the folowing 
repositories enabled:

base
dell-omsa-indep
dell-omsa-specific
dell-system-update_dependent
epel
extras
updates


For the first time I have the following error whan I tried to update the 
system:

# yum update --downloadonly

Loaded plugins: fastestmirror
Setting up Update Process
Loading mirror speeds from cached hostfile
  * base: mirror.nbtelecom.com.br
  * epel: epel.gtdinternet.com
  * extras: mirror.nbtelecom.com.br
  * updates: mirror.nbtelecom.com.br
Resolving Dependencies
--> Running transaction check
---> Package libsmbios.x86_64 0:2.2.27-4.155.1.el6 will be updated
--> Processing Dependency: libsmbios = 2.2.27-4.155.1.el6 for package: 
python-smbios-2.2.27-4.155.1.el6.x86_64
---> Package libsmbios.x86_64 0:2.2.27-1908.9058.el6 will be an update
---> Package smbios-utils-bin.x86_64 0:2.2.27-4.155.1.el6 will be updated
---> Package smbios-utils-bin.x86_64 0:2.2.27-1908.9058.el6 will be an 
update
---> Package srvadmin-argtable2.x86_64 0:8.1.0-4.5.1.el6 will be updated
---> Package srvadmin-argtable2.x86_64 0:8.3.0-1908.9058.el6 will be an 
update
---> Package srvadmin-base.x86_64 0:8.1.0-4.3.1.el6 will be updated
---> Package srvadmin-base.x86_64 0:8.3.0-1908.9058.el6 will be an update
---> Package srvadmin-cm.x86_64 0:8.1.0-4.1.249.el6 will be updated
---> Package srvadmin-cm.x86_64 0:8.3.0-1908.9058.el6 will be an update
---> Package srvadmin-deng.x86_64 0:8.1.0-4.8.1.el6 will be updated
---> Package srvadmin-deng.x86_64 0:8.3.0-1908.9058.el6 will be an update
---> Package srvadmin-hapi.x86_64 0:8.1.0-4.10.2.el6 will be updated
---> Package srvadmin-hapi.x86_64 0:8.3.0-1908.9058.el6 will be an update
---> Package srvadmin-isvc.x86_64 0:8.1.0-4.38.1.el6 will be updated
---> Package srvadmin-isvc.x86_64 0:8.3.0-1908.9058.el6 will be an update
---> Package srvadmin-nvme.x86_64 0:8.1.0-4.139.1.el6 will be updated
---> Package srvadmin-nvme.x86_64 0:8.3.0-1908.9058.el6 will be an update
---> Package srvadmin-omacs.x86_64 0:8.1.0-4.92.1.el6 will be updated
---> Package srvadmin-omacs.x86_64 0:8.3.0-1908.9058.el6 will be an update
---> Package srvadmin-omilcore.x86_64 0:8.1.0-4.85.1.el6 will be updated
---> Package srvadmin-omilcore.x86_64 0:8.3.0-1908.9058.el6 will be an 
update
---> Package srvadmin-ominst.x86_64 0:8.1.0-4.94.3.el6 will be updated
---> Package srvadmin-ominst.x86_64 0:8.3.0-1908.9058.el6 will be an update
---> Package srvadmin-racadm4.x86_64 0:8.1.0-4.1.127.el6 will be updated
---> Package srvadmin-racadm4.x86_64 0:8.3.0-1908.9058.el6 will be an update
---> Package srvadmin-racadm5.x86_64 0:8.1.0-4.1.128.el6 will be updated
--> Processing Dependency: srvadmin-racadm5 = 8.1.0 for package: 
dell_ie_rac_5-8.1.0-4.1.128.el6.x86_64
---> Package srvadmin-racadm5.x86_64 0:8.3.0-1908.9058.el6 will be an update
---> Package srvadmin-realssd.x86_64 0:8.1.0-4.139.1.el6 will be updated
---> Package srvadmin-realssd.x86_64 0:8.3.0-1908.9058.el6 will be an update
---> Package srvadmin-smcommon.x86_64 0:8.1.0-4.138.2.el6 will be updated
---> Package srvadmin-smcommon.x86_64 0:8.3.0-1908.9058.el6 will be an 
update
---> Package srvadmin-storelib.x86_64 0:8.1.0-4.139.1.el6 will be updated
---> Package srvadmin-storelib.x86_64 0:8.3.0-1908.9058.el6 will be an 
update
---> Package srvadmin-storelib-sysfs.x86_64 0:8.1.0-4.1.1.el6 will be 
updated
---> Package srvadmin-storelib-sysfs.x86_64 0:8.3.0-1908.9058.el6 will 
be an update
--> Finished Dependency Resolution
Error: Package: dell_ie_rac_5-8.1.0-4.1.128.el6.x86_64 (@dell-omsa-indep)
            Requires: srvadmin-racadm5 = 8.1.0
            Removing: srvadmin-racadm5-8.1.0-4.1.128.el6.x86_64 
(@dell-omsa-indep)
                srvadmin-racadm5 = 8.1.0-4.1.128.el6
            Updated By: srvadmin-racadm5-8.3.0-1908.9058.el6.x86_64 
(dell-omsa-indep)
                srvadmin-racadm5 = 8.3.0-1908.9058.el6
Error: Package: python-smbios-2.2.27-4.155.1.el6.x86_64 (@dell-omsa-indep)
            Requires: libsmbios = 2.2.27-4.155.1.el6
            Removing: libsmbios-2.2.27-4.155.1.el6.x86_64 (@dell-omsa-indep)
                libsmbios = 2.2.27-4.155.1.el6
            Updated By: libsmbios-2.2.27-1908.9058.el6.x86_64 
(dell-omsa-indep)
                libsmbios = 2.2.27-1908.9058.el6
            Available: libsmbios-2.2.26-3.el6.i686 (epel)
                libsmbios = 2.2.26-3.el6
  You could try using --skip-broken to work around the problem
  You could try running: rpm -Va --nofiles --nodigest

---------------------------------------

The problem is that yum can't find libsmbios-2.2.27-1908.9058.el6.x86_64  !


Some additional details about the repositories:

---------------------------------------

# cat /etc/yum.repos.d/dell-system-update.repo
[dell-system-update_independent]
name=dell-system-update_independent
baseurl=http://linux.dell.com/repo/hardware/dsu/os_independent/
gpgcheck=1
gpgkey=http://linux.dell.com/repo/hardware/dsu/public.key
enabled=1
exclude=dell-system-update*.i386

[dell-system-update_dependent]
name=dell-system-update_dependent
mirrorlist=http://linux.dell.com/repo/hardware/dsu/mirrors.cgi?osname=el$releasever&basearch=$basearch&native=1
gpgcheck=1
gpgkey=http://linux.dell.com/repo/hardware/dsu/public.key
enabled=1

-------------------------------

# cat /etc/yum.repos.d/dell-omsa-repository.repo
[dell-omsa-indep]
name=Dell OMSA repository - Hardware independent
type=rpm-md
mirrorlist=http://linux.dell.com/repo/hardware/latest/mirrors.cgi?osname=el$releasever&basearch=$basearch&native=1&dellsysidpluginver=$dellsysidpluginver
gpgcheck=1
gpgkey=http://linux.dell.com/repo/hardware/latest/RPM-GPG-KEY-dell
     http://linux.dell.com/repo/hardware/latest/RPM-GPG-KEY-libsmbios
enabled=1
failover=priority
bootstrapurl=http://linux.dell.com/repo/hardware/latest/bootstrap.cgi


[dell-omsa-specific]
name=Dell OMSA repository - Hardware specific
type=rpm-md
mirrorlist=http://linux.dell.com/repo/hardware/latest/mirrors.cgi?osname=el$releasever&basearch=$basearch&native=1&sys_ven_id=$sys_ven_id&sys_dev_id=$sys_dev_id&dellsysidpluginver=$dellsysidpluginver
gpgcheck=1
gpgkey=http://linux.dell.com/repo/hardware/latest/RPM-GPG-KEY-dell
     http://linux.dell.com/repo/hardware/latest/RPM-GPG-KEY-libsmbios
enabled=1
failover=priority
bootstrapurl=http://linux.dell.com/repo/hardware/latest/bootstrap.cgi

---------------------------------------

Reading this page

http://linux.dell.com/repo/hardware/dsu/

I don't understand if the problem is related to the use of OMSA 
repository (it seems that was replaced py DSU repositories).

Thanks in advance



More information about the Linux-PowerEdge mailing list