[Linux-PowerEdge] Problems with LTO tape drive on R520

Neil Millar nrm at ast.cam.ac.uk
Fri May 15 03:31:31 CDT 2015


Hi All, Apologies for the long message!

We are having problems with an R520 server backing up to an LTO tape
drive and wondered if anyone had any similar problems or
ideas on fixes.

We are using the Linux dump command to backup directories
to the tape, we have been using a similar setup with a Supermicro
server and Tandberg tape changer for several years with no problems.

The problems are that the dump will either stop with a
Write Error:Input/output error, or, often on the second tape of a set, 
will run very slowly (ie 10-50MB/s instead of the usual ~135MB/s)

Once the tape is in this slow mode, it is very difficult to get it
out. Canceling the backup and restarting with the first tape will
still run slowly, unloading and reloading the mpt2sas module
also doesn't work.

One interesting thing is that we can normally read from the raid
partition at ~650MB/s, but when the backup is running slowly a
read from the disk can also only read at ~3MB/s. This seems a good
indicator of something, but I'm not sure what! As soon as you cancel
the backup the disk goes back up to full speed.

We get the following errors in the logs, which look to be
timeout errors:

kernel: mpt2sas0: log_info(0x3112011a): originator(PL), code(0x12), 
sub_code(0x011a)
kernel: st0: Error b0000 (driver bt 0x0, host bt 0xb).
kernel: INFO: task dump:3035 blocked for more than 120 seconds.

I have tried both the IBM and Quantum tape drive testing
suites, which show no particular errors and can test a full
tape at ~135MB/s (even when dump is in its 'slow' mode)

The hardware is:

Dell R520 / H710 raid card / SAS 6Gpbs HBA external controller
Quantum Superloader 3 tape changer with IBM LTO 5 tape drive
Redhat 6.6
15TB ext4 Raid 6 data partition

Things we have tried:

Swapping the Superloader 3 with IBM tape drive for a stand-alone HP tape 
drive
Swapping the SAS cable
Swapping the Dell SAS card for an LSI card
Using new and used tapes
Using HP and Sony tapes
Using IBM's tape driver instead of the default linux driver
Block sizes from 10K to 1M
Backing up from a smaller (3TB) ext4 disk partition
Backing up a single file instead of lots of smaller files
IBM and Quantum tape drive testing suite

Thanks in advance!

Neil.



More information about the Linux-PowerEdge mailing list