[Linux-PowerEdge] OMSA dependency

Ben bda20 at cam.ac.uk
Wed May 13 08:30:52 CDT 2015


On Wed, 13 May 2015, Rathish_Das at DELL.com wrote:

> With YUM update this should not happen. We tested in our lab.
> Can you please do the followings and  let me know the result-
> 
> 1)      "yum remove srvadmin-hapi*"
> 
> 2)      Now please try to install OMSA 8.1.0

Well, that worked... sort of.  I did the following

# yum remove srvadmin-hapi*
# yum install srvadmin-storageservices srvadmin-omcommon
##### Because previous times srvadmin-omcommon hasn't been listed as a ##### 
dependency has had to be installed separately
# yum install dell_ft_install -y
# yum install $(bootstrap_firmware) -y
# /opt/dell/srvadmin/sbin/srvadmin-services.sh start

However, then doing the following revealed a mixture of 7.4.0 and 8.1.0 
components:

# omreport system summary
Server Module Summary

------------------
Software Profile
------------------
Systems Management
Name                 : Dell OpenManage Server Administrator
Version              : 7.4.0
Description          : Systems Management Software
Contains             : A library for parsing GNU style command line arguments 
7.4.0
                      : Data Engine 8.1.0
                      : Data Engine SNMP 8.1.0
                      : Disney SNMP 8.1.0
                      : Hardware Abstraction Programming Interface 8.1.0
                      : Instrumentation Services 8.1.0
                      : Meta package for installing the Server Administrator Storage Services feature 8.1.0
                      : Meta package for installing the Server Administrator storage cli component 8.1.0
                      : Meta package for installing the Server Administrator storage snmp component 8.1.0
                      : NVMe Library 7.4.0
                      : RAC5 Command Interface 7.1.0
                      : RealSSD package for storage management 7.4.0
                      : Remote Access Card Data Populator 8.1.0
                      : Server Administrator CLI 8.1.0
                      : Server Administrator Common Framework 8.1.0
                      : Server Administrator Common Services 7.4.0
                      : Server Administrator Core 8.1.0
                      : Server Administrator XML Support SDK 7.4.0
                      : Software package for Fluid Cache Management 7.4.0
                      : Storage Management CLI component 5.0.1
                      : Storage Management SNMP component 5.0.1
                      : Storage Management System Utilities Package / Libsysfs 1.3.0
                      : Storage Management accessors package 5.0.1
                      : Storage Management common files for GUI and CLI 5.0.1
                      : StoreLib package for storage management 8.1.0
                      : System Utilities Package/Libsysfs for LSI storage libraries 2.1.0
                      : iDRAC SNMP components 8.1.0
[...]

However!  A further "yum update" revealed

firmware-tools.noarch 0:2.1.17-4.10.1.el6
srvadmin-argtable2.x86_64 0:8.1.0-4.5.1.el6
srvadmin-nvme.x86_64 0:8.1.0-4.139.1.el6
srvadmin-omacs.x86_64 0:8.1.0-4.92.1.el6
srvadmin-omilcore.x86_64 0:8.1.0-4.85.1.el6
srvadmin-realssd.x86_64 0:8.1.0-4.139.1.el6
srvadmin-rnasoap.x86_64 0:8.1.0-4.139.1.el6
srvadmin-storelib-sysfs.x86_64 0:8.1.0-4.1.1.el6
srvadmin-xmlsup.x86_64 0:8.1.0-4.91.1.el6

Installing those gave me

# omreport system summary
System Summary

------------------
Software Profile
------------------
Systems Management
Name            : Dell OpenManage Server Administrator
Version         : 8.1.0
Description     : Systems Management Software
Contains        : A library for parsing GNU style command line arguments 8.1.0
                 : Data Engine 8.1.0
                 : Data Engine SNMP 8.1.0
                 : Disney SNMP 8.1.0
                 : Hardware Abstraction Programming Interface 8.1.0
                 : Instrumentation Services 8.1.0
                 : Meta package for installing the Server Administrator Storage Services feature 8.1.0
                 : Meta package for installing the Server Administrator storage cli component 8.1.0
                 : Meta package for installing the Server Administrator storage snmp component 8.1.0
                 : NVMe Library 8.1.0
                 : RAC5 Command Interface 7.1.0
                 : RealSSD package for storage management 8.1.0
                 : Remote Access Card Data Populator 8.1.0
                 : Server Administrator CLI 8.1.0
                 : Server Administrator Common Framework 8.1.0
                 : Server Administrator Common Services 8.1.0
                 : Server Administrator Core 8.1.0
                 : Server Administrator XML Support SDK 8.1.0
                 : Software package for Fluid Cache Management 8.1.0
                 : Storage Management CLI component 5.0.1
                 : Storage Management SNMP component 5.0.1
                 : Storage Management System Utilities Package / Libsysfs 1.3.0
                 : Storage Management accessors package 5.0.1
                 : Storage Management common files for GUI and CLI 5.0.1
                 : StoreLib package for storage management 8.1.0
                 : System Utilities Package/Libsysfs for LSI storage libraries 2.1.0
                 : iDRAC SNMP components 8.1.0
[...]

Which seems a bit more sensible.  Not entirely a smooth procedure!  And this 
box has only ever been installed via the yum repo (no manual installs).

Ben
-- 
Unix Support, UIS, University of Cambridge, England



More information about the Linux-PowerEdge mailing list