[Linux-PowerEdge] Update of OMSA leads to broken dependencies

Ben bda20 at cam.ac.uk
Wed May 13 04:37:29 CDT 2015


Hi All,

After a "yum clean all" I tried updating a RHEL6 server (Dell R610) from 
OMSA 7.4 to (apparently) 8.1 using "yum update".  This happened:

Error: Package: libsmal0-3.1.0-4.132.1.el6.x86_64 (@dell-omsa-indep)
            Requires: libdchipm.so.7()(64bit)
            Removing: srvadmin-hapi-7.4.0-4.28.2.el6.x86_64 (@dell-omsa-indep)
                libdchipm.so.7()(64bit)
            Updated By: srvadmin-hapi-8.1.0-4.10.2.el6.x86_64 (dell-omsa-specific)
                Not found
Error: Package: dell_ie_bios-3.1.0-4.105.2.el6.x86_64 (@dell-omsa-indep)
            Requires: libdchapi.so.7()(64bit)
            Removing: srvadmin-hapi-7.4.0-4.28.2.el6.x86_64 (@dell-omsa-indep)
                libdchapi.so.7()(64bit)
            Updated By: srvadmin-hapi-8.1.0-4.10.2.el6.x86_64 (dell-omsa-specific)
                Not found
Error: Package: dell_ie_pcissd-1.0.0-4.107.2.el6.x86_64 (@dell-omsa-indep)
            Requires: libdchapi.so.7()(64bit)
            Removing: srvadmin-hapi-7.4.0-4.28.2.el6.x86_64 (@dell-omsa-indep)
                libdchapi.so.7()(64bit)
            Updated By: srvadmin-hapi-8.1.0-4.10.2.el6.x86_64 (dell-omsa-specific)
                Not found
Error: Package: dell_ie_nvme_pcissd-1.0.0-4.122.2.el6.x86_64 (@dell-omsa-indep)
            Requires: libdchapi.so.7()(64bit)
            Removing: srvadmin-hapi-7.4.0-4.28.2.el6.x86_64 (@dell-omsa-indep)
                libdchapi.so.7()(64bit)
            Updated By: srvadmin-hapi-8.1.0-4.10.2.el6.x86_64 (dell-omsa-specific)
                Not found
Error: Package: dell_ie_nvme_pcissd-1.0.0-4.122.2.el6.x86_64 (@dell-omsa-indep)
            Requires: libdchbas.so.7()(64bit)
            Removing: srvadmin-hapi-7.4.0-4.28.2.el6.x86_64 (@dell-omsa-indep)
                libdchbas.so.7()(64bit)
            Updated By: srvadmin-hapi-8.1.0-4.10.2.el6.x86_64 (dell-omsa-specific)
                Not found
Error: Package: dell_ie_bios-3.1.0-4.105.2.el6.x86_64 (@dell-omsa-indep)
            Requires: libdchbas.so.7()(64bit)
            Removing: srvadmin-hapi-7.4.0-4.28.2.el6.x86_64 (@dell-omsa-indep)
                libdchbas.so.7()(64bit)
            Updated By: srvadmin-hapi-8.1.0-4.10.2.el6.x86_64 (dell-omsa-specific)
                Not found
Error: Package: dell_ie_pcissd-1.0.0-4.107.2.el6.x86_64 (@dell-omsa-indep)
            Requires: libdchbas.so.7()(64bit)
            Removing: srvadmin-hapi-7.4.0-4.28.2.el6.x86_64 (@dell-omsa-indep)
                libdchbas.so.7()(64bit)
            Updated By: srvadmin-hapi-8.1.0-4.10.2.el6.x86_64 (dell-omsa-specific)
                Not found
Error: Package: dell_ie_backplane-1.0.0-4.135.2.el6.x86_64 (@dell-omsa-indep)
            Requires: libdchapi.so.7()(64bit)
            Removing: srvadmin-hapi-7.4.0-4.28.2.el6.x86_64 (@dell-omsa-indep)
                libdchapi.so.7()(64bit)
            Updated By: srvadmin-hapi-8.1.0-4.10.2.el6.x86_64 (dell-omsa-specific)
                Not found
Error: Package: dell_ie_backplane-1.0.0-4.135.2.el6.x86_64 (@dell-omsa-indep)
            Requires: libdchbas.so.7()(64bit)
            Removing: srvadmin-hapi-7.4.0-4.28.2.el6.x86_64 (@dell-omsa-indep)
                libdchbas.so.7()(64bit)
            Updated By: srvadmin-hapi-8.1.0-4.10.2.el6.x86_64 (dell-omsa-specific)
                Not found

Can someone explain why the 8.1 version of srvadmin-hapi (coming from 
dell-omsa-specific rather than -indep) is missing the requisite files?  Or 
am I just missing something mentally? (-:

With thanks,

Ben
-- 
Unix Support, UIS, University of Cambridge, England



More information about the Linux-PowerEdge mailing list