[Linux-PowerEdge] OMSA8.1 on RHEL/CentOS 7.1 workaround

Alain Péan alain.pean at lpn.cnrs.fr
Wed May 6 04:15:03 CDT 2015


Le 05/05/2015 21:59, Manuel Mausz a écrit :
>   patch the LSI middleware to read an alternate sysfs attribute. e.g to
> read/sys/.../megaraid_sas/version instead:
>> >sed -i -e 's/\x00release_date\x00/\x00version\x00\x00\x00\x00\x00\x00/' /opt/dell/srvadmin/lib64/libstorelib.so.4.20.1-0
> Binary patching is the workaround I'm recommending. It's the easiest
> one. However whichever workaround you choose make sure to restart the
> datamgrd service afterwards so changes take effect.

Hi Manuel,

Thanks for sharing. I tried your recommended workaround (sed command on 
libstorelib.so.4.20.1-0, after backup original version), and indeed it 
works on my PE R710, with Perc 6/i. I restarted the service 'dataeng'. 
Previously, I had the message 'no controller found'. Now it is :

# omreport storage controller
  Controller  PERC 6/i Integrated(Embedded)

Controller
ID                                            : 0
Status                                        : Ok
Name                                          : PERC 6/i Integrated

I hope it will be included in future versions of OMSA 8.x.

Thanks a lot !

Alain

-- 
Administrateur Système/Réseau
Laboratoire de Photonique et Nanostructures (LPN/CNRS - UPR20)
Centre de Recherche Alcatel Data IV - Marcoussis
route de Nozay - 91460 Marcoussis
Tel : 01-69-63-61-34

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20150506/d3e65732/attachment.html 


More information about the Linux-PowerEdge mailing list