[Linux-PowerEdge] Dell m620: 10GBit Interfaces not working after update to FC22/ kernel 4.1.x. BNA driver issue

Michael Beckstette Michael.Beckstette at helmholtz-hzi.de
Fri Aug 21 09:43:43 CDT 2015


Dear all,

probably someone here encountered the same issue. After an update of one 
of our Dell m620 blades from Fedora C20 (kernel 3.19) to Fedora C22 
(kernel 4.1.x) I cannot see my 10GBit NIC devices (Broadcom BCM57810 
(now QLogic)) anymore and get an error when loading the bna device 
driver: "BNA: Initialization failed err=1"

output of 'modinfo bna':
filename: 
/lib/modules/4.1.5-200.fc22.x86_64/kernel/drivers/net/ethernet/brocade/bna/bna.ko.xz
firmware:       ct2fw-3.2.5.1.bin
firmware:       ctfw-3.2.5.1.bin
version:        3.2.25.1
description:    QLogic BR-series 10G PCIe Ethernet driver
license:        GPL
author:         Brocade
srcversion:     2A727BEFFF854CF1085DE30
alias:          pci:v00001657d00000022sv*sd*bc02sc00i*
alias:          pci:v00001657d00000014sv*sd*bc02sc00i*
depends:
intree:         Y
vermagic:       4.1.5-200.fc22.x86_64 SMP mod_unload
signer:         Fedora kernel signing key
sig_key: 7F:47:BD:38:A5:EA:58:EA:CE:D5:58:3F:6E:C3:84:99:26:DD:D1:55
sig_hashalgo:   sha256
parm:           bnad_msix_disable:Disable MSIX mode (uint)
parm:           bnad_ioc_auto_recover:Enable / Disable auto recovery (uint)
parm:           bna_debugfs_enable:Enables debugfs feature, default=1, 
Range[false:0|true:1] (uint)

As far as I know this is the latest driver and firmware available

dmesg output:
[    7.937607] QLogic BR-series 10G Ethernet driver - version: 3.2.25.1
[    7.937624] bnad_pci_probe : (0xffff881ff86ab000, 0xffffffffa03d20c0) 
PCI Func : (2)
[    7.944164] iTCO_vendor_support: vendor-support=0
[    7.946442] iTCO_wdt: Intel TCO WatchDog Timer Driver v1.11
[    7.946472] iTCO_wdt: Found a Patsburg TCO device (Version=2, 
TCOBASE=0x0860)
[    7.946570] iTCO_wdt: initialized. heartbeat=30 sec (nowayout=0)
[    7.993157] bar0 mapped to ffffc9000d100000, len 262144
[    7.993431] BNA: Initialization failed err=1  <------------ HERE IS 
THE ERROR!!!!
[    7.993453] bnad_pci_probe : (0xffff881ff86ac000, 0xffffffffa03d20c0) 
PCI Func : (3)
[    7.993859] bar0 mapped to ffffc9000d180000, len 262144
[    7.994075] BNA: Initialization failed err=1 <------------HERE IS THE 
ERROR!!!!
[    8.010434] pps_core: LinuxPPS API ver. 1 registered
[    8.010436] pps_core: Software ver. 5.3.6 - Copyright 2005-2007 
Rodolfo Giometti <giometti at linux.it>
[    8.012430] PTP clock support registered
[    8.056402] bnx2x: Broadcom NetXtreme II 5771x/578xx 10/20-Gigabit 
Ethernet Driver bnx2x 1.710.51-0 (2014/02/10)
[    8.056472] bnx2x 0000:01:00.0: msix capability found
[    8.056623] bnx2x 0000:01:00.0: part number 
394D4342-31383735-30315430-473030
[    8.127040] bnx2x 0000:01:00.1: msix capability found
[    8.127186] bnx2x 0000:01:00.1: part number 
394D4342-31383735-30315430-473030
[    8.170790] Adding 32767996k swap on 
/dev/mapper/fedora_bioinf011-swap.  Priority:-1 extents:1 
across:32767996k FS
[    8.375611] EXT4-fs (sda1): mounting ext2 file system using the ext4 
subsystem
[    8.382821] systemd-journald[767]: Received request to flush runtime 
journal from PID 1
[    8.609281] EXT4-fs (sda1): mounted filesystem without journal. Opts: 
(null)
[    9.108858] EXT4-fs (dm-2): mounted filesystem with ordered data 
mode. Opts: (null)
[    9.282803] bnx2x 0000:01:00.0 em1: renamed from eth0
[    9.426793] bnx2x 0000:01:00.1 em2: renamed from eth1

in the ifconfig output I see only lo,em1 and em2 from the two onboard 
NICs managed by driver bnx2x. The two 10GBit interfaces p3p1_2 and 
p3p2_2 are missing.

Remark: If I boot exactly the same machine with kernel 3.19 everything 
is ok.


Any idea?

Best regards,
Michael




More information about the Linux-PowerEdge mailing list