[Linux-PowerEdge] DSU repository: June 2015

vincent at cojot.name vincent at cojot.name
Wed Aug 12 15:17:59 CDT 2015


Hi everyone,
Is there a workaround at all? I see this issue still happening with the 
latest repo:

# dsu
terminate called after throwing an instance of 'xercesc_3_1::TranscodingException'
Aborted
# rpm -q dell-system-update
dell-system-update-1.1-15.07.00.x86_64

I've noticed that the value of MALLOC_PERTURB_ seems to have an impact on 
being able to start dsu at all but I have not yet found a way to make it 
work..

Vincent S. Cojot

On Fri, 26 Jun 2015, Peter Holl wrote:

> Hello Kilian and Soorej,
>
> for me there was a period from last weekend until Wednesday (I didn't try 
> yesterday), when dsu suddenly worked again. This afternoon it crashed again, 
> while right now it didn't.
>
> If it crashed on one of my machines, it crashes on all I tried, and if it 
> worked it worked on all.
>
>
> I hope my observation can help to resolve that problem.
>
>
> Cheerio,
> Peter
>
> On 6/26/15 7:34 PM, Kilian Cavalotti wrote:
>> Hi Soorej,
>> 
>> On Thu, Jun 25, 2015 at 5:07 AM,  <Soorej_Ponnandi at dell.com> wrote:
>>>     Thanks for confirming the xerces bug. As we understand, this issue is
>>> intermittent, hence not getting reproduced in our environment.
>> It doesn't seem to be intermittent at all. The crash is pretty
>> consistent across all the machines I tested, which are all in
>> different environments, using various versions of Red Hat and CentOS.
>> It could very well be that you have a more recent version of Xerces-C
>> installed on your test machines, and that this one is picked up by dsu
>> instead of the one that is shipped in the dell-system-update RPM. A
>> different LD_LIBRARY_PATH that doesn't list /ust/local first could
>> easily explain that.
>> 
>> Cheers,
>
>



More information about the Linux-PowerEdge mailing list