[Linux-PowerEdge] BMC and NIC #1 interaction

Ruben Laban r.laban+lists at ism.nl
Wed Aug 5 08:14:16 CDT 2015


Hi,

Today I ran into a nice challenge. I wanted to do a "ip link set em2 
down", but made a slight typo and did a "ip link set em1 down" instead.

Unfortunately, at this point em1 was the only interface with an IP 
configured and thus lost my SSH connection. Luckily I had finally 
managed to get SOL console redirection operational. However, when I 
tried to open SOL connection all I got was timeouts. It seemed that the 
BMC had dropped off the network as well. Once I got a colleague to bring 
up em1 again, the BMC also started working again.

Is this expected behavior??

The hardware in question is a R210-II and both BMC and em1 where 
configured to use DHCP within an untagged VLAN.

It also isn't the first time I ran into more or less similar issues with 
BMC/(i)DRAC connectivity using shared ports:

* With ESXi 3.5 the default driver would kill the connectivity of the 
(i)DRAC when using a shared port. A newer driver became available which 
solved this issue. This was on a handful of PE2950s.
* On a set of PE860s I could not have the BMC use a tagged VLAN if that 
VLAN was also configured on eth0/em1 it shared the port with.

Most of these cases can be worked around by using a dedicated port 
instead of shared port. But that obviously only applies to (i)DRACs and 
not the good ol' BMC. And for a simple R210-II an iDRAC Enterprise is 
rather silly as it's more expensive than the server itself basically. 
And iDRAC Express is so limited that it's hard to warrant its costs as well.

Regards,
Ruben Laban



More information about the Linux-PowerEdge mailing list