[Linux-PowerEdge] rhel 5.10 i386 dell_ie_nic_qlogic

Palko Jukka jukka.palko at medbit.fi
Wed Sep 24 05:49:51 CDT 2014


[root at atasl81 ~]# yum install $(bootstrap_firmware)
...
Resolving Dependencies
--> Running transaction check
---> Package 12G_SEP_Firmware_componentid_26018.noarch 5:a00-1 set to be 
updated
---> Package 
57810S_DP_10G_KR_Mezz_ven_0x14e4_dev_0x168e_subven_0x14e4_subdev_0x1007.noarch 
5:7.8.53-1 set to be updated
--> Processing Dependency: dell_ie_module(BROADCOM_FRMW) for package: 
57810S_DP_10G_KR_Mezz_ven_0x14e4_dev_0x168e_subven_0x14e4_subdev_0x1007
---> Package 
57810S_DP_bNDC_KR_ven_0x14e4_dev_0x168e_subven_0x1028_subdev_0x1f5f.noarch 
5:7.8.53-1 set to be updated
---> Package 
Enterprise_UEFI_Diagnostics_componentid_25806_for_system_ven_0x1028_dev_0x04db.noarch 
5:4241.1-1 set to be updated
--> Processing Dependency: dell_ie_module(MASER_DIAGS) for package: 
Enterprise_UEFI_Diagnostics_componentid_25806_for_system_ven_0x1028_dev_0x04db
---> Package 
FC8_Embedded_Mezz_Card_QME2572_ven_0x1077_dev_0x2532_subven_0x1077_subdev_0x0167.noarch 
5:6.0.0.8-1 set to be updated
--> Processing Dependency: dell_ie_module(QLOGIC_FRMW) for package: 
FC8_Embedded_Mezz_Card_QME2572_ven_0x1077_dev_0x2532_subven_0x1077_subdev_0x0167
---> Package 
Lifecycle_Controller_componentid_28897_for_system_ven_0x1028_dev_0x04db.noarch 
5:a00-1 set to be updated
--> Processing Dependency: dell_ie_module(MASER_USC) for package: 
Lifecycle_Controller_componentid_28897_for_system_ven_0x1028_dev_0x04db
---> Package 
OS_Drivers_Pack_componentid_18981_for_system_ven_0x1028_dev_0x04db.noarch 5:a00-1 
set to be updated
--> Processing Dependency: dell_ie_module(MASER_DP) for package: 
OS_Drivers_Pack_componentid_18981_for_system_ven_0x1028_dev_0x04db
---> Package 
PERC_H310_Mini_Blade_ven_0x1000_dev_0x0073_subven_0x1028_subdev_0x1f50.noarch 
5:a08-1 set to be updated
---> Package Savvio_15K_3_146GB_SAS_15K_RPM_componentid_25851.noarch 
5:a07-1 set to be updated
---> Package 
Server_BIOS_12G_componentid_00159_for_system_ven_0x1028_dev_0x04db.noarch 5:2.2.10-1 
set to be updated
---> Package 
iDRAC7_componentid_25227_for_system_ven_0x1028_dev_0x04db.noarch 5:a00-1 
set to be updated
--> Running transaction check
---> Package dell_ie_maser_diags.i386 0:3.2.0-4.130.2.el5 set to be updated
---> Package dell_ie_maser_dp.i386 0:3.2.0-4.130.2.el5 set to be updated
---> Package dell_ie_maser_usc.i386 0:3.2.0-4.130.2.el5 set to be updated
---> Package dell_ie_nic_broadcom.i386 0:1.1.0-8 set to be updated
---> Package dell_ie_nic_qlogic.i386 0:1.1.0-7 set to be updated
--> Processing Dependency: libscixicli.so(VERS1.1) for package: 
dell_ie_nic_qlogic
--> Processing Dependency: libncli.so(VERS1.1) for package: 
dell_ie_nic_qlogic
--> Finished Dependency Resolution
dell_ie_nic_qlogic-1.1.0-7.i386 from dell-omsa-indep has depsolving problems
   --> Missing Dependency: libncli.so(VERS1.1) is needed by package 
dell_ie_nic_qlogic-1.1.0-7.i386 (dell-omsa-indep)
dell_ie_nic_qlogic-1.1.0-7.i386 from dell-omsa-indep has depsolving problems
   --> Missing Dependency: libscixicli.so(VERS1.1) is needed by package 
dell_ie_nic_qlogic-1.1.0-7.i386 (dell-omsa-indep)
Error: Missing Dependency: libscixicli.so(VERS1.1) is needed by package 
dell_ie_nic_qlogic-1.1.0-7.i386 (dell-omsa-indep)
Error: Missing Dependency: libncli.so(VERS1.1) is needed by package 
dell_ie_nic_qlogic-1.1.0-7.i386 (dell-omsa-indep)
  You could try using --skip-broken to work around the problem
  You could try running: package-cleanup --problems
                         package-cleanup --dupes
                         rpm -Va --nofiles --nodigest

Well, checking on our other machines, it's provided by the 
dell_ie_nic_qlogic package, so let's test this:
# rpm -ivh --nodeps dell_ie_nic_qlogic-1.1.0-7.i386.rpm
Preparing... ########################################### [100%]
    1:dell_ie_nic_qlogic ########################################### [100%]
ln: creating symbolic link 
`/usr/libexec/dell_dup//dell_ie_nic_qlogic-1.1.0/UpdRollBack' to 
`/usr/libexec/dell_dup/dell_ie_bios/UpdRollBack': File exists
# updatedb
# locate libscixicli.so
/usr/libexec/dell_dup/dell_ie_nic_qlogic-1.1.0/linux/libscixicli.so
# locate libncli.so
/usr/libexec/dell_dup/dell_ie_nic_qlogic-1.1.0/linux/libncli.so
# rpm -qf 
/usr/libexec/dell_dup/dell_ie_nic_qlogic-1.1.0/linux/libscixicli.so
dell_ie_nic_qlogic-1.1.0-7
# rpm -qf /usr/libexec/dell_dup/dell_ie_nic_qlogic-1.1.0/linux/libncli.so
dell_ie_nic_qlogic-1.1.0-7
# rpm -ivh dell_ie_nic_qlogic-1.1.0-7.i386.rpm
error: Failed dependencies:
     libncli.so(VERS1.1) is needed by dell_ie_nic_qlogic-1.1.0-7.i386
     libscixicli.so(VERS1.1) is needed by dell_ie_nic_qlogic-1.1.0-7.i386
# rpm -q --provides dell_ie_nic_qlogic
./libncli.so(VERS1.1)
./libscixicli.so(VERS1.1)
dell_ie_module(QLOGIC_FRMW)
libHBAAPI.so
libfcapi.so
libfcapi.so(VERS1.1)
libildapi.so
libncli.so
libqlsdm.so
libqsw.so
libqswopenssl.so
libqswstubssl.so
libscixicli.so
dell_ie_nic_qlogic = 1.1.0-7

Could you fix this i386 package? Looks like a very small typo in the 
SPEC. Can I download a fixed version from somewhere?


Best regards,
    Jukka Palko

-- 
Jukka Palko
Järjestelmäasiantuntija, DBA
050 430 3534
Medbit Oy / Linux-tiimi

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20140924/0c5f7155/attachment.html 


More information about the Linux-PowerEdge mailing list