[Linux-PowerEdge] PERC Update performed but not noticed?

Supporto Tecnico - Crazy Network support at crazynetwork.it
Fri Oct 17 09:00:17 CDT 2014


Ok, so i do have to do something by myself or is a repo-side error/mismatch?

Regards and thanks

Il 17/10/2014 15:48, Tim Bosua ha scritto:
> There is a difference in the version;
>
> Checking PERC 6/i Integrated Controller 0 Firmware - *6.3.3.0002*
> Available: 
> pci_firmware(ven_0x1000_dev_0x0060_subven_0x1028_subdev_0x1f0c) - 
> *6.3.3-0002*
>
> Note the dot and the dash.
>
>
> Met vriendelijke groet/Kind regards,
>
> *Tim Bosua*
> Senior System Administrator
>
> Hostnet <https://www.hostnet.nl/>
>
> Hostnet bv
> De Ruyterkade 6 | 1013 AA Amsterdam
> T: 020-7500800 | F: 020-7500825
> www.hostnet.nl <https://www.hostnet.nl/> | weblog.hostnet.nl 
> <http://weblog.hostnet.nl/>
>
> Facebook <https://nl-nl.facebook.com/Hostnetbv> Twitter 
> <https://twitter.com/Hostnet> Linkedin 
> <https://www.linkedin.com/company/hostnet-bv>
>
> On 17 Oct 2014, at 15:44, Supporto Tecnico - Crazy Network 
> <support at crazynetwork.it <mailto:support at crazynetwork.it>> wrote:
>
>> Hi,
>>
>> i'm facing a strange issue on different servers, i'd update firmwares 
>> correctly but if i check update_firmware update, it always show an 
>> update for PERC firmware (with same version)
>>
>> Checking PERC 6/i Integrated Controller 0 Firmware - 6.3.3.0002
>>         Available: 
>> pci_firmware(ven_0x1000_dev_0x0060_subven_0x1028_subdev_0x1f0c) - 
>> 6.3.3-0002
>>         Found Update: 
>> pci_firmware(ven_0x1000_dev_0x0060_subven_0x1028_subdev_0x1f0c) - 
>> 6.3.3-0002
>>
>>
>> If i run the update in verbose mode this is the output:
>>
>> Checking Plugin (bootstrap_pci)
>>         Loaded bootstrap_pci plugin
>> Checking Plugin (bootstrap_cmd)
>>         Loaded bootstrap_cmd plugin
>> Checking Plugin (mock_inventory_bootstrap)
>>         Plugin mock_inventory_bootstrap not loaded: doesnt match load 
>> type ((4,))
>> Checking Plugin (dell_ft_ie_interface)
>>         Loaded dell_ft_ie_interface plugin
>> Checking Plugin (update_cmd)
>>         Loaded update_cmd plugin
>> Checking Plugin (listplugins_cmd)
>>         Loaded listplugins_cmd plugin
>> Checking Plugin (dellbios)
>>         Loaded dellbios plugin
>> Checking Plugin (mock_repository)
>>         Plugin mock_repository not loaded: doesnt match load type ((4,))
>> Checking Plugin (inventory_cmd)
>>         Loaded inventory_cmd plugin
>> Checking Plugin (dellbios_extract)
>>         Plugin raised DisablePlugin exception. skipping.
>>
>> Running system inventory...
>> verobse INFO: hi there
>> Running IE Submodule for /usr/libexec/dell_dup/dell_ie_pcissd
>>         Plugin command is pcissd -i -o inv.xml
>>         Output file is inv.xml
>>         Plugin timeout is 600
>> output from the cmd was:
>> <?xml version="1.0" encoding="UTF-8"?><SVMInventory 
>> lang="en"></SVMInventory>
>> Running IE Submodule for /usr/libexec/dell_dup/dell_ie_maser_ic
>>         Module not for this system, disabling module.
>> Running IE Submodule for /usr/libexec/dell_dup/dell_ie_ps
>>         Plugin command is psdup -i -o=inv.xml
>>         Output file is inv.xml
>>         Plugin timeout is 1200
>> output from the cmd was:
>> <?xml version="1.0" encoding="UTF-8" ?><SVMInventory 
>> lang="en"><SPStatus result="false"><Message id="2"> Update Failure: 
>> Unified Server Configurator Failure - USC is not present or is 
>> broken</Message></SPStatus></SVMInventory>
>>
>>
>>
>> Running IE Submodule for /usr/libexec/dell_dup/dell_ie_rac_5
>>         Plugin command is svm.sh -i -o inv.xml
>>         Output file is inv.xml
>>         Plugin timeout is 300
>> output from the cmd was:
>> <?xml version="1.0" encoding="UTF-8" ?>
>> <SVMInventory lang="en">
>>   <Device componentID="8735" display="DRAC 5">
>>     <Application componentType="FRMW" version="1.65" display="DRAC 5 
>> Firmware">
>>     </Application>
>>   </Device>
>> </SVMInventory>
>>
>> Added DEVICE: dell_dup_componentid_08735
>> Running IE Submodule for /usr/libexec/dell_dup/dell_ie_nitrogen
>>         Module not for this system, disabling module.
>> Running IE Submodule for /usr/libexec/dell_dup/dell_ie_sas
>>         Plugin command is sasdupie.sh -i -o inv.xml
>>         Output file is inv.xml
>>         Plugin timeout is 600
>> output from the cmd was:
>> <?xml version="1.0" encoding="UTF-8"?><SVMInventory lang="en"><Device 
>> vendorID="1000" deviceID="0060" subDeviceID="1f0c" subVendorID="1028" 
>> bus="1" device="0" function="0" display="PERC 6/i Integrated 
>> Controller 0" impactsTPMmeasurements="TRUE"><Application 
>> componentType="FRMW" version="6.3.3.0002" display="PERC 6/i 
>> Integrated Controller 0 Firmware"/></Device><Device 
>> componentID="00000" enum="CtrlId 0 DeviceId 0" display="ST1000LM024 
>> HN-M"><Application componentType="FRMW" version="0001" 
>> display="ST1000LM024 HN-M Firmware"/></Device><Device 
>> componentID="00000" enum="CtrlId 0 DeviceId 1" display="SAMSUNG 
>> HN-M101M"><Application componentType="FRMW" version="0001" 
>> display="SAMSUNG HN-M101M Firmware"/></Device><Device 
>> componentID="00000" enum="CtrlId 0 DeviceId 2" display="SAMSUNG 
>> HN-M101M"><Application componentType="FRMW" version="0001" 
>> display="SAMSUNG HN-M101M Firmware"/></Device><Device 
>> componentID="00000" enum="CtrlId 0 DeviceId 3" display="SAMSUNG 
>> HN-M101M"><Application componentType="FRMW" version="0001" 
>> display="SAMSUNG HN-M101M Firmware"/></Device><Device 
>> componentID="00000" enum="CtrlId 0 DeviceId 4" display="ST1000LM024 
>> HN-M"><Application componentType="FRMW" version="0002" 
>> display="ST1000LM024 HN-M Firmware"/></Device><Device 
>> componentID="00000" enum="CtrlId 0 DeviceId 5" display="ST1000LM024 
>> HN-M"><Application componentType="FRMW" version="0002" 
>> display="ST1000LM024 HN-M Firmware"/></Device><Device 
>> componentID="00000" enum="CtrlId 0 DeviceId 6" display="ST1000LM024 
>> HN-M"><Application componentType="FRMW" version="0002" 
>> display="ST1000LM024 HN-M Firmware"/></Device><Device 
>> componentID="00000" enum="CtrlId 0 DeviceId 7" display="ST1000LM024 
>> HN-M"><Application componentType="FRMW" version="0002" 
>> display="ST1000LM024 HN-M Firmware"/></Device><Device 
>> componentID="11204" enum="CtrlId 0 DeviceId 20 Backplane" 
>> display="SAS/SATA Backplane 0:0 Backplane"><Application 
>> componentType="FRMW" version="1.05" display="SAS/SATA Backplane 0:0 
>> Backplane Firmware"/></Device></SVMInventory>
>> Added DEVICE: 
>> pci_firmware(ven_0x1000_dev_0x0060_subven_0x1028_subdev_0x1f0c)
>> Added DEVICE: dell_dup_componentid_00000
>> Added DEVICE: dell_dup_componentid_00000
>> Added DEVICE: dell_dup_componentid_00000
>> Added DEVICE: dell_dup_componentid_00000
>> Added DEVICE: dell_dup_componentid_00000
>> Added DEVICE: dell_dup_componentid_00000
>> Added DEVICE: dell_dup_componentid_00000
>> Added DEVICE: dell_dup_componentid_00000
>> Added DEVICE: dell_dup_componentid_11204
>> Running IE Submodule for /usr/libexec/dell_dup/dell_ie_nvme_pcissd
>>         Plugin command is nvme_pcissd -i -o inv.xml
>>         Output file is inv.xml
>>         Plugin timeout is 600
>> output from the cmd was:
>> <?xml version="1.0" encoding="UTF-8"?><SVMInventory 
>> lang="en"></SVMInventory>
>> Running IE Submodule for /usr/libexec/dell_dup/dell_ie_idrac7
>>         Module not for this system, disabling module.
>> Running IE Submodule for /usr/libexec/dell_dup/dell_ie_imc
>>         Module not for this system, disabling module.
>> Running IE Submodule for /usr/libexec/dell_dup/dell_ie_tape_quantum-1.1.0
>>         Plugin command is pvtapeupgwrapper -c
>>         Output file is scsiInv.txt
>>         Plugin timeout is 500
>> output from the cmd was:
>> <?xml version="1.0" encoding="UTF-8"?>
>> <SVMInventory lang="en">
>> </SVMInventory>
>>
>> Running IE Submodule for /usr/libexec/dell_dup/dell_ie_tape_ibm-1.1.0
>>         Plugin command is IbmDupwrapper -silent
>>         Output file is scsiInv.txt
>>         Plugin timeout is 500
>> output from the cmd was:
>> <?xml version="1.0" encoding="UTF-8"?>
>> <SVMInventory lang="en">
>> </SVMInventory>
>>
>> Running IE Submodule for /usr/libexec/dell_dup/dell_ie_nic_broadcom-1.1.0
>>         Plugin command is dup_inv
>>         Output file is brcmfwinventory.xml
>>         Plugin timeout is 300
>> output from the cmd was:
>> <?xml version="1.0" encoding="UTF-8"?>
>> <SVMInventory lang="en">
>>         <Device vendorID="14e4" deviceID="164c" subVendorID="1028" 
>> subDeviceID="01b2" bus="3" device="0" function="0" display="NetXtreme 
>> II BCM5708 Gigabit Ethernet rev 12 (eth0)">
>>                 <Application componentType="FRMW" version="7.10.17" 
>> display="NetXtreme II BCM5708 Gigabit Ethernet rev 12 (eth0)" />
>>         </Device>
>>         <Device vendorID="14e4" deviceID="164c" subVendorID="1028" 
>> subDeviceID="01b2" bus="7" device="0" function="0" display="NetXtreme 
>> II BCM5708 Gigabit Ethernet rev 12 (eth1)">
>>                 <Application componentType="FRMW" version="7.10.17" 
>> display="NetXtreme II BCM5708 Gigabit Ethernet rev 12 (eth1)" />
>>         </Device>
>> </SVMInventory>
>>
>> Added DEVICE: 
>> pci_firmware(ven_0x14e4_dev_0x164c_subven_0x1028_subdev_0x01b2)
>> Added DEVICE: 
>> pci_firmware(ven_0x14e4_dev_0x164c_subven_0x1028_subdev_0x01b2)
>> Running IE Submodule for /usr/libexec/dell_dup/dell_ie_bios
>>         Plugin command is biosie.sh -i inv.xml
>>         Output file is inv.xml
>>         Plugin timeout is 300
>> output from the cmd was:
>> <?xml version="1.0" encoding="UTF-8" ?><SVMInventory 
>> lang="en"><Device componentID= "159" display="BIOS" 
>> impactsTPMmeasurements="TRUE"><Application componentType= "BIOS" 
>> version="2.7.0" display = "BIOS" /></Device></SVMInventory>
>> Added DEVICE: dell_dup_componentid_00159
>>
>> Searching storage directory for available BIOS updates...
>> Checking SAS/SATA Backplane 0:0 Backplane Firmware - 1.05
>>         Available: dell_dup_componentid_11204 - 1.05
>>         Did not find a newer package to install that meets all 
>> installation checks.
>> Checking NetXtreme II BCM5708 Gigabit Ethernet rev 12 (eth0) - 7.10.17
>>         Available: 
>> pci_firmware(ven_0x14e4_dev_0x164c_subven_0x1028_subdev_0x01b2) - 7.10.17
>>         Did not find a newer package to install that meets all 
>> installation checks.
>> Checking PERC 6/i Integrated Controller 0 Firmware - 6.3.3.0002
>>         Available: 
>> pci_firmware(ven_0x1000_dev_0x0060_subven_0x1028_subdev_0x1f0c) - 
>> 6.3.3-0002
>>         Found Update: 
>> pci_firmware(ven_0x1000_dev_0x0060_subven_0x1028_subdev_0x1f0c) - 
>> 6.3.3-0002
>> Checking NetXtreme II BCM5708 Gigabit Ethernet rev 12 (eth1) - 7.10.17
>>         Available: 
>> pci_firmware(ven_0x14e4_dev_0x164c_subven_0x1028_subdev_0x01b2) - 7.10.17
>>         Did not find a newer package to install that meets all 
>> installation checks.
>> Checking BIOS - 2.7.0
>>         Available: dell_dup_componentid_00159 - 2.7.0
>>         Did not find a newer package to install that meets all 
>> installation checks.
>> Checking System BIOS for PowerEdge 2950 - 2.7.0
>>         Did not find a newer package to install that meets all 
>> installation checks.
>> Checking DRAC 5 Firmware - 1.65
>>         Available: dell_dup_componentid_08735 - 1.65
>>         Did not find a newer package to install that meets all 
>> installation checks.
>> Checking ST1000LM024 HN-M Firmware - 0002
>>         Did not find a newer package to install that meets all 
>> installation checks.
>>
>> Found firmware which needs to be updated.
>>
>> Running updates...
>> hey, we are supposed to be installing now... :)
>> -       Installing 
>> pci_firmware(ven_0x1000_dev_0x0060_subven_0x1028_subdev_ ...loading 
>> xml from: /usr/libexec/dell_dup/PERC6_PERC/PIEConfig.xml
>> loaded.
>>         Plugin command is sasdupie -u -f -o update.xml
>>         Output file is update.xml
>>         Plugin timeout is 9900
>> |       Installing 
>> pci_firmware(ven_0x1000_dev_0x0060_subven_0x1028_subdev_ ...output 
>> from the cmd was:
>> <?xml version="1.0" encoding="UTF-8"?><SVMExecution lang="en"><Device 
>> vendorID="1000" deviceID="0060" subDeviceID="1f0c" subVendorID="1028" 
>> bus="1" device="0" function="0" display="PERC 6/i Integrated 
>> Controller 0"><Application componentType="FRMW" version="6.3.3.0002" 
>> display="PERC 6/i Integrated Controller 0 Firmware"><Package 
>> version="6.3.3.0002"/><SPStatus result="true"><Message id="0">The 
>> operation was successful. 
>> </Message></SPStatus></Application></Device><RebootRequired>1</RebootRequired></SVMExecution>
>>  100% Installing 
>> pci_firmware(ven_0x1000_dev_0x0060_subven_0x1028_subdev_0x1f0c) - 
>> 6.3.3-0002
>> Done: The operation was successful. You must perform a reboot for the 
>> update to take effect.
>>
>> Complete!
>>
>>
>> Does you have any hint to try or is a bug on repository side?
>>
>> Regards
>>
>> -- 
>> Andrea Iannucci
>> ----------------------------
>> <hdefgghd.gif>
>> ----------------------------
>> Crazy Network di Iannucci Andrea
>> Viale G.B. Pergolesi, 1
>> 00052 Cerveteri - RM
>> (w) www.crazynetwork.it
>> (e) andrea.iannucci at crazynetwork.it
>> (t) +39 06 62279876
>> (f) +39 06 62298767
>> (m) +39 338 8552885
>>
>> -------------------------------------------------------------------------------
>> Please consider our enviromental responsabilità before printing this 
>> E-Mail. Thank you.
>> -------------------------------------------------------------------------------
>> Questo messaggio di posta elettronica contiene informazioni di 
>> carattere confidenziale rivolte esclusivamente al destinatario sopra 
>> indicato.
>> E' vietato l'uso, la diffusione, distribuzione o riproduzione da 
>> parte di ogni altra persona. Nel caso aveste ricevuto questo 
>> messaggio di posta elettronica per errore, siete pregati di 
>> segnalarlo immediatamente al mittente e distruggere quanto ricevuto 
>> (compresi i file allegati) senza farne copia.
>> Qualsivoglia utilizzo non autorizzato del contenuto di questo 
>> messaggio costituisce violazione dell'obbligo di non prendere 
>> cognizione della corrispondenza tra altri soggetti, salvo più grave 
>> illecito, ed espone il responsabile alle relative conseguenze.
>> --------------------------------------------------------------------------------
>> This e-mail is confidential and may also contain privileged 
>> information. If you are not the intended recipient you are not 
>> authorised to read, print, save, process or disclose this message. If 
>> you have received this message by mistake, please inform the sender 
>> immediately and delete this e-mail, its attachments and any copies.
>> Any use, distribution, reproduction or disclosure by any person other 
>> than the intended recipient is strictly prohibited and the person 
>> responsible may incur penalties.
>> -------------------------------------------------------------------------------- 
>>
>>
>> _______________________________________________
>> Linux-PowerEdge mailing list
>> Linux-PowerEdge at dell.com <mailto:Linux-PowerEdge at dell.com>
>> https://lists.us.dell.com/mailman/listinfo/linux-poweredge
>


-- 
Andrea Iannucci
----------------------------

----------------------------
Crazy Network di Iannucci Andrea
Viale G.B. Pergolesi, 1
00052 Cerveteri - RM
(w) www.crazynetwork.it
(e) andrea.iannucci at crazynetwork.it
(t) +39 06 62279876
(f) +39 06 62298767
(m) +39 338 8552885

-------------------------------------------------------------------------------
Please consider our enviromental responsabilità before printing this 
E-Mail. Thank you.
-------------------------------------------------------------------------------
Questo messaggio di posta elettronica contiene informazioni di carattere 
confidenziale rivolte esclusivamente al destinatario sopra indicato.
E' vietato l'uso, la diffusione, distribuzione o riproduzione da parte 
di ogni altra persona. Nel caso aveste ricevuto questo messaggio di 
posta elettronica per errore, siete pregati di segnalarlo immediatamente 
al mittente e distruggere quanto ricevuto (compresi i file allegati) 
senza farne copia.
Qualsivoglia utilizzo non autorizzato del contenuto di questo messaggio 
costituisce violazione dell'obbligo di non prendere cognizione della 
corrispondenza tra altri soggetti, salvo più grave illecito, ed espone 
il responsabile alle relative conseguenze.
--------------------------------------------------------------------------------
This e-mail is confidential and may also contain privileged information. 
If you are not the intended recipient you are not authorised to read, 
print, save, process or disclose this message. If you have received this 
message by mistake, please inform the sender immediately and delete this 
e-mail, its attachments and any copies.
Any use, distribution, reproduction or disclosure by any person other 
than the intended recipient is strictly prohibited and the person 
responsible may incur penalties.
-------------------------------------------------------------------------------- 


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20141017/d30222de/attachment-0001.html 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: hifjehhi.gif
Type: image/gif
Size: 2665 bytes
Desc: not available
Url : http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20141017/d30222de/attachment-0001.gif 


More information about the Linux-PowerEdge mailing list