[Linux-PowerEdge] PERC H700 activate disk without reboot

Alex Mestiashvili alex at biotec.tu-dresden.de
Sat Dec 20 10:46:07 CST 2014


Hi,

Yes, that is clear now, PERC H700 doesn't support non-raid 
configurations: 
http://www.dell.com/learn/us/en/04/campaigns/dell-raid-controllers.

Best,
Alex

On 12/19/2014 06:48 AM, George Machitidze wrote:
> Hi
>
> In my case all modules are owned by kernel-2.6.32-504.3.3.el6.x86_64.
> Still, as it was noted by Josh - disks must be members of array.
>
> [root at rhel6 ~]# modinfo megaraid_sas mpt2sas mptbase | egrep
> "^version|descr"
> description:    LSI MegaRAID SAS Driver
> version:        06.700.06.00-rh1
> version:        15.101.00.00
> description:    LSI MPT Fusion SAS 2.0 Device Driver
> version:        3.04.20
> description:    Fusion MPT base driver
>
> *George Machitidze*
>
>
>
> 2014-12-12 18:47 GMT+04:00 Alex Mestiashvili<alex at biotec.tu-dresden.de>:
>>   Hi George!
>>
>> the one shipped with linux-3.2.61:
>>
>> modinfo megaraid_sas mpt2sas mptbase | egrep "^version|descr"
>> description:    LSI MegaRAID SAS Driver
>> version:        00.00.06.12-rc1
>> description:    LSI MPT Fusion SAS 2.0 Device Driver
>> version:        10.100.00.00
>> description:    Fusion MPT base driver
>> version:        3.04.20
>>
>> Best regards,
>> Alex
>>
>>
>>
>> On 12/12/2014 03:28 PM, George Machitidze wrote:
>>
>> Hi Alex,
>>
>> Which versions of controller driver/packages have you installed?
>>
>> modinfo
>>
>> George Machitidze
>> 12 დეკ, 2014 18:25, "Alex Mestiashvili"<alex at biotec.tu-dresden.de>
>> დაწერა:
>>
>>> Hello,
>>>
>>> After inserting a new disk to Dell PE R710 with PERC H700 adapter I can
>>> see it via omreport or with megacli tool, but can not make it visible to
>>> the system - Debian Wheezy with kernel 3.2.61.
>>>
>>> After issuing host_rescan:
>>>
>>>    echo '- - -'  >/sys/class/scsi_host/host0/scan
>>>
>>> I see in dmesg that the disk is recognized by the kernel, but still do
>>> not see it in fdisk/lsblk.. output.
>>>
>>> I noticed that omreport shows the new disk status as Ready and not
>>> Online, but it seems that I can not change the status using omconfig:
>>>
>>>     omconfig  storage pdisk action=online controller=0 pdisk=1:0:4
>>>     Operation disabled. Read, action=online
>>>     Refer to the documentation for more information.
>>>
>>> megacli fails here too:
>>>
>>>     megacli -PDOnline -PhysDrv [32:4] -a0
>>>
>>>     Adapter: 0: Failed to change PD state at EnclId-32 SlotId-4.
>>>
>>>     Exit Code: 0x01
>>>
>>> Is there a way to activate the disk without rebooting the server ?
>>>
>>> Thank you,
>>> Alex
>>>
>>> _______________________________________________
>>> Linux-PowerEdge mailing list
>>> Linux-PowerEdge at dell.com
>>> https://lists.us.dell.com/mailman/listinfo/linux-poweredge
>>>



More information about the Linux-PowerEdge mailing list