[Linux-PowerEdge] Broadcom update is passing (Stefan M. Radman)

Palko Jukka jukka.palko at medbit.fi
Wed Apr 23 01:05:58 CDT 2014


Every update to the whole set of tools I keep getting back to the fact 
that this procedure works best for my servers to update OMSA and 
firmware packages:
yum -y remove $(bootstrap_firmware)
yum -y remove $(rpm -qa | grep srvadmin)
rm -rf /opt/dell/srvadmin /usr/libexec/dell_dup /usr/share/firmware/dell
yum -y install srvadmin-all srvadmin-cm dell_ft_install
yum -y install $(bootstrap_firmware)

Perhaps the first step isn't necessary separately as the second would 
clean them too but I just have ran the commands this way and it has 
worked for me. :) If I don't do this, some firmware packages do not get 
the newest rpm installed when updating via "yum update" or some xml or 
other file has faulty content even though there is no .rpmsave file present.

Thanks for finally producing the srvadmin-cm 64bit version though. :)

Tried for a test to run the firmware update without doing the steps 
above first but ran into this again:
-----------------------------------------------------------
Found firmware which needs to be updated.

Running updates...
/    Installing pci_firmware(ven_0x14e4_dev_0x168e_subven_0x1028_subdev_ 
...Installation failed for package: 
pci_firmware(ven_0x14e4_dev_0x168e_subven_0x1028_subdev_0x1f5f) - 7.8.53
aborting update...

The error message from the low-level command was:

Update failure. Firmware programming utility returned an error.
-----------------------------------------------------------

Additionally, there were more updates listed after running the steps 
than before running them.


-Jukka

On 04/23/2014 08:17 AM, Stefan M. Radman wrote:
> Any luck with uninstalling and re-installing firmware-tools, smbios and DUPs?
>
> Stefan
>
> Sent from my fingertips
>
>
> Am 23.04.2014 um 06:32 schrieb "Stéphane Rossan" <stephane.rossan at workday.com<mailto:stephane.rossan at workday.com>>:
>
> I have the same problem as Stephan. I can not upgrade Broadcom firmware with latest firmware snapshot.
> It seems any upgrade is impossible if current version is either 7.6.15 or 7.8.16, I don’t have the issue when the version is 7.2.20.
> -Stephane
> Stephane Rossan|Cloud Operations |Workday, Inc.|6230 Stoneridge Mall Road|Pleasanton, CA 94588|Mobile: 408.348.5103|Skype: stephane.rossan.workday|
>
>
>
>
> _______________________________________________
> Linux-PowerEdge mailing list
> Linux-PowerEdge at dell.com<mailto:Linux-PowerEdge at dell.com>
> https://lists.us.dell.com/mailman/listinfo/linux-poweredge
>
> _______________________________________________
> Linux-PowerEdge mailing list
> Linux-PowerEdge at dell.com
> https://lists.us.dell.com/mailman/listinfo/linux-poweredge

-- 
Jukka Palko
Järjestelmäasiantuntija, DBA
050 430 3534
Medbit Oy / Linux-tiimi



More information about the Linux-PowerEdge mailing list