[Linux-PowerEdge] insmo iqvlinux.ko

Tony Schreiner anthony.schreiner at bc.edu
Thu Apr 17 12:01:58 CDT 2014


On Apr 17, 2014, at 11:19 AM, lhecking at users.sourceforge.net wrote:

> Tony Schreiner writes:
>> In the last 2 days, 2 of my systems are writing the following into /dev/nul  (note the mis-spelling) when I boot.
>> 
>> insmod: can't read '/lib/modules/2.6.32-431.11.2.el6.x86_64/kernel/drivers/net/iqvlinux.ko': No such file or directory
>> 
>> What these 2 systems have in common, and differentiate from all my other systems is that I updated OMSA to 7.4.0-4.100.1. They are both CentOS 6.5.
>> 
>> 
>> I don't know for sure that srvadmin is writing this, I can't find any reference to iqvlinux.ko, nor to /dev/nul.  Is it possible though?
> 
> I don't know if this version of srvadmin really is the source of the kernel
> module - iqvlinux.ko is the "Intel QV Linux kernel driver" or Ethernet Adapter
> Debug driver. It is available on sourceforge and also comes with tools like
> Intel's BootUtil.
> 
> Does the problem go away if you run depmod?
> 

To follow up

I ran depmod, rebooted and the message appeared again.
I tested some more and the file gets created 0-3 minutes after I run

srvadmin-services.sh start

at the same time, the files deviceadd.evt, Inventory.xml.X InvLog.xml., caching.txt get written to 
/opt/dell/srvadmin/var/log/openmanage

I don't mind that it's trying to load a non-existent module, but there has to be a typo somewhere, that's writing to /dev/nul instead of /dev/null




More information about the Linux-PowerEdge mailing list