[Linux-PowerEdge] OMSA 7.4, DTK 4.4 and iSM 1.0 published for Ubuntu/Debian

D. Jared Dominguez Jared_Dominguez at dell.com
Wed Apr 9 10:28:30 CDT 2014


>To be clear, this did not work in 7.3.0 either and had the same XML error.
>I saw someone else had reported them same thing back in August 2013.

Sorry, still early for me. I missed that detail in your original 
message. So this doesn't sound like an upgrade issue.

Since you're using this system as a frontend, would it be feasible for 
you completely uninstall and reinstall OMSA on this VM? Also, before you 
do that, could you send me the contents of 
/opt/dell/srvadmin/lib/openmanage/apache-tomcat/conf minus the keystore* 
files?

--Jared


> here are the details:
>
>openmanage ~ # ls -ld /opt/dell/srvadmin/lib/openmanage/jre
>lrwxrwxrwx 1 root root 37 Apr  9 10:35
>/opt/dell/srvadmin/lib/openmanage/jre ->
>/usr/lib/jvm/java-7-openjdk-amd64/jre
>
>openmanage ~ # dpkg -S /opt/dell/srvadmin/lib/openmanage/jre
>srvadmin-jre: /opt/dell/srvadmin/lib/openmanage/jre
>
>openmanage ~ # cat /opt/dell/srvadmin/var/log/openmanage/dsm_om_connsvcdIO.log
>Apr 09, 2014 10:43:59 AM org.apache.tomcat.util.digester.SetPropertiesRule
>begin
>WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting
>property 'debug' to '0' did not find a matching property.
>Apr 09, 2014 10:44:00 AM org.apache.coyote.AbstractProtocol init
>INFO: Initializing ProtocolHandler ["http-bio-1311"]
>Apr 09, 2014 10:44:00 AM org.apache.catalina.startup.Catalina load
>INFO: Initialization processed in 1881 ms
>Apr 09, 2014 10:44:01 AM org.apache.catalina.core.StandardService
>startInternal
>INFO: Starting service Catalina
>Apr 09, 2014 10:44:01 AM org.apache.catalina.core.StandardEngine
>startInternal
>INFO: Starting Servlet Engine: Apache Tomcat/7.0.39
>Apr 09, 2014 10:44:05 AM org.apache.catalina.session.PersistentManagerBase
>startInternal
>SEVERE: No Store configured, persistence disabled
>Apr 09, 2014 10:44:05 AM org.apache.catalina.startup.HostConfig
>deployDirectory
>INFO: Deploying web application directory
>/opt/dell/srvadmin/lib/openmanage/apache-tomcat/webapps/omsa
>Apr 09, 2014 10:44:08 AM org.apache.catalina.startup.HostConfig
>deployDirectory
>INFO: Deploying web application directory
>/opt/dell/srvadmin/lib/openmanage/apache-tomcat/webapps/manager
>Apr 09, 2014 10:44:08 AM org.apache.catalina.startup.HostConfig
>deployDirectory
>INFO: Deploying web application directory
>/opt/dell/srvadmin/lib/openmanage/apache-tomcat/webapps/host-manager
>Apr 09, 2014 10:44:08 AM org.apache.coyote.AbstractProtocol start
>INFO: Starting ProtocolHandler ["http-bio-1311"]
>Apr 09, 2014 10:44:08 AM org.apache.catalina.startup.Catalina start
>INFO: Server startup in 7552 ms
>[Fatal Error] :1:44: XML document structures must start and end within the
>same entity.
>[Fatal Error] :1:44: XML document structures must start and end within the
>same entity.
>[Fatal Error] :1:44: XML document structures must start and end within the
>same entity.
>[Fatal Error] :1:44: XML document structures must start and end within the
>same entity.
>[Fatal Error] :1:44: XML document structures must start and end within the
>same entity.
>Thanks
>
>John
>
>
>
>On Wed, 9 Apr 2014, D. Jared Dominguez wrote:
>
>> Date: Wed, 9 Apr 2014 10:09:49 -0500
>> From: D. Jared Dominguez <Jared_Dominguez at dell.com>
>> To: john <lists at cloned.org.uk>
>> Cc: linux-poweredge-Lists <linux-poweredge at lists.us.dell.com>
>> Subject: Re: [Linux-PowerEdge] OMSA 7.4,
>>     DTK 4.4 and iSM 1.0 published for Ubuntu/Debian
>>
>> Thanks. Hmm, looks like I need to test upgrades with just the webserver
>> installed. I'll need to do that this afternoon so I can fix upgrades for your
>> use case. For now, could you tell me the output of:
>>        ls -ld /opt/dell/srvadmin/lib/openmanage/jre
>>        dpkg -S /opt/dell/srvadmin/lib/openmanage/jre
>>
>> Also, could you send me
>> /opt/dell/srvadmin/var/log/openmanage/dsm_om_connsvcdIO.log from your system?
>>
>> --Jared
>>
>>
>> On Wed, Apr 09, 2014 at 10:00:45AM -0500, john wrote:
>>> Hi,
>>> I just did upgrade. Have just looked and dist-upgrade will install zero
>>> packages.
>>>
>>> # dpkg -l | egrep "(srvadmin|jdk|jre)"
>>> ii  icedtea-7-jre-jamvm:amd64          7u25-2.3.10-1~deb7u1          amd64
>>> Alternative JVM for OpenJDK, using JamVM
>>> ii  openjdk-7-jre:amd64                7u25-2.3.10-1~deb7u1          amd64
>>> OpenJDK Java runtime, using Hotspot JIT
>>> ii  openjdk-7-jre-headless:amd64       7u25-2.3.10-1~deb7u1          amd64
>>> OpenJDK Java runtime, using Hotspot JIT (headless)
>>> ii  openjdk-7-jre-lib                  7u25-2.3.10-1~deb7u1          all
>>> OpenJDK Java runtime (architecture independent libraries)
>>> ii  srvadmin-jre                       7.4.0-1                       amd64
>>> Oracle Java Runtime Environment
>>> ii  srvadmin-omacs                     7.4.0-2                       amd64
>>> Dell OpenManage Server Administrator OMACS
>>> ii  srvadmin-omcommon                  7.4.0-2                       amd64
>>> Dell OpenManage Server Administrator Common Framework
>>> ii  srvadmin-omilcore                  7.4.0-1                       all
>>> Dell OpenManage Server Administrator Install Core
>>> ii  srvadmin-smcommon                  7.4.0-1                       amd64
>>> Storage Management common files for GUI and CLI
>>> ii  srvadmin-smweb                     7.4.0-1                       amd64
>>> Storage Management package for GUI component
>>> ii  srvadmin-tomcat                    7.4.0-1                       amd64
>>> Secure Port Server and Server Administrator GUI
>>> ii  srvadmin-webserver                 7.4.0                         amd64
>>> Meta package for installing the Server Administrator Web Server feature
>>>
>>>
>>> Thanks,
>>>
>>> john
>>>
>>>
>>> On Wed, 9 Apr 2014, D. Jared Dominguez wrote:
>>>
>>>> Could you send me the output of the following command?
>>>>        dpkg -l | egrep "(srvadmin|jdk|jre)"
>>>>
>>>> Also, did you dist-upgrade or just upgrade?
>>>>
>>>> --Jared
>>>>
>>>>
>>>> On Wed, Apr 09, 2014 at 05:04:06AM -0500, john wrote:
>>>>> On Tue, 8 Apr 2014, D. Jared Dominguez wrote:
>>>>>
>>>>>> http://en.community.dell.com/techcenter/b/techcenter/archive/2014/04/08/dell-omsa-7-4-dtk-4-4-and-ism-1-0-for-ubuntu-and-debian.aspx
>>>>>>
>>>>>> Let me know if you find bugs. :)
>>>>>
>>>>> I have a Debian wheezy VM I'm running 7.4 on (updated from OM 7.3) as
>>>>> a webinterface to some centos/redhat based xenservers (running 7.3.0)
>>>>> which no longer install the webinterface. I have only dsm_om_connsvc
>>>>> running on the Debian VM.
>>>>>
>>>>> When I try and login to a remote system using port 5986 through this it
>>>>> just comes up with "login failed" immediately. Checking the logs:
>>>>>
>>>>> /opt/dell/srvadmin/var/log/openmanage/dsm_om_connsvcdIO.log it outputs:
>>>>>
>>>>> [Fatal Error] :1:44: XML document structures must start and end within
>>>>> the
>>>>> same entity.
>>>>>
>>>>> And that's it. Don't see anything at the other end. Don't see any packets
>>>>> or anything.
>>>>>
>>>>> Any ideas why I can't login to remote systems? It did the same on 7.3. My
>>>>> next step was going to be try it on CentOS and see if it was the same but
>>>>> not gotten round to that yet.
>>>>>
>>>>> Thanks,
>>>>>
>>>>> John
>>>>
>>>> --
>>>> Jared Domínguez
>>>> Server OS Engineering
>>>> Dell | Enterprise Solutions Group
>>>>
>>
>>> _______________________________________________
>>> Linux-PowerEdge mailing list
>>> Linux-PowerEdge at dell.com
>>> https://lists.us.dell.com/mailman/listinfo/linux-poweredge
>>
>>
>> --
>> Jared Domínguez
>> Server OS Engineering
>> Dell | Enterprise Solutions Group
>>

-- 
Jared Domínguez
Server OS Engineering
Dell | Enterprise Solutions Group



More information about the Linux-PowerEdge mailing list