[Linux-PowerEdge] Dell Open Manager - Alerts are blocked, lost or delayed

odisseu21 at gmail.com odisseu21 at gmail.com
Fri Apr 4 06:45:40 CDT 2014


These situation is happening with 2 servers, orion and sirius, after OMSA upgrade.

ORION
---------
PE R410
CentOS Linux release 6.0 (Final)
Linux orion.xxxx.com.br 2.6.32-431.11.2.el6.x86_64 #1 SMP Tue Mar 25 19:59:55 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
iDrac6 1.96 (build 01)
OMSA 7.3.2

SIRIUS
---------
PE R720
CentOS release 6.4 (Final)
Linux sirius.xxxx.com.br 2.6.32-431.11.2.el6.x86_64 #1 SMP Tue Mar 25 19:59:55 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
iDrac7 1.56.55 (build 05)
OMSA 7.3.2

Alert setup
----------------
omconfig system alertaction event=powersupply alert=true broadcast=true execappath="/root/bin/alarm_dell.sh powersupply"


Sometimes, only after dsm_sa_eventmgrd restart, alerts are fired; see below.

[root at orion ~]# !988
/opt/dell/srvadmin/sbin/srvadmin-services.sh restart

Shutting down DSM SA Shared Services:                      [  OK  ]
Shutting down DSM SA Connection Service:                   [  OK  ]
Stopping Systems Management Data Engine:
Stopping dsm_sa_snmpd:                                     [  OK  ]
Stopping dsm_sa_eventmgrd:                                 [  OK  ]
Stopping dsm_sa_datamgrd:                                  [  OK  ]
Stopping Systems Management Device Drivers:
Stopping dell_rbu:                                         [  OK  ]

Starting Systems Management Device Drivers:
Starting dell_rbu:                                         [  OK  ]
Starting ipmi driver: Already started                      [  OK  ]
Starting Systems Management Data Engine:
Starting dsm_sa_datamgrd:                                  [  OK  ]
Starting dsm_sa_eventmgrd:   (**** now alert is fired ****)

Broadcast message from root at orion.ibiz.com.br (Fri Apr  4 08:06:47 2014):

Server Administrator : Redundancy lost
Redundancy unit: System Board PS Redundancy
Chassis location: Main System Chassis
Previous redundancy state was: Unknown

Broadcast message from root at orion.ibiz.com.br (Fri Apr  4 08:06:47 2014):

Server Administrator : Power supply detected a failure
Sensor location: PS 1 Status
Chassis location: Main System Chassis
Previous state was: Unknown
Power Supply type: AC
Power Supply state: Presence detected, AC lost
                                                           [  OK  ]
Starting dsm_sa_snmpd:                                     [  OK  ]
Starting DSM SA Shared Services:                           [  OK  ]
Starting DSM SA Connection Service:                        [  OK  ]

Please, how to solve this situation? How to get alerts sooner?
Any help will be greatly appreciated!

thanks,
ulisses
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20140404/fc72d474/attachment-0001.html 


More information about the Linux-PowerEdge mailing list