[Linux-PowerEdge] OM 7.1.0-4 Debian Repo srvadmin-tomcat doesn't install

Jeremy MAURO jmauro at antidot.net
Fri Oct 26 12:00:17 CDT 2012


Sorry, you are right regarding the facts that I didn't have any setup 
error, thoses messages are just some kind of warning message.



Regards,
JM


On 10/26/12 18:07, Jared_Dominguez at DELL.com wrote:
>  From what you copied, it looks to me like the install went fine. Was there an error at the end that you didn't show in your email?
>
> Note that you will see those messages from cp, but the preinstall script is written such that it will continue if it can't copy those. It is the same code as in the official OMSA release's spec file with only minor changes for POSIX compliance. I can change the pre/post scripts so that you won't see those messages, but I'd have to do it in a way that diverges from the official releases or that violates Debian Policy.
>
> --Jared
>
> -----Original Message-----
> From: Jeremy MAURO [mailto:jmauro at antidot.net]
> Sent: Friday, October 26, 2012 8:54 AM
> To: Dominguez, Jared
> Cc: clavier at veepee.com; linux-poweredge-Lists
> Subject: Re: [Linux-PowerEdge] OM 7.1.0-4 Debian Repo srvadmin-tomcat doesn't install
>
> Hi everyone,
>
>
>       From a clean install in debian squeeze:
>      apt-get install -y --force-yes srvadmin-all ipmitool
>      Reading package lists...
>      Building dependency tree...
>      Reading state information...
>      ipmitool is already the newest version.
>      The following extra packages will be installed:
>          libargtable2-0 (12-1)
>          libopenipmi0 (2.0.16-1.2)
>          libperl5.10 (5.10.1-17squeeze3)
>          libsensors4 (3.1.2-6)
>          libsmbios2 (2.2.13-0ubuntu4)
>          libsnmp-base (5.4.3~dfsg-2)
>          libsnmp15 (5.4.3~dfsg-2)
>          libxext6 (1.1.2-1)
>          libxi6 (1.3-7)
>          libxslt1.1 (1.1.26-6+squeeze2)
>          libxt6 (1.0.7-1)
>          libxtst6 (1.1.0-3)
>          openipmi (2.0.16-1.2)
>          python-libsmbios (2.2.13-0ubuntu4)
>          setserial (2.17-45.3)
>          smbios-utils (2.2.13-0ubuntu4)
>          snmpd (5.4.3~dfsg-2)
>          srvadmin-base (7.1.0-2)
>          srvadmin-deng (7.1.0-2)
>          srvadmin-hapi (7.1.0-2)
>          srvadmin-idrac (7.1.0-1)
>          srvadmin-idrac-ivmcli (7.1.0-1)
>          srvadmin-idrac-vmcli (7.1.0-1)
>          srvadmin-idrac7 (7.1.0-1)
>          srvadmin-idracadm (7.1.0-1)
>          srvadmin-idracadm7 (7.1.0-1)
>          srvadmin-isvc (7.1.0-1)
>          srvadmin-jre (7.1.0-2)
>          srvadmin-omacore (7.1.0-4)
>          srvadmin-omcommon (7.1.0-1)
>          srvadmin-omilcore (7.1.0-2)
>          srvadmin-rac-components (7.1.0-1)
>          srvadmin-rac4 (7.1.0-2)
>          srvadmin-rac4-populator (7.1.0-2)
>          srvadmin-rac5 (7.1.0-1)
>          srvadmin-racadm4 (7.1.0-2)
>          srvadmin-racadm5 (7.1.0-1)
>          srvadmin-racdrsc (7.1.0-1)
>          srvadmin-racsvc (7.1.0-2)
>          srvadmin-realssd (7.1.0-1)
>          srvadmin-smcommon (7.1.0-1)
>          srvadmin-smweb (7.1.0-1)
>          srvadmin-storage (7.1.0-1)
>          srvadmin-storageservices (7.1.0-2)
>          srvadmin-storelib (7.1.0-1)
>          srvadmin-storelib-sysfs (7.1.0-1)
>          srvadmin-sysfsutils (7.1.0-1)
>          srvadmin-tomcat (7.1.0-4)
>          srvadmin-webserver (7.1.0-2)
>          srvadmin-xmlsup (7.1.0-1)
>      Suggested packages:
>          libsmbios-doc (2.2.13-0ubuntu4)
>          snmp-mibs-downloader (1.1)
>      Recommended packages:
>          lm-sensors (3.1.2-6)
>      The following NEW packages will be installed:
>          libargtable2-0 (12-1)
>          libopenipmi0 (2.0.16-1.2)
>          libperl5.10 (5.10.1-17squeeze3)
>          libsensors4 (3.1.2-6)
>          libsmbios2 (2.2.13-0ubuntu4)
>          libsnmp-base (5.4.3~dfsg-2)
>          libsnmp15 (5.4.3~dfsg-2)
>          libxext6 (1.1.2-1)
>          libxi6 (1.3-7)
>          libxslt1.1 (1.1.26-6+squeeze2)
>          libxt6 (1.0.7-1)
>          libxtst6 (1.1.0-3)
>          openipmi (2.0.16-1.2)
>          python-libsmbios (2.2.13-0ubuntu4)
>          setserial (2.17-45.3)
>          smbios-utils (2.2.13-0ubuntu4)
>          snmpd (5.4.3~dfsg-2)
>          srvadmin-all (7.1.0-2)
>          srvadmin-base (7.1.0-2)
>          srvadmin-deng (7.1.0-2)
>          srvadmin-hapi (7.1.0-2)
>          srvadmin-idrac (7.1.0-1)
>          srvadmin-idrac-ivmcli (7.1.0-1)
>          srvadmin-idrac-vmcli (7.1.0-1)
>          srvadmin-idrac7 (7.1.0-1)
>          srvadmin-idracadm (7.1.0-1)
>          srvadmin-idracadm7 (7.1.0-1)
>          srvadmin-isvc (7.1.0-1)
>          srvadmin-jre (7.1.0-2)
>          srvadmin-omacore (7.1.0-4)
>          srvadmin-omcommon (7.1.0-1)
>          srvadmin-omilcore (7.1.0-2)
>          srvadmin-rac-components (7.1.0-1)
>          srvadmin-rac4 (7.1.0-2)
>          srvadmin-rac4-populator (7.1.0-2)
>          srvadmin-rac5 (7.1.0-1)
>          srvadmin-racadm4 (7.1.0-2)
>          srvadmin-racadm5 (7.1.0-1)
>          srvadmin-racdrsc (7.1.0-1)
>          srvadmin-racsvc (7.1.0-2)
>          srvadmin-realssd (7.1.0-1)
>          srvadmin-smcommon (7.1.0-1)
>          srvadmin-smweb (7.1.0-1)
>          srvadmin-storage (7.1.0-1)
>          srvadmin-storageservices (7.1.0-2)
>          srvadmin-storelib (7.1.0-1)
>          srvadmin-storelib-sysfs (7.1.0-1)
>          srvadmin-sysfsutils (7.1.0-1)
>          srvadmin-tomcat (7.1.0-4)
>          srvadmin-webserver (7.1.0-2)
>          srvadmin-xmlsup (7.1.0-1)
>      0 upgraded, 51 newly installed, 0 to remove and 0 not upgraded.
>      Need to get 113 MB of archives.
>      After this operation, 330 MB of additional disk space will be used.
>      ...
>      Selecting previously deselected package srvadmin-jre.^M
>      Unpacking srvadmin-jre (from .../srvadmin-jre_7.1.0-2_amd64.deb) ...^M
>      Selecting previously deselected package srvadmin-tomcat.^M
>      Unpacking srvadmin-tomcat (from
>      .../srvadmin-tomcat_7.1.0-4_amd64.deb) ...^M
>      cp: cannot stat
>      `/opt/dell/srvadmin/lib/openmanage/apache-tomcat/webapps/omsa/WEB-INF/lib/OMPREF.jar':
>      No such file or directory^M
>      cp: cannot stat
>      `/opt/dell/srvadmin/lib/openmanage/apache-tomcat/webapps/omsa/WEB-INF/lib/OMSA.jar':
>      No such file or directory^M
>      cp: cannot stat
>      `/opt/dell/srvadmin/lib/openmanage/apache-tomcat/webapps/omsa/WEB-INF/web.xml':
>      No such file or directory^M
>      cp: cannot stat
>      `/opt/dell/srvadmin/lib/openmanage/apache-tomcat/conf/keystore.db':
>      No such file or directory^M
>      cp: cannot stat
>      `/opt/dell/srvadmin/lib/openmanage/apache-tomcat/conf/web.xml': No
>      such file or directory^M
>      cp: cannot stat
>      `/opt/dell/srvadmin/lib/openmanage/apache-tomcat/conf/server.xml':
>      No such file or directory^M
>      Selecting previously deselected package srvadmin-smweb.^M
>      Unpacking srvadmin-smweb (from .../srvadmin-smweb_7.1.0-1_amd64.deb)
>      ...^M
>      Selecting previously deselected package srvadmin-webserver.^M
>      Unpacking srvadmin-webserver (from
>      .../srvadmin-webserver_7.1.0-2_amd64.deb) ...^M
>      Selecting previously deselected package srvadmin-racadm4.^M
>      Unpacking srvadmin-racadm4 (from
>      .../srvadmin-racadm4_7.1.0-2_amd64.deb) ...^M
>      ...
>
>
> I am having the same issue
>
> Regards,
> JM
>
> On 10/26/12 15:38, Jared_Dominguez at DELL.com wrote:
>
>> It installs for me both on Ubuntu 10.04 and Ubuntu 12.04. Can you check if /etc/opt/dell/srvadmin/openmanage/iws/config is exists? It should not exist on a clean install but might on an upgrade. I'll add some checks for upgrades, but for clean installs, you should not be running into this problem at all.
>>
>> --Jared
>> ________________________________________
>> From: linux-poweredge-bounces-Lists On Behalf Of Cyril LAVIER
>> [clavier at veepee.com]
>> Sent: Friday, October 26, 2012 4:57 AM
>> To: linux-poweredge-Lists
>> Subject: Re: [Linux-PowerEdge] OM 7.1.0-4 Debian Repo srvadmin-tomcat
>> doesn't install
>>
>> Same issue here.
>>
>> I tried to upgrade using "apt-get dist-upgrade", and I have the exact same error.
>>
>> The only way I succeded is very very dirty, I copied the OMPREF.jar and OMSA.jar files where the preinst-script thinks they are :
>> cp
>> /opt/dell/srvadmin/lib/openmanage/apache-tomcat/webapps/omsa/WEB-INF/l
>> ib/OMPREF.jar /opt/dell/srvadmin/backup/ cp
>> /opt/dell/srvadmin/lib/openmanage/apache-tomcat/webapps/omsa/WEB-INF/l
>> ib/OMSA.jar /opt/dell/srvadmin/backup/ cp
>> /opt/dell/srvadmin/lib/openmanage/apache-tomcat/webapps/omsa/WEB-INF/l
>> ib/OMSA.jar /opt/dell/srvadmin/share/java/ cp
>> /opt/dell/srvadmin/lib/openmanage/apache-tomcat/webapps/omsa/WEB-INF/l
>> ib/OMPREF.jar /opt/dell/srvadmin/share/java/
>>
>> And I relaunched a "apt-get install srvadmin-tomcat".
>>
>> Thanks.
>>
>> -----Original Message-----
>> From: linux-poweredge-bounces at dell.com
>> [mailto:linux-poweredge-bounces at dell.com] On Behalf Of Dirk Hartmann
>> Sent: vendredi 26 octobre 2012 10:39
>> To: linux-poweredge at dell.com
>> Subject: [Linux-PowerEdge] OM 7.1.0-4 Debian Repo srvadmin-tomcat
>> doesn't install
>>
>> Hi,
>>
>> we can't install the new Version of srvadmin from the Ubuntu/Debian Repo. The tomcat-deb blocks it.
>>
>> With apt-get install srvadmin-tomcat I get:
>> Unpacking srvadmin-tomcat (from .../srvadmin-tomcat_7.1.0-4_i386.deb)
>> ...
>>
>> cp: cannot stat `/opt/dell/srvadmin/share/java/OMSA.jar': No such file
>> or directory
>>
>> dpkg: error processing
>> /var/cache/apt/archives/srvadmin-tomcat_7.1.0-4_i386.deb
>>
>> Could be the preinst-script that trys to backup jars and keystore regardless if it's a new install or an upgrade.
>> But even on an upgrade it fails with the same error.
>>
>> Best Regards
>> Dirk
>>
>> --
>> Dirk Hartmann, Heise Zeitschriften Verlag GmbH&   Co. KG
>> IT-Systemmanagement, Karl-Wiechert-Allee 10,  D-30625 Hannover
>> E-Mail: dha at heise.de - Tel.: +49 511 5352 494 - FAX:  - 479
>> PGP-Fingerprint 4153 7C95 3259 C39F 49AA  9BAA 6833 A8DC 6D90 050E
>>
>> Don't blame me for the following spam, blame european government:
>>
>> Heise Zeitschriften Verlag GmbH&   Co. KG
>> Registergericht: Amtsgericht Hannover HRA 26709
>>
>> Persönlich haftende Gesellschafterin:
>> Heise Zeitschriften Verlag Geschäftsführung GmbH
>> Registergericht: Amtsgericht Hannover, HRB 60405
>> Geschäftsführer: Ansgar Heise, Dr. Alfons Schräder
>>
>> _______________________________________________
>> Linux-PowerEdge mailing list
>> Linux-PowerEdge at dell.com
>> https://lists.us.dell.com/mailman/listinfo/linux-poweredge
>>
>> _______________________________________________
>> Linux-PowerEdge mailing list
>> Linux-PowerEdge at dell.com
>> https://lists.us.dell.com/mailman/listinfo/linux-poweredge
>> _______________________________________________
>> Linux-PowerEdge mailing list
>> Linux-PowerEdge at dell.com
>> https://lists.us.dell.com/mailman/listinfo/linux-poweredge
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20121026/8c685e60/attachment.html 


More information about the Linux-PowerEdge mailing list