[Linux-PowerEdge] idrac7 and omsa on rhel 6

Matthew Kent matthew at 37signals.com
Tue Nov 27 19:04:30 CST 2012


(new to list, apologies if this is a known issue)

Setting up a new r620 with genuine rhel 6 today and ran into a fun issue I thought I'd share.

I ran the bootstrap as per http://linux.dell.com/wiki/index.php/Repository/OMSA and installed srvadmin-all without issue. On running racadm I got:

[root at foo ~]# racadm getsysinfo

NOTE:
This Integrated Dell Remote Access Controller does not support RACADM commands.
Please contact Dell Customer Service to upgrade your version of iDRAC.


uh oh!

Even stranger an identical machine running Ubuntu was running racadm fine.

After some digging the culprit is the dependencies on srvadmin-all, they are missing the idrac7 packages on rhel:

[root at foo ~]# rpm -q -a --requires srvadmin-all
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
srvadmin-base = 7.1.0
srvadmin-idrac = 7.1.0
srvadmin-rac4 = 7.1.0
srvadmin-rac5 = 7.1.0
srvadmin-standardAgent = 7.1.0
srvadmin-storageservices = 7.1.0
srvadmin-webserver = 7.1.0


while Ubuntu has them:

root at bar:~# dpkg -s srvadmin-all | grep Depends
Depends: srvadmin-base (>= 7.1.0), srvadmin-storageservices (>= 7.1.0), srvadmin-webserver (>= 7.1.0), srvadmin-rac4 (>= 7.1.0), srvadmin-rac5 (>= 7.1.0), srvadmin-idrac (>= 7.1.0), srvadmin-idrac7 (>= 7.1.0)


a quick

yum install srvadmin-idrac7 srvadmin-idracadm7

Fixed the issue.

Would love it if someone from Dell could fix and push this. A more accurate error message might be useful as well.
-- 
Matthew Kent | System Admin | http://37signals.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20121127/7fd53766/attachment.html 


More information about the Linux-PowerEdge mailing list