[Linux-PowerEdge] USC Freezes and USC/Lifecycle Controller Update

Jeff Boyce jboyce at meridianenv.com
Mon Nov 26 15:30:26 CST 2012


Patrick -

This is where I was having problems with the instructions that I was finding 
in the Dell documentation.  My version of the iDRAC web interface does not 
have "Remote Access" in the left hand tree.  It has the following list in 
the left hand tree.

System
iDRAC Settings
Batteries
Fans
Intrusion
Power Supplies
Removable Flash Media
Temperatures
Voltage
Power Monitoring
LCD

Under "iDRAC Settings" there is an update tab, and I did use this to update 
the iDRAC firmware from 1.80 to 1.92.  I tried using that to do the 
USC/Lifecycle Controller firmware update, but the system responded saying 
that file was not recognizable as an iDRAC firmware update (don't recall the 
exact phrase it used), implying that this menu option was only designed for 
the iDRAC update and not other system firmware.  So I am still at a loss as 
to how to repair/update the USC/Lifecycle Controller firmware.

Jeff



----- Original Message ----- 
From: <Patrick_Boyd at Dell.com>
To: <jboyce at meridianenv.com>; <linux-poweredge at lists.us.dell.com>
Sent: Monday, November 26, 2012 1:09 PM
Subject: RE: [Linux-PowerEdge] USC Freezes and USC/Lifecycle Controller 
Update


You can apply the USC repair package through the iDRAC GUI by selecting 
"Remote Access" in the left hand tree and then selecting the update tab. 
It's the same page as you would use to update the iDRAC itself with the 
iDRAC.

Hope that helps,
Patrick Boyd
Systems Management Development
Dell, Inc.

-----Original Message-----
From: linux-poweredge-bounces-Lists On Behalf Of Jeff Boyce
Sent: Monday, November 26, 2012 12:27 PM
To: linux-poweredge-Lists
Subject: [Linux-PowerEdge] USC Freezes and USC/Lifecycle Controller Update

Greetings -



This post may be a little long, but I wanted to make sure that I clearly 
describe my issue and what steps I have taken to try to resolve it before 
asking for assistance.



I have two issues; first the Unified Server Configurator freezes when trying 
to start, and second I am trying to figure out the proper way to repair 
and/or update the USC/Lifecycle Controller firmware.  Now some background of 
how I got here and what I have tried.



I administer the computer network for my small company in addition to my 
other technical duties.  We have a Poweredge T610 that is almost a year old 
and has been working reliably as our office file server the entire time.
The box runs Centos 6.2 on the KVM host system, and has two VMs also running 
Centos 6.2.  In late October it unexpectedly crashed during the weekend.  I 
could find nothing in the logs to indicate the cause of the crash, so I 
figured the proper thing to do first was to schedule a day to update the 
system firmware and OS.  I have Dell's firmware tools installed which 
allowed me to inventory and update the device drivers and device firmware.
However, this tool does not show all the firmware that is available for the 
iDRAC, the USC, or the BIOS (compared to seeing what is available for my 
system on Dell Support Drivers and Downloads page for my service tag).



Then I figured I would start the USC/Lifecycle Controller so that I could 
run the hardware diagnostics and look into completing the remaining firmware 
updates.  When I started the USC at boot via F10 the system gets to the Dell 
Logo screen where it displays "Entering System Services. Starting Unified 
Server Configurator".  At this point it just freezes there; I finally 
powered it down after 30 minutes.  I suspect that the crash in late October 
has caused some corruption in the USC/Lifecycle Controller, but that is pure 
speculation on my part.



What I have tried:

1.  After a little Google research on this situation, I unplug the power 
cords to the server, and the iDRAC network cable to allow the iDRAC to 
reset.  Powering up and selecting F10 produces the same freeze result.



2.  More Google research and reading the manual for the USC, leads me to try 
the repair program for the USC/LCC.  However reading the instructions for 
this it states to run/install the repair program via the iDRAC web interface 
(select the Remote Access tab and browse to the repair package).  Well, 
unless I am completely blind my iDRAC web interface does not have a Remote 
Access tab, or anything that appears to have a similar function.  I have an
iDRAC6 Enterprise, running firmware version 1.92.  The screen shots with the 
instructions are clearly showing an older version of the iDRAC web 
interface.  I have not found any newer or updated instructions that would 
match my iDRAC web interface options.




3.  Next attempt was to download the firmware BIN file and run it from the 
command line.  I downloaded the file 
Lifecycle-Controller_Application_F0D50_LN32_1.5.2.32_A00.BIN and read 
through the notes.  I noticed that the notes mention that the update may 
fail to run on 64-bit Linux Operating systems, and that I may need to 
install some 32-bit compatibility libraries.  So I tried the install and it 
told me specifically the three libraries it needed installed.  So I then did 
a yum search & yum install for compat-libstdc++-33.i686.  This library 
installed without any other dependencies required.  Then I did a yum search 
& yum install for libstdc++.i686.  This resulted in yum producing a 
dependency check error (not really sure if that is the correct term to use) 
stating that there was incompatible protected multilib versions, and that 
the software was not installed.  I am guessing that this has to do with 32 
vs. 64-bit libraries.  It also stated that I could override the conflict 
with an option.  But I am not going to do that for fear of causing other 
problems down the road.



So that is where I am at this point, a system without a complete set of 
firmware updates installed, and still unable to start the USC/Lifecycle 
Controller.  I am looking for suggestions on how to properly fix the 
USC/Lifecycle Controller so that I may use it.  I can provide any additional 
system information or logs that may help with diagnostics or resolution of 
this issue.  Thanks.



System Information:

Poweredge T610, BIOS ver. 6.0.7

iDRAC 6 Enterprise, firmware updated to ver. 1.92

USC/Lifecycle Controller firmware ver. 1.5.1.57

OS: CentOS 6.2 x64




Jeff Boyce
Meridian Environmental
www.meridianenv.com



_______________________________________________
Linux-PowerEdge mailing list
Linux-PowerEdge at dell.com
https://lists.us.dell.com/mailman/listinfo/linux-poweredge



More information about the Linux-PowerEdge mailing list