[Linux-PowerEdge] Fwd: Solution to update Dell firmwares in Debian based distros.

Claudio Cesar Sanchez Tejeda demonccc.y at gmail.com
Mon Nov 12 12:30:53 CST 2012


On Mon, Nov 12, 2012 at 2:39 PM, Jean-Daniel TISSOT <
Jean-Daniel.Tissot at univ-fcomte.fr> wrote:
>
> Le 12/11/2012 17:40, Claudio Cesar Sanchez Tejeda a écrit :
>
>> Hi All,
>>
>> I developed a bash application that download the rpm packages (firmware,
firmware tools and ie modules) from the YUM Dell repo and port them to
Debian packages.
>>
>> You can upload these packages to a Debian repo and install them in your
Dell servers.
>>
>> The project is hosted in Github:
https://github.com/demonccc/lnxDellRepo2deb
>>
>> Please let me know if you have some workarounds or ideas in order to
improve this project.
>>
>> Regards.
>>
> Hi,
>
> Do you think i can upgrade my PERC 6/i or my PERC H700 controler ?
>
> Thanks in advance
>
> Regards
>
> --
> Bien cordialement, Jean-Daniel TISSOT
> Administrateur Systèmes et Réseaux
> Tel: +33 3 81 666 440           Fax: +33 3 81 666 568
>
> Laboratoire Chrono-Environnement
http://chrono-environnement.univ-fcomte.fr/
> Université de Franche-Comté
http://www.univ-fcomte.fr/
> 16, Route de Gray
> 25030 BESANÇON Cedex                mailto:
Jean-Daniel.Tissot at Univ-FComte.FR
> http://chrono-environnement.univ-fcomte.fr/spip.php?article457
>
>

Hi Jean,

Yes, you can update the firmware of your storage controller.

All the firmware of this system was updated using the packages generated by
this tool:

# smbios-sys-info
Libsmbios version:      2.2.27
Product Name:           PowerEdge R610
Vendor:                 Dell Inc.
BIOS Version:           6.3.0
System ID:              0x0236
Service Tag:            XXXXXXX
Express Service Code:   XXXXXXXXXXXX
Asset Tag:
Property Ownership Tag:
# update_firmware -y

Running system inventory...
Invalid XML from module /usr/libexec/dell_dup/dell_ie_nic_emulex-1.1.0
Invalid XML from module /usr/libexec/dell_dup/dell_ie_nic_intel-1.1.0

Searching storage directory for available BIOS updates...
Checking BIOS - 6.3.0
Available: dell_dup_componentid_00159 - 6.3.0
Did not find a newer package to install that meets all installation checks.
Checking SAS/SATA Backplane 0:0 Backplane Firmware - 1.07
Available: dell_dup_componentid_11204 - 1.07
Did not find a newer package to install that meets all installation checks.
Checking NetXtreme II BCM5709 Gigabit Ethernet rev 20 (eth1) - 7.2.14
Available: pci_firmware(ven_0x14e4_dev_0x1639_subven_0x1028_subdev_0x0236)
- 7.2.14
Did not find a newer package to install that meets all installation checks.
Checking NetXtreme II BCM5709 Gigabit Ethernet rev 20 (eth0) - 7.2.14
Available: pci_firmware(ven_0x14e4_dev_0x1639_subven_0x1028_subdev_0x0236)
- 7.2.14
Did not find a newer package to install that meets all installation checks.
Checking ST973452SS Firmware - ht64
Available: dell_dup_componentid_20608 - ht64
Did not find a newer package to install that meets all installation checks.
Checking iDRAC6 - 1.80
Did not find a newer package to install that meets all installation checks.
Checking Power Supply - 04.14.00
Did not find a newer package to install that meets all installation checks.
Checking PERC 6/i Integrated Controller 0 Firmware - 6.3.1-0003
Available: pci_firmware(ven_0x1000_dev_0x0060_subven_0x1028_subdev_0x1f0c)
- 6.3.1-0003
Did not find a newer package to install that meets all installation checks.
Checking System BIOS for PowerEdge R610 - 6.3.0
Did not find a newer package to install that meets all installation checks.
Checking NetXtreme II BCM5709 Gigabit Ethernet rev 20 (eth2) - 7.2.14
Available: pci_firmware(ven_0x14e4_dev_0x1639_subven_0x1028_subdev_0x0236)
- 7.2.14
Did not find a newer package to install that meets all installation checks.
Checking NetXtreme II BCM5709 Gigabit Ethernet rev 20 (eth3) - 7.2.14
Available: pci_firmware(ven_0x14e4_dev_0x1639_subven_0x1028_subdev_0x0236)
- 7.2.14
Did not find a newer package to install that meets all installation checks.

This system does not appear to have any updates available.
No action necessary.
#

Regards.



On Mon, Nov 12, 2012 at 3:28 PM, Claudio Cesar Sanchez Tejeda <
demonccc.y at gmail.com> wrote:

> On Mon, Nov 12, 2012 at 2:39 PM, Jean-Daniel TISSOT <
> Jean-Daniel.Tissot at univ-fcomte.fr> wrote:
> >
> > Le 12/11/2012 17:40, Claudio Cesar Sanchez Tejeda a écrit :
> >
> >> Hi All,
> >>
> >> I developed a bash application that download the rpm packages
> (firmware, firmware tools and ie modules) from the YUM Dell repo and port
> them to Debian packages.
> >>
> >> You can upload these packages to a Debian repo and install them in your
> Dell servers.
> >>
> >> The project is hosted in Github:
> https://github.com/demonccc/lnxDellRepo2deb
> >>
> >> Please let me know if you have some workarounds or ideas in order to
> improve this project.
> >>
> >> Regards.
> >>
> > Hi,
> >
> > Do you think i can upgrade my PERC 6/i or my PERC H700 controler ?
> >
> > Thanks in advance
> >
> > Regards
> >
> > --
> > Bien cordialement, Jean-Daniel TISSOT
> > Administrateur Systèmes et Réseaux
> > Tel: +33 3 81 666 440           Fax: +33 3 81 666 568
> >
> > Laboratoire Chrono-Environnement
> http://chrono-environnement.univ-fcomte.fr/
> > Université de Franche-Comté
> http://www.univ-fcomte.fr/
> > 16, Route de Gray
> > 25030 BESANÇON Cedex                mailto:
> Jean-Daniel.Tissot at Univ-FComte.FR
> > http://chrono-environnement.univ-fcomte.fr/spip.php?article457
> >
> >
>
> Hi Jean,
>
> Yes, you can update the firmware of your storage controller.
>
> All the firmware of this system was updated using the packages generated
> by this tool:
>
> # smbios-sys-info
> Libsmbios version:      2.2.27
> Product Name:           PowerEdge R610
> Vendor:                 Dell Inc.
> BIOS Version:           6.3.0
> System ID:              0x0236
> Service Tag:            XXXXXXX
> Express Service Code:   XXXXXXXXXXXX
> Asset Tag:
> Property Ownership Tag:
> # update_firmware -y
>
> Running system inventory...
> Invalid XML from module /usr/libexec/dell_dup/dell_ie_nic_emulex-1.1.0
> Invalid XML from module /usr/libexec/dell_dup/dell_ie_nic_intel-1.1.0
>
> Searching storage directory for available BIOS updates...
> Checking BIOS - 6.3.0
> Available: dell_dup_componentid_00159 - 6.3.0
> Did not find a newer package to install that meets all installation checks.
> Checking SAS/SATA Backplane 0:0 Backplane Firmware - 1.07
> Available: dell_dup_componentid_11204 - 1.07
> Did not find a newer package to install that meets all installation checks.
> Checking NetXtreme II BCM5709 Gigabit Ethernet rev 20 (eth1) - 7.2.14
> Available: pci_firmware(ven_0x14e4_dev_0x1639_subven_0x1028_subdev_0x0236)
> - 7.2.14
> Did not find a newer package to install that meets all installation checks.
> Checking NetXtreme II BCM5709 Gigabit Ethernet rev 20 (eth0) - 7.2.14
> Available: pci_firmware(ven_0x14e4_dev_0x1639_subven_0x1028_subdev_0x0236)
> - 7.2.14
> Did not find a newer package to install that meets all installation checks.
> Checking ST973452SS Firmware - ht64
> Available: dell_dup_componentid_20608 - ht64
> Did not find a newer package to install that meets all installation checks.
> Checking iDRAC6 - 1.80
> Did not find a newer package to install that meets all installation checks.
> Checking Power Supply - 04.14.00
> Did not find a newer package to install that meets all installation checks.
> Checking PERC 6/i Integrated Controller 0 Firmware - 6.3.1-0003
> Available: pci_firmware(ven_0x1000_dev_0x0060_subven_0x1028_subdev_0x1f0c)
> - 6.3.1-0003
> Did not find a newer package to install that meets all installation checks.
> Checking System BIOS for PowerEdge R610 - 6.3.0
> Did not find a newer package to install that meets all installation checks.
> Checking NetXtreme II BCM5709 Gigabit Ethernet rev 20 (eth2) - 7.2.14
> Available: pci_firmware(ven_0x14e4_dev_0x1639_subven_0x1028_subdev_0x0236)
> - 7.2.14
> Did not find a newer package to install that meets all installation checks.
> Checking NetXtreme II BCM5709 Gigabit Ethernet rev 20 (eth3) - 7.2.14
> Available: pci_firmware(ven_0x14e4_dev_0x1639_subven_0x1028_subdev_0x0236)
> - 7.2.14
> Did not find a newer package to install that meets all installation checks.
>
> This system does not appear to have any updates available.
> No action necessary.
> #
>
> Regards.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20121112/83c0494d/attachment.html 


More information about the Linux-PowerEdge mailing list