GRUB no output on Serial-over-LAN, R510, Centos 6.2

Richard Chan rspchan at starhub.net.sg
Tue Mar 13 19:40:25 CDT 2012


Using GRUB from CentOS 6.2 on a Poweredge 510.

But no output from GRUB on Serial-over-LAN after the point where the message
"Press any key.." appears to select between serial or console.

Kernel and agetty on COM2 work fine, though.

BIOS:
Console Redirection COM2 - ON
Console Redirection after Boot -OFF

GRUB:
timeout 20
serial --unit=1 --speed=115200
terminal --timeout=10 serial console

Kernel:
<....>  console=ttyS1,115200 console=tty0

I can see the part where GRUB shows "Press any key to continue"  on both
internal video and SOL channels.
After that the serial-over-LAN does not take input or show the GRUB menu.

Tried forcing the serial console "terminal serial" - result: no output/input
Tried GRUB console-only with "Console Redirection after Boot - ON" -
result: no menu

However, once GRUB times out and the kernel boots the kernel output and
getty on ttyS1/SOL work perfectly.

In summary, GRUB (Centos 6.2) does not seem to receive or output anything
on the SOL channel.

Any suggestions?

Richard
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20120314/2b4c0f26/attachment.html 


More information about the Linux-PowerEdge mailing list