UEFI PXE boot

Erinn Looney-Triggs erinn.looneytriggs at gmail.com
Thu Jul 26 13:49:52 CDT 2012


On 07/26/2012 10:13 AM, Spike_White at Dell.com wrote:
> I'm not understanding how this is a bug in 11th gen servers.  Rather a limitation of that firmware's user interface.
> 
> PXE boot implies a BIOS boot.  I PXE-boot all the time at my house into CentOS, Ubuntu or OEL.  Using pxelinux (with pxelinux.0 as my NBP).
> 
> Also, we have PXE boot set up in our labs for our server builds.  It's a more complicated back-end infrastructure, but the same phases.  DHCP -> TFTP -> download NBP -> off to the races.
> 
> UEFI network boot is a different animal.    Luckily, UEFI network boots can re-use our existing DHCP/TFTP infrastructure we've already set up.  But it's a totally different NBP and it's the boot client doing a UEFI boot instead of a BIOS boot.  
> 
> Here's a good reference for re-using existing PXE infrastructure for a network UEFI boot:
> 
>      http://docs.fedoraproject.org/en-US/Fedora/17/html/Installation_Guide/s1-netboot-pxe-config-efi.html   
> 
> So in this example, it's pxelinux/bootx64.efi that's the network boot program.  (Appears to be the /install/images/efiboot.img out of the CentOS 6.2 DVD.)
> 
> On a 12th gen server (like a M620 or R620) you can go into boot manager (F11) and interactively select a UEFI boot or a BIOS boot.  If you want PXE, you select BIOS boot.
> 
> On a 11th gen server (like a R710), F11 by default is the BIOS boot manager.  If you press F2 and go to Boot settings, you can change the boot mode to UEFI.  Then if you reboot, F11 is the UEFI boot manager.  But then you can't PXE boot (as PXE boot implies a BIOS boot).
> 
> Internally,  if attempting a UEFI network boot, a Dell 11g or 12g server sends this Vendor Class Identifier (VCI):
> 
>     PXEClient:ARCH:00007:UNDI:00301
> 
> If attempting a PXE boot, the client sends this VCI:
> 
>     PXEClient:Arch:00000:UNDI:002001
> 
> A smart DHCP server can key off that VCI and set up the DHCP option 67 (boot filename) appropriately.  As they do in the example above.
> 
> Spike
> 
> 
> 
> Where 
> 
>> ------------------------------
>>
>> Message: 2
>> Date: Thu, 26 Jul 2012 08:53:39 -0800
>> From: Erinn Looney-Triggs <erinn.looneytriggs at gmail.com>
>> Subject: Re: UEFI PXE boot
>> To: linux-poweredge at lists.us.dell.com
>> Message-ID: <50117613.8000809 at gmail.com>
>> Content-Type: text/plain; charset="iso-8859-1"
>>
>> To continue on with this somewhat Red Hat support has now duplicated the
>> failure to PXE boot with UEFI enabled, on an R610 (in my testing r510
>> and r710 systems fail as well) and is working with Dell on a resolution
>> to the issue. No idea how long that will take.
>>
>> -Erinn
> 
> 
> _______________________________________________
> Linux-PowerEdge mailing list
> Linux-PowerEdge at dell.com
> https://lists.us.dell.com/mailman/listinfo/linux-poweredge
> 

Thanks for the explanation, I believe we are simply crossing at
terminology, which is my fault as UEFI boot in the very broad sense does
essentially the same thing as PXE boot, but this is a very simplistic
view and when I started this thread, honestly I didn't understand much
about, well, much.

So what is failing is a UEFI boot from RHEL 6.3. It may be hardware, it
may be software, it may be on Red Hat it may be on you folks where the
problem arises, however there is a problem in there, it simply doesn't
work.

I understand how to reuse the existing tftp/dhcp infrastructure to allow
UEFI booting, in fact I wrote a patch to cobbler that enables just this:
https://github.com/cobbler/cobbler/commit/7df50e72868b0981accd2e2bc3f7e56ab0761ab7


All that being said I don't understand the subtle nuances of how all
this comes together, and to be honest I might not have the energy to
track it all down. UEFI boot works, sort of, as I said in the original
message, though clearly I was getting the terminology wrong,
http://lists.us.dell.com/pipermail/linux-poweredge/2012-July/046617.html. Now
the system may well be beyond the point that the failure is anything but
Red Hats problem, as the UEFI boot has worked pulled in the NBP, loaded
it up and pulled in the vmlinuz and initrd, and it then fails to do,
well, anything.

Have you folks configured UEFI boot on the 12th generation servers to
work against RHEL (and I assume centos would be the same)? So far I
haven't been able to track down anyone who has it working unless they
are using i/gPXE as their NBP.

So apologies for screwing up the terminology, and thanks for setting me
on the right track with that, as I said I was pretty fresh to this at
the beginning.

Let me know if you have had success booting with UEFI using the grub
image and the normal chain on Dell 12th generation servers, if you
haven't tried, would you? If I am able to get more people to
confirm/deny this issue it would be great. As is all of my systems have
failed, I have tried grabbing different GRUB images, etc. all to no avail.

-Erinn


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 554 bytes
Desc: OpenPGP digital signature
Url : http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20120726/2dac5560/attachment.bin 


More information about the Linux-PowerEdge mailing list