no dell_ie_rac_4 package for OMSA 7.0?

James Ralston qralston+ml.dell-poweredge at andrew.cmu.edu
Wed Jul 25 14:50:30 CDT 2012


The Dell OMSA 6.5.3 yum repository contains these two packages:

    dell_ie_rac_4-6.5.0-1.1.6.el5.x86_64.rpm
    dell_ie_rac_5-6.5.0-1.1.6.el5.x86_64.rpm

However, the OMAS 7.0 yum repository contains only:

    dell_ie_rac_5-7.0.0-4.1.8.el5.x86_64.rpm

Meaning, the dell_ie_rac_4 package isn't present for OMSA 7.0.

Because of this, updating srvadmin-racadm4 from 6.5.0 to 7.0 fails,
because dell_ie_rac_4 requires librac4.so.6()(64bit) that
srvadmin-racadm4-6.5.0-1.154.2.el5 provides:

$ yum update srvadmin-racadm4
...
--> Running transaction check
--> Processing Dependency: librac4.so.6()(64bit) for package: dell_ie_rac_4
---> Package srvadmin-racadm4.x86_64 0:7.0.0-4.163.1.el5 set to be updated
--> Finished Dependency Resolution
dell_ie_rac_4-6.5.0-1.1.6.el5.x86_64 from installed has depsolving problems
  --> Missing Dependency: librac4.so.6()(64bit) is needed by package dell_ie_rac_4-6.5.0-1.1.6.el5.x86_64 (installed)
Error: Missing Dependency: librac4.so.6()(64bit) is needed by package dell_ie_rac_4-6.5.0-1.1.6.el5.x86_64 (installed)

What's the deal here?  If dell_ie_rac_4 is deprecated in OMSA 7.0, why
isn't it properly Obsoleted/Conflicted in srvadmin-racadm4?  E.g.:

    Obsoletes: dell_ie_rac_4 < 7.0
    Conflicts: dell_ie_rac_4 < 7.0

If it's not obsoleted, where is the package?

I looked through the OMSA 7.0 release notes, but I don't see any
mention of this...



More information about the Linux-PowerEdge mailing list