update_firmware on CentOS 5.8. PER610

Brian Collins brianc at sedata.com
Thu Jul 19 12:06:52 CDT 2012


After reading these threads, we decided to uninstall srvadmin* and dell* prior to installing OM7.  So far, that has generated no errors when running 'update_firmware --yes'.  While for most software, running 'yum update' works, I think there are enough changes to the packages to justify doing a full remove first.

Only oddity I had was that we had 2 versions of PowerVault_RD1000_Internal_SATA_5_25__componentid_12731 installed, which made the updater go apoplectic.  But after I removed the older one we updated fine.
From: linux-poweredge-bounces at dell.com [mailto:linux-poweredge-bounces at dell.com] On Behalf Of Shaun Qualheim
Sent: Thursday, July 19, 2012 10:44 AM
To: Ernst Pijper
Cc: linux-poweredge at lists.us.dell.com
Subject: Re: update_firmware on CentOS 5.8. PER610

Sure enough, that was it.  Thanks so much. :)  Sorry if I missed that in an earlier message...
On Thu, Jul 19, 2012 at 10:40 AM, Ernst Pijper <ernst.pijper at sara.nl<mailto:ernst.pijper at sara.nl>> wrote:
Hi Shaun,

Does indeed look very much the same. Have a look at the output of the following command:

ls -l /usr/libexec/dell_dup/BROADCOM_FRMW/10-ignore-secupd.fdi

My guess is that it is a link to /usr/libexec/dell_dup/dell_ie_bios/10-ignore-secupd.fdi which no longer exists because it was part of a previous package that was replaced with an update. The package that originally created link this was also updated but the link was never removed. So just remove the link:

rm -f /usr/libexec/dell_dup/BROADCOM_FRMW/10-ignore-secupd.fdi

Ernst

On 07/19/2012 04:31 PM, Shaun Qualheim wrote:
Hi there folks -

This looks similar to a lot of what many others have going on, but I don't see anything that matches exactly, so...

After using yum to update to the latest everything in the repository, I'm seeing the following on update_firmware:

# update_firmware --yes

Running system inventory...

Searching storage directory for available BIOS updates...
Checking BIOS - 6.1.0
        Available: dell_dup_componentid_00159 - 6.1.0
        Did not find a newer package to install that meets all installation checks.
Checking MBE2147RC Firmware - d906
        Available: dell_dup_componentid_20515 - d906
        Did not find a newer package to install that meets all installation checks.
Checking SAS/SATA Backplane 0:0 Backplane Firmware - 1.07
        Available: dell_dup_componentid_11204 - 1.07
        Did not find a newer package to install that meets all installation checks.
Checking Dell Lifecycle Controller, v.1.5.1.57, A00 - 1.5.1.57
        Did not find a newer package to install that meets all installation checks.
Checking NetXtreme II BCM5709 Gigabit Ethernet rev 20 (eth1) - 6.2.12
        Available: pci_firmware(ven_0x14e4_dev_0x1639) - 6.2.16
        Found Update: pci_firmware(ven_0x14e4_dev_0x1639) - 6.2.16
Checking NetXtreme II BCM5709 Gigabit Ethernet rev 20 (eth0) - 6.2.12
        Available: pci_firmware(ven_0x14e4_dev_0x1639) - 6.2.16
        Found Update: pci_firmware(ven_0x14e4_dev_0x1639) - 6.2.16
Checking Dell OS Drivers Pack, v.6.5.3, A00 - 6.5.3
        Did not find a newer package to install that meets all installation checks.
Checking iDRAC6 - 1.80
        Available: dell_dup_componentid_20137 - 1.85
        Found Update: dell_dup_componentid_20137 - 1.85
Checking PERC H200I Controller 0 Firmware - 07.02.42.00
        Available: pci_firmware(ven_0x1000_dev_0x0072_subven_0x1028_subdev_0x1f1e) - 07.03.05.00
        Found Update: pci_firmware(ven_0x1000_dev_0x0072_subven_0x1028_subdev_0x1f1e) - 07.03.05.00
Checking System BIOS for PowerEdge R610 - 6.1.0
        Did not find a newer package to install that meets all installation checks.
Checking NetXtreme II BCM5709 Gigabit Ethernet rev 20 (eth2) - 6.2.12
        Available: pci_firmware(ven_0x14e4_dev_0x1639) - 6.2.16
        Found Update: pci_firmware(ven_0x14e4_dev_0x1639) - 6.2.16
Checking NetXtreme II BCM5709 Gigabit Ethernet rev 20 (eth3) - 6.2.12
        Available: pci_firmware(ven_0x14e4_dev_0x1639) - 6.2.16
        Found Update: pci_firmware(ven_0x14e4_dev_0x1639) - 6.2.16
Checking Dell 32 Bit Diagnostics, v.5154A0, 5154.1 - 5154a0
        Did not find a newer package to install that meets all installation checks.

Found firmware which needs to be updated.

Running updates...
-       Installing pci_firmware(ven_0x14e4_dev_0x1639) - 6.2.16Traceback (most recent call last):
  File "/usr/sbin/update_firmware", line 23, in ?
    ftmain.main(sys.argv[1:])
  File "/usr/share/firmware-tools/ftmain.py", line 109, in main
    result, resultmsgs = base.doCommands()
  File "<firmwaretools.peak_util_decorators.rewrap wrapping cli.doCommands at 0x1067F1B8>", line 3, in doCommands
  File "/usr/lib/python2.4/site-packages/firmwaretools/trace_decorator.py", line 81, in trace
    result = func(*args, **kw)
  File "/usr/share/firmware-tools/cli.py", line 134, in doCommands
    self.opts.mode, self.fullCmdLine, self.args)
  File "<firmwaretools.peak_util_decorators.rewrap wrapping update_cmd.doCommand at 0x108BDB90>", line 3, in doCommand
  File "/usr/lib/python2.4/site-packages/firmwaretools/trace_decorator.py", line 81, in trace
    result = func(*args, **kw)
  File "/usr/share/firmware-tools/plugins/update_cmd.py", line 69, in doCommand
    base.updateFirmware(base.opts.show_unknown)
  File "<firmwaretools.peak_util_decorators.rewrap wrapping cli.updateFirmware at 0x1067FA28>", line 3, in updateFirmware
  File "/usr/lib/python2.4/site-packages/firmwaretools/trace_decorator.py", line 81, in trace
    result = func(*args, **kw)
  File "/usr/share/firmware-tools/cli.py", line 214, in updateFirmware
    ret = firmwaretools.pycompat.runLongProcess(pkg.install, waitLoopFunction=statusFunc)
  File "<firmwaretools.peak_util_decorators.rewrap wrapping firmwaretools.pycompat.runLongProcess at 0x2B407AE3EA28>", line 3, in runLongProcess
  File "/usr/lib/python2.4/site-packages/firmwaretools/trace_decorator.py", line 81, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.4/site-packages/firmwaretools/pycompat.py", line 177, in runLongProcess
    raise thread.exception
shutil.Error: [('/usr/libexec/dell_dup/BROADCOM_FRMW/10-ignore-secupd.fdi', '/tmp/firmware_install-qUQoF/ie/10-ignore-secupd.fdi', <exceptions.IOError instance at 0x109eeb90>)]

Any ideas?

Thanks,
Shaun


_______________________________________________

Linux-PowerEdge mailing list

Linux-PowerEdge at dell.com<mailto:Linux-PowerEdge at dell.com>

https://lists.us.dell.com/mailman/listinfo/linux-poweredge


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20120719/ee78e303/attachment.html 


More information about the Linux-PowerEdge mailing list