Problem with bnx2 NICs & latest RHEL/CentOS kernel

Gaash Hazan gaash at qwilt.com
Thu Jul 12 10:06:59 CDT 2012


I've just installed centos 5.2 on R610. bnx2 NICs works well.

$ uname -a
Linux rd05.it.qwilt.com 2.6.32-279.el6.x86_64 #1 SMP Fri Jun 22
12:19:21 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

$modinfo  bnx2
filename:       /lib/modules/2.6.32-279.el6.x86_64/kernel/drivers/net/bnx2.ko
firmware:       bnx2/bnx2-rv2p-09ax-6.0.17.fw
firmware:       bnx2/bnx2-rv2p-09-6.0.17.fw
firmware:       bnx2/bnx2-mips-09-6.2.1b.fw
firmware:       bnx2/bnx2-rv2p-06-6.0.15.fw
firmware:       bnx2/bnx2-mips-06-6.2.3.fw
version:        2.2.1
license:        GPL
description:    Broadcom NetXtreme II BCM5706/5708/5709/5716 Driver
author:         Michael Chan <mchan at broadcom.com>
srcversion:     DD3C21C3B426C4D3E2A68B9
alias:          pci:v000014E4d0000163Csv*sd*bc*sc*i*
alias:          pci:v000014E4d0000163Bsv*sd*bc*sc*i*
alias:          pci:v000014E4d0000163Asv*sd*bc*sc*i*
alias:          pci:v000014E4d00001639sv*sd*bc*sc*i*
alias:          pci:v000014E4d000016ACsv*sd*bc*sc*i*
alias:          pci:v000014E4d000016AAsv*sd*bc*sc*i*
alias:          pci:v000014E4d000016AAsv0000103Csd00003102bc*sc*i*
alias:          pci:v000014E4d0000164Csv*sd*bc*sc*i*
alias:          pci:v000014E4d0000164Asv*sd*bc*sc*i*
alias:          pci:v000014E4d0000164Asv0000103Csd00003106bc*sc*i*
alias:          pci:v000014E4d0000164Asv0000103Csd00003101bc*sc*i*
depends:
vermagic:       2.6.32-279.el6.x86_64 SMP mod_unload modversions
parm:           disable_msi:Disable Message Signaled Interrupt (MSI) (int)


Gaash Hazan
Qwilt | M +972.54.4575.232 | gaash at qwilt.com


On Thu, Jul 12, 2012 at 6:01 PM, George Hills <george at brightbox.co.uk> wrote:
>
> Hallo,
>
> Is anyone using the kernel from RHEL / CentOS 6.3 and having trouble with bnx2 NICs in a Poweredge?
>
> I'm trying the EL 6.3 kernels (2.6.32-279 and 2.6.32-279.1.1) on a Poweredge R510 with built-in bnx2 NICs, and seeing link up, but no traffic passing.
>
> All the previous kernels were fine.
>
> I've tried changing to the bnx2 firmware from the previous kernel (no change)
>
> I've tried using the previous kernel with the kmod-bnx2 package (which includes the same bnx2 driver as the new kernel), and that works fine.
>
> Cheers
>
> --
> George Hills
> Systems Administrator
> Brightbox
>
> _______________________________________________
> Linux-PowerEdge mailing list
> Linux-PowerEdge at dell.com
> https://lists.us.dell.com/mailman/listinfo/linux-poweredge



More information about the Linux-PowerEdge mailing list