Disable bios protection of boot sector?

David Hubbard dhubbard at dino.hostasaurus.com
Thu Sep 22 22:39:58 CDT 2011


So I've recently run into an issue on both an R410 and SC1435 where the
systems had i386 CentOS 5 installed and then I overwrote them with a
64-bit CentOS 6 install.  Everything installed fine but at boot time it
would just hang.  I figured this had to be some leftovers from the grub
32-bit or whatever the case may be, tried a variety of tricks to wipe
out the boot sector including dd, no go.  Finally booted up 'parted
magic' and tried to do a secure erase on the hard drives as a last ditch
attempt to wipe out whatever is on there and it reported that the drive
could not be overwritten due to a bios lock.  Ah ha!  Some searching
online suggests this is a bios issue where the bios is trying to protect
the master boot record for things such as a virus infecting the computer
and trying to wipe out the boot sector.

Only problem is, I can find no way to disable this behavior in the Dell
Bios.  Any ideas?

Thanks,

Dave



More information about the Linux-PowerEdge mailing list