iDRAC6: undocumented settings for console com2

karasline at yahoo.com karasline at yahoo.com
Thu Sep 22 07:08:20 CDT 2011


Sorry, I haven't gotten back to you.  A hernia operation has left me flat on my back (literally).

The topology can be much simpler and still fail.  For example



A-sysadm desktop <-----> B=iDRAC6 


If A runs a vncviewer (either locally or on B's machine) and brings up a browser in the vncviewer, points the browser to B's iDRAC6, and launches the console, the keys will be mapped incorrectly.  Chuck Anderson (http://lists.us.dell.com/pipermail/linux-poweredge/2011-September/045264.html) wrote of one possible solution, but it only seems to address the arrow and sysreg keys.  With respect to the iDRAC6, all the keys appear to be mapped incorrectly when typing in any text window on the console within a VNC session.  Since the same situation work fine with the iDRAC5, I would think that this should be an issue Dell should correct.


Note that if one brings up the browser from A and points the browser to B's iDRAC6 (without using VNC), it works okay.  However, my actual situation is much more complicated which, because of network security on the gateway machine, prohibits port forwarding.

In addition to working on the iDRAC5, the VNC interface also works when using HP's iLo3.  So again, I think that this is a bug in Dell's iDRAC6 firmware.  Does anyone know the method for reporting this bug?



________________________________
From: Arthur Prokosch <arthurp at csail.mit.edu>
To: linux-poweredge at lists.us.dell.com
Sent: Tuesday, September 6, 2011 5:12 PM
Subject: Re: iDRAC6: undocumented settings for console com2

On Mon, Aug 29, 2011 at 06:04:27AM -0700, karasline at yahoo.com wrote:
> Did you by any chance see my post on the iDRAC6 and VNC
> (http://lists.us.dell.com/pipermail/linux-poweredge/2011-July/045028.html)? 
> I wasn't sure if your iDRAC6 issue was related to mine, but
> regardless, I still can't get the iDRAC6 console to work correctly
> within a VNC window.  Any thoughts?   

I did.  Our desire to use a serial console stems in part from how
cumbersome it can be to access DRACs located on a secure network --
which I expect has something to do with why you're having to use VNC.
So I guess in that sense our posts are related.

So, topology:
  A=Sysadmin's desktop  <--->  B=gateway  <--->  C=DRAC

You're using VNC for the link between "A" and "B", then running the
browser/java on "B".  So https and proprietary-applet-VNC are
connecting "B" and "C".  I don't know what OS your intermediate host
is running.  If *nix, you might check X11 keymaps and such.  Have you
tried switching the flavor of VNC software running on A and/or B?

We initiate an ssh connection to the intermediate host with port
forwarding, so that ports 443, 5900, and 5901 pass from A, through B
to C.  That is, if both A and B are *nix/Mac OS: 
  ssh gatewayhost -L 443:drac-host:443 -L 5900:drac-host:5900 -L 5901:drac-host:5901 -N
and then on my desktop, I point my browser to 
  https://localhost/

Would our approach be of use to you?

-arthur.

_______________________________________________
Linux-PowerEdge mailing list
Linux-PowerEdge at dell.com
https://lists.us.dell.com/mailman/listinfo/linux-poweredge
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20110922/f64a1cbe/attachment-0001.html 


More information about the Linux-PowerEdge mailing list