iDrac 6 firmware update not detected

Erinn Looney-Triggs erinn.looneytriggs at gmail.com
Tue Sep 20 15:21:35 CDT 2011


On 09/20/2011 12:18 PM, Jeffrey_L_Mendoza at Dell.com wrote:
>> Checking iDRAC6 - 1.54
>>         Available: dell_dup_componentid_20137 - 1.70
>>         Did not find a newer package to install that meets all
>> installation checks.
> Running update_firmware -v should provide some insight.
>
> -Jeff

Ok, don't know what it all means but here for your reading pleasure:

Checking Plugin (bootstrap_pci)
        Loaded bootstrap_pci plugin
Checking Plugin (bootstrap_cmd)
        Loaded bootstrap_cmd plugin
Checking Plugin (mock_inventory_bootstrap)
        Plugin mock_inventory_bootstrap not loaded: doesnt match load
type ((4,))
Checking Plugin (dell_ft_ie_interface)
        Loaded dell_ft_ie_interface plugin
Checking Plugin (update_cmd)
        Loaded update_cmd plugin
Checking Plugin (listplugins_cmd)
        Loaded listplugins_cmd plugin
Checking Plugin (dellbios)
        Loaded dellbios plugin
Checking Plugin (mock_repository)
        Plugin mock_repository not loaded: doesnt match load type ((4,))
Checking Plugin (inventory_cmd)
        Loaded inventory_cmd plugin
Checking Plugin (dellbios_extract)
        Plugin raised DisablePlugin exception. skipping.

Running system inventory...
verobse INFO: hi there
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_nic_broadcom-1.1.0
        Plugin command is dup_inv
        Output file is brcmfwinventory.xml
        Plugin timeout is 300
output from the cmd was:
<?xml version="1.0" encoding="UTF-8"?>
<SVMInventory lang="en">
        <Device vendorID="14e4" deviceID="1639" subVendorID="1028"
subDeviceID="0236" bus="1" device="0" function="0" display="NetXtreme II
BCM5709 Gigabit Ethernet rev 20 (eth0)">
                <Application componentType="FRMW" version="6.2.14"
display="NetXtreme II BCM5709 Gigabit Ethernet rev 20 (eth0)" />
        </Device>
        <Device vendorID="14e4" deviceID="1639" subVendorID="1028"
subDeviceID="0236" bus="1" device="0" function="1" display="NetXtreme II
BCM5709 Gigabit Ethernet rev 20 (eth1)">
                <Application componentType="FRMW" version="6.2.14"
display="NetXtreme II BCM5709 Gigabit Ethernet rev 20 (eth1)" />
        </Device>
        <Device vendorID="14e4" deviceID="1639" subVendorID="1028"
subDeviceID="0236" bus="2" device="0" function="0" display="NetXtreme II
BCM5709 Gigabit Ethernet rev 20 (eth2)">
                <Application componentType="FRMW" version="6.2.14"
display="NetXtreme II BCM5709 Gigabit Ethernet rev 20 (eth2)" />
        </Device>
        <Device vendorID="14e4" deviceID="1639" subVendorID="1028"
subDeviceID="0236" bus="2" device="0" function="1" display="NetXtreme II
BCM5709 Gigabit Ethernet rev 20 (eth3)">
                <Application componentType="FRMW" version="6.2.14"
display="NetXtreme II BCM5709 Gigabit Ethernet rev 20 (eth3)" />
        </Device>
</SVMInventory>

Added DEVICE:
pci_firmware(ven_0x14e4_dev_0x1639_subven_0x1028_subdev_0x0236)
Added DEVICE:
pci_firmware(ven_0x14e4_dev_0x1639_subven_0x1028_subdev_0x0236)
Added DEVICE:
pci_firmware(ven_0x14e4_dev_0x1639_subven_0x1028_subdev_0x0236)
Added DEVICE:
pci_firmware(ven_0x14e4_dev_0x1639_subven_0x1028_subdev_0x0236)
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_tape_ibm-1.1.0
        Plugin command is IbmDupwrapper -silent
        Output file is scsiInv.txt
        Plugin timeout is 500
output from the cmd was:
<?xml version="1.0" encoding="UTF-8"?>
<SVMInventory lang="en">
</SVMInventory>

Running IE Submodule for /usr/libexec/dell_dup/dell_ie_tape_prostor-1.1.0
        Plugin command is DUPwrapper -s -i inv.xml
        Output file is inv.xml
        Plugin timeout is 300
output from the cmd was:
<?xml version="1.0" encoding="UTF-8"?>
<SVMInventory lang="en">
</SVMInventory>

Running IE Submodule for /usr/libexec/dell_dup/dell_ie_tape_tandberg-1.1.0
        Plugin command is dupswrapper -c
        Output file is scsiInv.txt
        Plugin timeout is 400
output from the cmd was:
<SVMInventory lang="en">
</SVMInventory>

Running IE Submodule for /usr/libexec/dell_dup/dell_ie_nitrogen
        Plugin command is bmcie.sh -xml > inv.xml
        Output file is inv.xml
        Plugin timeout is 300
output from the cmd was:
<?xml version="1.0" encoding="UTF-8" ?>
<SVMInventory lang="en">
   <Device componentID="20137" display="iDRAC6">
      <Application componentType="FRMW" version="1.54" display="iDRAC6" />
   </Device>
</SVMInventory>

Added DEVICE: dell_dup_componentid_20137
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_tape_quantum-1.1.0
        Plugin command is pvtapeupgwrapper -c
        Output file is scsiInv.txt
        Plugin timeout is 500
output from the cmd was:
<?xml version="1.0" encoding="UTF-8"?>
<SVMInventory lang="en">
</SVMInventory>

Running IE Submodule for /usr/libexec/dell_dup/dell_ie_bios
        Plugin command is biosie.bin -i inv.xml
        Output file is inv.xml
        Plugin timeout is 300
output from the cmd was:
<?xml version="1.0" encoding="UTF-8" ?><SVMInventory lang="en"><Device
componentID= "159" display="BIOS"
impactsTPMmeasurements="TRUE"><Application componentType= "BIOS"
version="3.0.0" display = "BIOS" /></Device></SVMInventory>
Added DEVICE: dell_dup_componentid_00159
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_sas
        Plugin command is sasdupie -i -o inv.xml
        Output file is inv.xml
        Plugin timeout is 600
output from the cmd was:
<?xml version="1.0" encoding="UTF-8"?><SVMInventory lang="en"><Device
vendorID="1000" deviceID="0072" subDeviceID="1f1e" subVendorID="1028"
bus="3" device="0" function="0" display="PERC H200I Controller 0"
impactsTPMmeasurements="TRUE"><Application componentType="FRMW"
version="07.02.44.00" display="PERC H200I Controller 0
Firmware"/></Device><Device componentID="11204" enum="CtrlId 2000000
DeviceId 0 Backplane" display="SAS/SATA Backplane 0:0
Backplane"><Application componentType="FRMW" version="1.07"
display="SAS/SATA Backplane 0:0 Backplane Firmware"/></Device><Device
componentID="20607" enum="CtrlId 2000000 DeviceId 1"
display="ST9300603SS"><Application componentType="FRMW" version="FS64"
display="ST9300603SS Firmware"/></Device><Device componentID="20516"
enum="CtrlId 2000000 DeviceId 2" display="MBE2073RC"><Application
componentType="FRMW" version="D905" display="MBE2073RC
Firmware"/></Device><Device componentID="20516" enum="CtrlId 2000000
DeviceId 3" display="MBE2073RC"><Application componentType="FRMW"
version="D905" display="MBE2073RC Firmware"/></Device><Device
componentID="20607" enum="CtrlId 2000000 DeviceId 4"
display="ST9300603SS"><Application componentType="FRMW" version="FS64"
display="ST9300603SS Firmware"/></Device></SVMInventory>
Added DEVICE:
pci_firmware(ven_0x1000_dev_0x0072_subven_0x1028_subdev_0x1f1e)
Added DEVICE: dell_dup_componentid_11204
Added DEVICE: dell_dup_componentid_20607
Added DEVICE: dell_dup_componentid_20516
Added DEVICE: dell_dup_componentid_20516
Added DEVICE: dell_dup_componentid_20607

Searching storage directory for available BIOS updates...
Checking BIOS - 3.0.0
        Available: dell_dup_componentid_00159 - 3.0.0
        Did not find a newer package to install that meets all
installation checks.
Checking MBE2073RC Firmware - d905
        Available: dell_dup_componentid_20516 - d905
        Did not find a newer package to install that meets all
installation checks.
Checking SAS/SATA Backplane 0:0 Backplane Firmware - 1.07
        Available: dell_dup_componentid_11204 - 1.07
        Did not find a newer package to install that meets all
installation checks.
Checking NetXtreme II BCM5709 Gigabit Ethernet rev 20 (eth1) - 6.2.14
        Available: pci_firmware(ven_0x14e4_dev_0x1639) - 6.2.14
        Did not find a newer package to install that meets all
installation checks.
Checking NetXtreme II BCM5709 Gigabit Ethernet rev 20 (eth0) - 6.2.14
        Available: pci_firmware(ven_0x14e4_dev_0x1639) - 6.2.14
        Did not find a newer package to install that meets all
installation checks.
Checking iDRAC6 - 1.54
        Available: dell_dup_componentid_20137 - 1.70
        Did not find a newer package to install that meets all
installation checks.
Checking ST9300603SS Firmware - fs64
        Available: dell_dup_componentid_20607 - fs64
        Did not find a newer package to install that meets all
installation checks.
Checking PERC H200I Controller 0 Firmware - 07.02.44.00
        Available:
pci_firmware(ven_0x1000_dev_0x0072_subven_0x1028_subdev_0x1f1e) -
07.02.44.00
        Did not find a newer package to install that meets all
installation checks.
Checking System BIOS for PowerEdge R610 - 3.0.0
        Did not find a newer package to install that meets all
installation checks.
Checking NetXtreme II BCM5709 Gigabit Ethernet rev 20 (eth2) - 6.2.14
        Available: pci_firmware(ven_0x14e4_dev_0x1639) - 6.2.14
        Did not find a newer package to install that meets all
installation checks.
Checking NetXtreme II BCM5709 Gigabit Ethernet rev 20 (eth3) - 6.2.14
        Available: pci_firmware(ven_0x14e4_dev_0x1639) - 6.2.14
        Did not find a newer package to install that meets all
installation checks.

This system does not appear to have any updates available.
No action necessary.

Complete!




More information about the Linux-PowerEdge mailing list