PowerEdge R200 Error! XML Transformation failed and other errors

Trond Hasle Amundsen t.h.amundsen at usit.uio.no
Fri Sep 16 04:16:53 CDT 2011


Mgia <mgiashmera at lavabit.com> writes:

> Hello,
> This system runs OMSA 6.5.0 in a PowerEdge R200.
>
> I get to many of theses messages:
>
> Storage Error! No controllers found
>
> Problem running 'omreport chassis batteries': Error! XML Transformation
> failed
>
> Battery probe 9999 [Unknown location] is Unknown reading
>
> Problem running 'omreport chassis removableflashmedia': Error! XML
> Transformation failed
>
>>From /var/log/messages:
>
> kernel: omreport[18804]: segfault at 0000000018000000 rip
> 000000324de728ae rsp 00007fffcc56c6b0 error 4
>
>
> I'm running omreport via check_openmanage nagios plugin and I can see
> many open semaphores, which I delete regularly via a cronjob --since I
> haven't found a solution yet.
>
> I reinstalled OMSA and updated the RAID firmware to the latest versions.
>
> I have similar problems in other PowerEdge R200 servers is there a
> problem/known issue with this server model?

Hi Mgia,

I've seen the error "XML Transformation failed" once before. I think it
was due to a component that was in such a bad shape that OMSA couldn't
handle it. I can't remember which component.

In normal circumstances OMSA shouldn't leak semaphores. I think the
semaphore leakage may be caused by the error condition above. A segfault
in omreport would possibly lead to semaphores not being freed.

I would call Dell and have them replace the motherboard (or perhaps just
the CMOS battery). Replacing the faulty component with a healthy one may
be the solution to both issues.

Cheers,
-- 
Trond H. Amundsen <t.h.amundsen at usit.uio.no>
Center for Information Technology Services, University of Oslo



More information about the Linux-PowerEdge mailing list