error updating firmware on R410

Santosh_Gore at Dell.com Santosh_Gore at Dell.com
Fri Sep 9 01:01:13 CDT 2011


Hi 

Thanks for log files.  What is operating installed on the system?

Please perform following steps and send us SMAL_DBG.log file.
 
1. cd "/usr/libexec/dell_dup/dell_ie_maser_ic"
2. run "./MaserIE -i -d"

Thanks
Santosh

-----Original Message-----
From: Vincent Hoffman [mailto:vhoffman at names.co.uk] 
Sent: Wednesday, August 24, 2011 9:02 PM
To: Gore, Santosh
Cc: linux-poweredge-Lists
Subject: Re: error updating firmware on R410

On 23/08/2011 16:58, Santosh_Gore at Dell.com wrote:
> Hi 
>
> BIOS update is failing on system. please post output of "update_firmware --yes --verbose" command and the log file /var/log/firmware-updates.log.

Hi,
     See below.

[root at unassigned86.bmk.namesco.net ~]# update_firmware --yes --verbose
Checking Plugin (bootstrap_pci)
    Loaded bootstrap_pci plugin
Checking Plugin (bootstrap_cmd)
    Loaded bootstrap_cmd plugin
Checking Plugin (mock_inventory_bootstrap)
    Plugin mock_inventory_bootstrap not loaded: doesnt match load type
((4,))
Checking Plugin (dell_ft_ie_interface)
    Loaded dell_ft_ie_interface plugin
Checking Plugin (update_cmd)
    Loaded update_cmd plugin
Checking Plugin (listplugins_cmd)
    Loaded listplugins_cmd plugin
Checking Plugin (dellbios)
    Loaded dellbios plugin
Checking Plugin (mock_repository)
    Plugin mock_repository not loaded: doesnt match load type ((4,))
Checking Plugin (inventory_cmd)
    Loaded inventory_cmd plugin
Checking Plugin (dellbios_extract)
    Plugin raised DisablePlugin exception. skipping.

Running system inventory...
verobse INFO: hi there
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_imc
    Module not for this system, disabling module.
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_tape_ibm-1.1.0
    Plugin command is IbmDupwrapper -silent
    Output file is scsiInv.txt
    Plugin timeout is 500
output from the cmd was:
<?xml version="1.0" encoding="UTF-8"?>
<SVMInventory lang="en">
</SVMInventory>

Running IE Submodule for /usr/libexec/dell_dup/dell_ie_nic_broadcom-1.1.0
    Plugin command is dup_inv
    Output file is brcmfwinventory.xml
    Plugin timeout is 300
output from the cmd was:
<?xml version="1.0" encoding="UTF-8"?>
<SVMInventory lang="en">
    <Device vendorID="14e4" deviceID="163b" subVendorID="1028"
subDeviceID="028c" bus="1" device="0" function="0" display="NetXtreme II
BCM5716 Gigabit Ethernet rev 20 (eth0)">
        <Application componentType="FRMW" version="6.0.1"
display="NetXtreme II BCM5716 Gigabit Ethernet rev 20 (eth0)" />
    </Device>
    <Device vendorID="14e4" deviceID="163b" subVendorID="1028"
subDeviceID="028c" bus="1" device="0" function="1" display="NetXtreme II
BCM5716 Gigabit Ethernet rev 20 (eth1)">
        <Application componentType="FRMW" version="6.0.1"
display="NetXtreme II BCM5716 Gigabit Ethernet rev 20 (eth1)" />
    </Device>
</SVMInventory>

Added DEVICE:
pci_firmware(ven_0x14e4_dev_0x163b_subven_0x1028_subdev_0x028c)
Added DEVICE:
pci_firmware(ven_0x14e4_dev_0x163b_subven_0x1028_subdev_0x028c)
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_bp-1.1.0
    Module not for this system, disabling module.
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_bmc-1.1.0
    Module not for this system, disabling module.
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_rac_5
    Module not for this system, disabling module.
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_tape_prostor-1.1.0
    Plugin command is DUPwrapper -s -i inv.xml
    Output file is inv.xml
    Plugin timeout is 300
output from the cmd was:
<?xml version="1.0" encoding="UTF-8"?>
<SVMInventory lang="en">
</SVMInventory>

Running IE Submodule for /usr/libexec/dell_dup/dell_ie_nitrogen
    Plugin command is bmcie.sh -xml > inv.xml
    Output file is inv.xml
    Plugin timeout is 300
output from the cmd was:
<?xml version="1.0" encoding="UTF-8" ?>
<SVMInventory lang="en">
   <Device componentID="20137" display="iDRAC6">
      <Application componentType="FRMW" version="1.54" display="iDRAC6" />
   </Device>
</SVMInventory>

Added DEVICE: dell_dup_componentid_20137
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_tape_tandberg-1.1.0
    Plugin command is dupswrapper -c
    Output file is scsiInv.txt
    Plugin timeout is 400
output from the cmd was:
<SVMInventory lang="en">
</SVMInventory>

Running IE Submodule for /usr/libexec/dell_dup/dell_ie_maser_ic
    Plugin command is MaserApp.sh -i -o=inv.xml
    Output file is inv.xml
    Plugin timeout is 1200
output from the cmd was:
<?xml version="1.0" encoding="UTF-8" ?><SVMInventory lang="en"><SPStatus
result = "false"><Message id="1"> Inventory Failure: This Operating
System is not supported</Message></SPStatus></SVMInventory>

Running IE Submodule for /usr/libexec/dell_dup/dell_ie_bios
    Plugin command is biosie.bin -i inv.xml
    Output file is inv.xml
    Plugin timeout is 300
output from the cmd was:
<?xml version="1.0" encoding="UTF-8" ?><SVMInventory lang="en"><Device
componentID= "159" display="BIOS"
impactsTPMmeasurements="TRUE"><Application componentType= "BIOS"
version="1.5.3" display = "BIOS" /></Device></SVMInventory>
Added DEVICE: dell_dup_componentid_00159
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_sas
    Plugin command is sasdupie -i -o inv.xml
    Output file is inv.xml
    Plugin timeout is 600
output from the cmd was:
<?xml version="1.0" encoding="UTF-8"?><SVMInventory lang="en"><Device
vendorID="1000" deviceID="0079" subDeviceID="1f16" subVendorID="1028"
bus="3" device="0" function="0" display="PERC H700 Adapter Controller 0"
impactsTPMmeasurements="TRUE"><Application componentType="FRMW"
version="12.10.0-0025" display="PERC H700 Adapter Controller 0
Firmware"/></Device><Device componentID="24882" enum="CtrlId 0 DeviceId
0" display="SAMSUNG HE502HJ"><Application componentType="FRMW"
version="0001" display="SAMSUNG HE502HJ Firmware"/></Device><Device
componentID="24882" enum="CtrlId 0 DeviceId 1" display="SAMSUNG
HE502HJ"><Application componentType="FRMW" version="0001"
display="SAMSUNG HE502HJ Firmware"/></Device></SVMInventory>
Added DEVICE:
pci_firmware(ven_0x1000_dev_0x0079_subven_0x1028_subdev_0x1f16)
Added DEVICE: dell_dup_componentid_24882
Added DEVICE: dell_dup_componentid_24882
Running IE Submodule for /usr/libexec/dell_dup/dell_ie_tape_quantum-1.1.0
    Plugin command is pvtapeupgwrapper -c
    Output file is scsiInv.txt
    Plugin timeout is 500
output from the cmd was:
<?xml version="1.0" encoding="UTF-8"?>
<SVMInventory lang="en">
</SVMInventory>


Searching storage directory for available BIOS updates...
Checking BIOS - 1.5.3
    Available: dell_dup_componentid_00159 - 1.6.3
    Found Update: dell_dup_componentid_00159 - 1.6.3
Checking NetXtreme II BCM5716 Gigabit Ethernet rev 20 (eth1) - 6.0.1
    Available: pci_firmware(ven_0x14e4_dev_0x163b) - 6.2.14
    Found Update: pci_firmware(ven_0x14e4_dev_0x163b) - 6.2.14
Checking NetXtreme II BCM5716 Gigabit Ethernet rev 20 (eth0) - 6.0.1
    Available: pci_firmware(ven_0x14e4_dev_0x163b) - 6.2.14
    Found Update: pci_firmware(ven_0x14e4_dev_0x163b) - 6.2.14
Checking SAMSUNG HE502HJ Firmware - 0001
    Did not find a newer package to install that meets all installation
checks.
Checking iDRAC6 - 1.54
    Available: dell_dup_componentid_20137 - 1.70
    Found Update: dell_dup_componentid_20137 - 1.70
Checking PERC H700 Adapter Controller 0 Firmware - 12.10.0-0025
    Available:
pci_firmware(ven_0x1000_dev_0x0079_subven_0x1028_subdev_0x1f16) -
12.10.1-0001
    Found Update:
pci_firmware(ven_0x1000_dev_0x0079_subven_0x1028_subdev_0x1f16) -
12.10.1-0001
Checking System BIOS for PowerEdge R410 - 1.5.3
    Did not find a newer package to install that meets all installation
checks.

Found firmware which needs to be updated.

Running updates...
hey, we are supposed to be installing now... :)
/    Installing dell_dup_componentid_00159 - 1.6.3loading xml from:
/usr/libexec/dell_dup/BIOS_NONE/PIEConfig.xml
loaded.
    Plugin command is biosie.bin -u update.xml
    Output file is update.xml
    Plugin timeout is 600
-    Installing dell_dup_componentid_00159 - 1.6.3[Errno 2] No such file
or directory: u'/tmp/firmware_installRXhR2Z/ie/update.xml'
None
[Errno 2] No such file or directory:
u'/tmp/firmware_installRXhR2Z/ie/update.xml'

And
[root at unassigned86.bmk.namesco.net ~]# cat /var/log/firmware-updates.log
2011-08-24 17:27:00,063: Attempting Firmware Update
2011-08-24 17:27:00,064: Attempted by user: root
2011-08-24 17:27:00,064: Package name: dell_dup_componentid_00159
2011-08-24 17:27:00,064: Package display name: Server BIOS 11G
2011-08-24 17:27:00,064: Package version: 1.6.3
2011-08-24 17:27:00,065: Devices:
2011-08-24 17:27:00,065: Device name: dell_dup_componentid_00159
2011-08-24 17:27:00,065: Device display name: BIOS
2011-08-24 17:27:00,065: Device version: 1.5.3
2011-08-24 17:27:00,122: Update result: The device is being updated now
2011-08-24 17:29:51,642: Attempting Firmware Update
2011-08-24 17:29:51,643: Attempted by user: root
2011-08-24 17:29:51,643: Package name: dell_dup_componentid_00159
2011-08-24 17:29:51,643: Package display name: Server BIOS 11G
2011-08-24 17:29:51,644: Package version: 1.6.3
2011-08-24 17:29:51,644: Devices:
2011-08-24 17:29:51,644: Device name: dell_dup_componentid_00159
2011-08-24 17:29:51,644: Device display name: BIOS
2011-08-24 17:29:51,644: Device version: 1.5.3
2011-08-24 17:29:51,699: Update result: The device is being updated now


I se from the various other answers this is not uncommon though.

Thanks,
Vince


>
> Thanks
> Santosh
> -----Original Message-----
> From: linux-poweredge-bounces-Lists On Behalf Of Vincent Hoffman
> Sent: Tuesday, August 23, 2011 6:01 PM
> To: linux-poweredge-Lists
> Subject: error updating firmware on R410
>
> Hi,
>     We just got 10 R410s and I wanted them up to date before we deploy
> them. I've been trying to update the various firmwares via the command
> line tools and am getting an error of
> Could not parse output, bad xml for package: dell_dup_componentid_00159
>
>
> I installed the repo using
> wget -q -O - http://linux.dell.com/repo/hardware/latest/bootstrap.cgi | bash
> following which I ran
> [root at r410 db] yum install dell_ft_install
> [root at r410 db] yum install $(bootstrap_firmware)
> then
> [root at r410 db]# update_firmware --yes
>
> Running system inventory...
>
> Searching storage directory for available BIOS updates...
> Checking BIOS - 1.5.3
>     Available: dell_dup_componentid_00159 - 1.6.3
>     Found Update: dell_dup_componentid_00159 - 1.6.3
> Checking NetXtreme II BCM5716 Gigabit Ethernet rev 20 (eth1) - 6.0.1
>     Available: pci_firmware(ven_0x14e4_dev_0x163b) - 6.2.14
>     Found Update: pci_firmware(ven_0x14e4_dev_0x163b) - 6.2.14
> Checking NetXtreme II BCM5716 Gigabit Ethernet rev 20 (eth0) - 6.0.1
>     Available: pci_firmware(ven_0x14e4_dev_0x163b) - 6.2.14
>     Found Update: pci_firmware(ven_0x14e4_dev_0x163b) - 6.2.14
> Checking SAMSUNG HE502HJ Firmware - 0001
>     Did not find a newer package to install that meets all installation
> checks.
> Checking iDRAC6 - 1.54
>     Available: dell_dup_componentid_20137 - 1.70
>     Found Update: dell_dup_componentid_20137 - 1.70
> Checking PERC H700 Adapter Controller 0 Firmware - 12.10.0-0025
>     Available:
> pci_firmware(ven_0x1000_dev_0x0079_subven_0x1028_subdev_0x1f16) -
> 12.10.1-0001
>     Found Update:
> pci_firmware(ven_0x1000_dev_0x0079_subven_0x1028_subdev_0x1f16) -
> 12.10.1-0001
> Checking System BIOS for PowerEdge R410 - 1.5.3
>     Did not find a newer package to install that meets all installation
> checks.
>
> Found firmware which needs to be updated.
>
> Running updates...
> \    Installing dell_dup_componentid_00159 - 1.6.3Installation failed
> for package: dell_dup_componentid_00159 - 1.6.3
> aborting update...
>
> The error message from the low-level command was:
>
> Could not parse output, bad xml for package: dell_dup_componentid_00159
>
>
> Any suggestions welcome, I'm quite new to the Dell tools so point me at
> docs if i'm doing something wrong.
>
> Thanks,
> Vince
>
> _______________________________________________
> Linux-PowerEdge mailing list
> Linux-PowerEdge at dell.com
> https://lists.us.dell.com/mailman/listinfo/linux-poweredge



More information about the Linux-PowerEdge mailing list