omreport segfault and OMSA with nagios many semaphore

Mgia mgiashmera at lavabit.com
Thu Sep 8 10:48:54 CDT 2011


Hello,

I'm trying long time to get OMSA work in some PowerEdge R200 with
similar configuration and OS CentOS. So once again my journey :)

I am seeing a lot of segfault messages regarding omreport
in /var/log/messages

kernel: omreport[13681]: segfault at 0000000000000000 rip
0000003861a795d2 rsp 00007fff05c18e18 error 4

Additionally I use a nagios plugin via nrpe to monitor OMSA and this
produces a lot of nagios semaphore (as I can check with ipcs command).
Since I don't think that is related with the plugin (I have used other
plugin) I tried once again to update the firmware of the storage
controller.

OMSA output
----------
Name                                          : SAS 6/iR Adapter
State                                         : Degraded
Firmware Version                              : 00.20.46.00.06.14.10.00
Minimum Required Firmware Version             : 00.25.47.00.06.22.03.00


I tried to update the firmware via:

1. OMSA repo instructions http://linux.dell.com/repo/hardware/latest/

$ yum install dell_ft_install
$ yum install $(bootstrap_firmware)
$ update_firmware -y

but it fails with the following errors:
Installing
pci_firmware(ven_0x1000_dev_0x0058_subven_0x1028_subdev_ ...[Errno 2]
File or folder not found: u'/tmp/firmware_installIU9ZZt/ie/update.xml'

2. Dell support site

Running as root the appropriate firmware, once again fails with the
following errors:

/tmp/RAID_FRMW_LX_R197382.BIN-1485-15339/spsetup.sh: line
1575: ./getSystemId: Keine Berechtigung (No permission)
Collecting inventory...
/tmp/RAID_FRMW_LX_R197382.BIN-1485-15339/spsetup.sh: line
888: ./sasdupie: Keine Berechtigung (No permission)

Inventory collection failed.


Please let me know if you have any idea or what else I can do to make
OMSA stable.

Thanks
-- 
Mgia




More information about the Linux-PowerEdge mailing list