OMSA 6.4 upgrade problems

Vaibhav_Kumar at Dell.com Vaibhav_Kumar at Dell.com
Fri Feb 11 00:29:28 CST 2011


If your RHEL is of 32-bit arch or 64-bit arch and you want to have 32-bit OpenManage, then navigate to i386 folder of OM 6.4 and upgrade opensource components by executing "rpm -Uvh *.rpm --force"

If your RHEL is of 64-bit arch and you want to have 64-bit OpenManage, then uninstall all 6.2 RPMs including all opensource rpms like sfcb, sfcc, openwsman-server, libcmpi, libwsman etc, and then fresh install 64-bit OM 6.4 including new opensource RPMs.

Regards
-Vaibhav

From: linux-poweredge-bounces-Lists On Behalf Of Jeremiah D. Jester
Sent: Friday, February 11, 2011 2:42 AM
To: linux-poweredge-Lists
Subject: OMSA 6.4 upgrade problems

I'm running RHEL5 w/ OMSA v6.2 and attempting to upgrade to 6.4. I've attemped upgrading and uninstalling 6.2 but keep getting conlicts, as seen below. Any insight would be appreciated. See cmd history for more info.

Thanks,
JJ


[root at monk x86_64]# rpm -ivh *rpm
warning: libcmpiCppImpl0-2.0.0Dell-1.3.el5.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 23b66a9d
Preparing...                ########################################### [100%]
        package libwsman1-2.2.3.9-1.5.3.el5.x86_64 is already installed
        package sblim-sfcc-2.2.1-47.el5.i386 (which is newer than sblim-sfcc-2.2.1-1.4.1.el5.x86_64) is already installed
        package libcmpiCppImpl0-2.0.0Dell-1.3.el5.x86_64 is already installed
        package openwsman-client-2.2.3.9-1.5.3.el5.x86_64 is already installed
        file /etc/init.d/openwsmand from install of openwsman-server-2.2.3.9-1.5.3.el5.x86_64 conflicts with file from package openwsman-server-2.1.5Dell-2.1.el5.i386
        file /etc/openwsman/openwsman.conf from install of openwsman-server-2.2.3.9-1.5.3.el5.x86_64 conflicts with file from package openwsman-server-2.1.5Dell-2.1.el5.i386
        file /etc/pam.d/openwsman from install of openwsman-server-2.2.3.9-1.5.3.el5.x86_64 conflicts with file from package openwsman-server-2.1.5Dell-2.1.el5.i386
        file /etc/init.d/sfcb from install of sblim-sfcb-1.3.7-1.4.2.el5.x86_64 conflicts with file from package sblim-sfcb-1.3.2Dell-9.1.el5.i386
        file /etc/pam.d/sfcb from install of sblim-sfcb-1.3.7-1.4.2.el5.x86_64 conflicts with file from package sblim-sfcb-1.3.2Dell-9.1.el5.i386
        file /etc/sfcb/sfcb.cfg from install of sblim-sfcb-1.3.7-1.4.2.el5.x86_64 conflicts with file from package sblim-sfcb-1.3.2Dell-9.1.el5.i386
        file /usr/bin/sfcbrepos from install of sblim-sfcb-1.3.7-1.4.2.el5.x86_64 conflicts with file from package sblim-sfcb-1.3.2Dell-9.1.el5.i386
        file /usr/bin/wbemcat from install of sblim-sfcb-1.3.7-1.4.2.el5.x86_64 conflicts with file from package sblim-sfcb-1.3.2Dell-9.1.el5.i386
        file /usr/share/man/man1/genSslCert.1.gz from install of sblim-sfcb-1.3.7-1.4.2.el5.x86_64 conflicts with file from package sblim-sfcb-1.3.2Dell-9.1.el5.i386
        file /usr/share/man/man1/getSchema.1.gz from install of sblim-sfcb-1.3.7-1.4.2.el5.x86_64 conflicts with file from package sblim-sfcb-1.3.2Dell-9.1.el5.i386
        file /usr/share/man/man1/sfcbd.1.gz from install of sblim-sfcb-1.3.7-1.4.2.el5.x86_64 conflicts with file from package sblim-sfcb-1.3.2Dell-9.1.el5.i386
        file /usr/share/man/man1/sfcbrepos.1.gz from install of sblim-sfcb-1.3.7-1.4.2.el5.x86_64 conflicts with file from package sblim-sfcb-1.3.2Dell-9.1.el5.i386
        file /usr/share/man/man1/sfcbstage.1.gz from install of sblim-sfcb-1.3.7-1.4.2.el5.x86_64 conflicts with file from package sblim-sfcb-1.3.2Dell-9.1.el5.i386
        file /usr/share/man/man1/sfcbunstage.1.gz from install of sblim-sfcb-1.3.7-1.4.2.el5.x86_64 conflicts with file from package sblim-sfcb-1.3.2Dell-9.1.el5.i386
        file /usr/share/man/man1/sfcbuuid.1.gz from install of sblim-sfcb-1.3.7-1.4.2.el5.x86_64 conflicts with file from package sblim-sfcb-1.3.2Dell-9.1.el5.i386
        file /usr/share/man/man1/wbemcat.1.gz from install of sblim-sfcb-1.3.7-1.4.2.el5.x86_64 conflicts with file from package sblim-sfcb-1.3.2Dell-9.1.el5.i386
        file /usr/share/man/man1/xmltest.1.gz from install of sblim-sfcb-1.3.7-1.4.2.el5.x86_64 conflicts with file from package sblim-sfcb-1.3.2Dell-9.1.el5.i386
        file /usr/share/sfcb/default.reg from install of sblim-sfcb-1.3.7-1.4.2.el5.x86_64 conflicts with file from package sblim-sfcb-1.3.2Dell-9.1.el5.i386
        file /usr/share/sfcb/genSslCert.sh from install of sblim-sfcb-1.3.7-1.4.2.el5.x86_64 conflicts with file from package sblim-sfcb-1.3.2Dell-9.1.el5.i386
        file /usr/share/sfcb/getSchema.sh from install of sblim-sfcb-1.3.7-1.4.2.el5.x86_64 conflicts with file from package sblim-sfcb-1.3.2Dell-9.1.el5.i386
        file /usr/share/sfcb/indication.mof from install of sblim-sfcb-1.3.7-1.4.2.el5.x86_64 conflicts with file from package sblim-sfcb-1.3.2Dell-9.1.el5.i386
        file /var/lib/sfcb/stage/default.reg from install of sblim-sfcb-1.3.7-1.4.2.el5.x86_64 conflicts with file from package sblim-sfcb-1.3.2Dell-9.1.el5.i386
        file /var/lib/sfcb/stage/mofs/indication.mof from install of sblim-sfcb-1.3.7-1.4.2.el5.x86_64 conflicts with file from package sblim-sfcb-1.3.2Dell-9.1.el5.i386

[root at monk x86_64]# rpm -e openwsman-server-2.1.5Dell-2.1.el5
[root at monk x86_64]# rpm -q openwsman-server
package openwsman-server is not installed
[root at monk x86_64]# rpm -ivh openwsman-server-2.2.3.9-1.5.3.el5.x86_64.rpm
warning: openwsman-server-2.2.3.9-1.5.3.el5.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 23b66a9d
error: Failed dependencies:
        libcmpisfcc.so.1()(64bit) is needed by openwsman-server-2.2.3.9-1.5.3.el5.x86_64
        libcmpisfcc.so.1(CMPISFCC_2.0)(64bit) is needed by openwsman-server-2.2.3.9-1.5.3.el5.x86_64

[root at monk x86_64]# rpm -ivh libcmpiCppImpl0-2.0.0Dell-1.3.el5.x86_64.rpm
warning: libcmpiCppImpl0-2.0.0Dell-1.3.el5.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 23b66a9d
Preparing...                ########################################### [100%]
        package libcmpiCppImpl0-2.0.0Dell-1.3.el5.x86_64 is already installed
[root at monk x86_64]# rpm -ivh openwsman-server-2.2.3.9-1.5.3.el5.x86_64.rpm
warning: openwsman-server-2.2.3.9-1.5.3.el5.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 23b66a9d
error: Failed dependencies:
        libcmpisfcc.so.1()(64bit) is needed by openwsman-server-2.2.3.9-1.5.3.el5.x86_64
        libcmpisfcc.so.1(CMPISFCC_2.0)(64bit) is needed by openwsman-server-2.2.3.9-1.5.3.el5.x86_64

Jeremiah Jester
Informatics Specialist
Microbiology - Katze Lab
206-732-6185

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.us.dell.com/pipermail/linux-poweredge/attachments/20110211/2ff57d6d/attachment-0001.htm 


More information about the Linux-PowerEdge mailing list