OpenManage 6.4 for Ubuntu/Debian posted

Prudhvi_Tella at Dell.com Prudhvi_Tella at Dell.com
Wed Feb 2 11:50:57 CST 2011


Try completely removing sara dellomsa. If that doesn't work, you can set -x in /var/lib/dpkg/info/srvadmin-isvc.postinst. The postinst runs regsiter script and creates a symbolic link:
/opt/dell/srvadmin/lib/srvadmin-isvc/register-isvc.sh
[ ! -e /usr/share/pci.ids -a -e /usr/share/hwdata/pci.ids ] && ln -s /usr/share/hwdata/pci.ids /usr/share
________________________________________
From: Johan Sjöberg [johan.sjoberg at deltamanagement.se]
Sent: Wednesday, February 02, 2011 12:20 AM
To: Tella, Prudhvi; linux-poweredge-Lists
Subject: RE: OpenManage 6.4 for Ubuntu/Debian posted

Hi.

Thanks for your reply.
I have tried on another Debian machine, 32-bit this time, and got the same error. Could this be because we earlier had the dellomsa package from sara installed? Is there some way to get more detail about what is failing in the configure script?

Best regards,
Johan

> -----Original Message-----
> From: linux-poweredge-bounces at dell.com [mailto:linux-poweredge-
> bounces at dell.com] On Behalf Of Prudhvi_Tella at dell.com
> Sent: den 1 februari 2011 22:32
> To: linux-poweredge at lists.us.dell.com
> Subject: RE: OpenManage 6.4 for Ubuntu/Debian posted
>
> I am able to install srvadmin-base in Debian Squeeze without any errors and
> couldn't reproduce the error you got. You can try reinstalling srvadmin
> components:
>
> 1. apt-get purge --auto-remove srvadmin-base
> 2. apt-get remove libsmbios*, if it is not removed
> 3. apt-get install srvadmin-base
>
> -----Original Message-----
> From: Johan Sj?berg <johan.sjoberg at deltamanagement.se>
> Subject: RE: OpenManage 6.4 for Ubuntu/Debian posted
> To: "Linux-PowerEdge at dell.com" <Linux-PowerEdge at dell.com>
> Message-ID:
>       <B08F3F3D67451844A7A8A029FCC71E4C18F4A3E851 at WIN01.a
> d.deltamanagement.se>
>
> Content-Type: text/plain; charset="iso-8859-1"
>
> Hi. I tried installing this on a PE1950 with Debian Squeeze, running kernel
> 2.6.32. I am having some trouble because the configuration of the srvadmin-
> isvc package fails. I have installed the smbios-utils package from the
> repository but I cannot get it to work. The error message doesn't really tell
> me much about the cause of the problems. Is it because the server is
> running Squeeze? Below is the output from the apt-get srvadmin-base.
>
> /Johan
>
> # apt-get install srvadmin-base
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> The following extra packages will be installed:
>   srvadmin-deng srvadmin-hapi srvadmin-isvc srvadmin-omacore srvadmin-
> omcommon srvadmin-omilcore srvadmin-smcommon
>   srvadmin-xmlsup
> The following NEW packages will be installed:
>   srvadmin-base srvadmin-deng srvadmin-hapi srvadmin-isvc srvadmin-
> omacore srvadmin-omcommon srvadmin-omilcore
>   srvadmin-smcommon srvadmin-xmlsup
> 0 upgraded, 9 newly installed, 0 to remove and 327 not upgraded.
> Need to get 0B/5,205kB of archives.
> After this operation, 30.8MB of additional disk space will be used.
> Do you want to continue [Y/n]?
> WARNING: The following packages cannot be authenticated!
>   srvadmin-omilcore srvadmin-deng srvadmin-hapi srvadmin-isvc srvadmin-
> omcommon srvadmin-xmlsup srvadmin-omacore
>   srvadmin-smcommon srvadmin-base
> Install these packages without verification [y/N]? y Selecting previously
> deselected package srvadmin-omilcore.
> (Reading database ... 35229 files and directories currently installed.)
> Unpacking srvadmin-omilcore (from .../srvadmin-omilcore_6.4.0-1_all.deb)
> ...
> Selecting previously deselected package srvadmin-deng.
> Unpacking srvadmin-deng (from .../srvadmin-deng_6.4.0-1_amd64.deb) ...
> Selecting previously deselected package srvadmin-hapi.
> Unpacking srvadmin-hapi (from .../srvadmin-hapi_6.4.0-1_amd64.deb) ...
> Selecting previously deselected package srvadmin-isvc.
> Unpacking srvadmin-isvc (from .../srvadmin-isvc_6.4.0-1_amd64.deb) ...
> Selecting previously deselected package srvadmin-omcommon.
> Unpacking srvadmin-omcommon (from .../srvadmin-omcommon_6.4.0-
> 1_amd64.deb) ...
> Selecting previously deselected package srvadmin-xmlsup.
> Unpacking srvadmin-xmlsup (from .../srvadmin-xmlsup_6.4.0-1_amd64.deb)
> ...
> Selecting previously deselected package srvadmin-omacore.
> Unpacking srvadmin-omacore (from .../srvadmin-omacore_6.4.0-
> 1_amd64.deb) ...
> Selecting previously deselected package srvadmin-smcommon.
> Unpacking srvadmin-smcommon (from .../srvadmin-smcommon_6.4.0-
> 1_amd64.deb) ...
> Selecting previously deselected package srvadmin-base.
> Unpacking srvadmin-base (from .../srvadmin-base_6.4.0-1_amd64.deb) ...
> Setting up srvadmin-omilcore (6.4.0-1) ...
>      **********************************************************
>      After the install process completes, you may need
>      to log out and then log in again to reset the PATH
>      variable to access the Dell OpenManage CLI utilities
>      **********************************************************
> Setting up srvadmin-deng (6.4.0-1) ...
> update-rc.d: using dependency based boot sequencing
> update-rc.d: warning: dataeng start runlevel arguments (2 3 4 5) do not
> match LSB Default-Start values (3 4 5)
> update-rc.d: warning: dataeng stop runlevel arguments (0 1 6) do not match
> LSB Default-Stop values (1 2) Setting up srvadmin-hapi (6.4.0-1) ...
> Setting up srvadmin-isvc (6.4.0-1) ...
> dpkg: error processing srvadmin-isvc (--configure):
>  subprocess installed post-installation script returned error exit status 255
> Setting up srvadmin-omcommon (6.4.0-1) ...
> Setting up srvadmin-xmlsup (6.4.0-1) ...
> dpkg: dependency problems prevent configuration of srvadmin-omacore:
>  srvadmin-omacore depends on srvadmin-isvc; however:
>   Package srvadmin-isvc is not configured yet.
> dpkg: error processing srvadmin-omacore (--configure):
>  dependency problems - leaving unconfigured Setting up srvadmin-
> smcommon (6.4.0-1) ...
> dpkg: dependency problems prevent configuration of srvadmin-base:
>  srvadmin-base depends on srvadmin-isvc (>= 6.4.0-1); however:
>   Package srvadmin-isvc is not configured yet.
>  srvadmin-base depends on srvadmin-omacore (>= 6.4.0-1); however:
>   Package srvadmin-omacore is not configured yet.
> dpkg: error processing srvadmin-base (--configure):
>  dependency problems - leaving unconfigured Errors were encountered
> while processing:
>  srvadmin-isvc
>  srvadmin-omacore
>  srvadmin-base
> E: Sub-process /usr/bin/dpkg returned an error code (1)
>
> > -----Original Message-----
> > From: linux-poweredge-bounces at dell.com [mailto:linux-poweredge-
> > bounces at dell.com] On Behalf Of Prudhvi_Tella at dell.com
> > Sent: den 13 januari 2011 22:00
> > To: linux-poweredge at lists.us.dell.com
> > Subject: OpenManage 6.4 for Ubuntu/Debian posted
> >
> > OpenManage 6.4 for Ubuntu/Debian is now available for download. At the
> > moment, only 64-bit packages are available.
> > We are still working on 32-bit packages and will update once they are
> posted.
> >
> > http://linux.dell.com/repo/community/deb/latest/
> > http://en.community.dell.com/dell-blogs/enterprise/b/tech-
> > center/archive/2011/01/13/dell-openmanage-server-administrator-6-4-
> for
> > -
> > ubuntu.aspx
> >
> > The above blog post goes into detail about this release.
> >
> > -Prudhvi Tella
> >
> > _______________________________________________
> > Linux-PowerEdge mailing list
> > Linux-PowerEdge at dell.com
> > https://lists.us.dell.com/mailman/listinfo/linux-poweredge
> > Please read the FAQ at http://lists.us.dell.com/faq
>
> _______________________________________________
> Linux-PowerEdge mailing list
> Linux-PowerEdge at dell.com
> https://lists.us.dell.com/mailman/listinfo/linux-poweredge
> Please read the FAQ at http://lists.us.dell.com/faq



More information about the Linux-PowerEdge mailing list