how to update firmware for R710 hardware

Eric Doutreleau Eric.Doutreleau at it-sudparis.eu
Thu Sep 23 09:41:43 CDT 2010


thanks for tour answer
i will try with usc

Le 23/09/2010 15:54, Lisa Giaime a écrit :
> I have a pile of R610.  I never tried to use a yum repo for the
> firmware updates.  However, I did try a few things. The R610's have
> the universal server configurator.  When that points to ftp.dell.com,
> it is crazy slow.  Updates can take all night.  Instead, I built a
> local ftp server for this.  I saw what I think are the same XML error
> messages when I did this.  I say "I think" because I worked on this
> back in January/February and my memory just isn't that good.  The
> problem then turned out to be that I wasn't fetching the xml catalog
> file.  The firmware updates are broken into directories like bios and
> lifecycle.  They aren't grouped by machine type.  Every one of those
> directories has an xml catalog that needs to be correct in order for
> the firmware updates to succeed.  Looking back at the thread that
> Robin cites, it looks like there is a bad xml catalog for this
> package.  I found on the R610's that if I could not run a piece of
> firmware at the OS level, it was possible to run it at the Server
> Configurator Level and vice versa.  Once I got past the offending
> package, all of the other firmware would run by my chosen method.  I
> also found that some firmware updates are pre-requisites to others but
> that the system wasn't able to figure this out on it's own.  For
> example, if my server was on the original bios level, I had to run a
> bios update and reboot before I could update some other piece.  The
> important thing there was that I had to select only that piece to
> update.  When that happened, I would get wonky error messages that
> gave no idea of what the problem was.
>
> How I managed to have success with getting all of the firmware updated
> on the R610 was to just try alternate methods for installing a package
> that failed.  Once I got past the bump, the rest of it would usually
> go pretty smoothly.
>
> HTH-
> Lisa
>
> On Sep 23, 2010, at 8:23 AM, Robin Bowes wrote:
>
>> On 23/09/10 13:05, Eric Doutreleau wrote:
>>> hi
>>>
>>> i have setup the yum repo for firmware in my R710 machine.
>>> I m running centos 5.5
>>>
>>> but when i run update_firmware --yes i got the following messages
>>>
>>> Running updates...
>>> /	Installing dell_dup_componentid_00159 - 2.1.9Installation failed
>>> for
>>> package: dell_dup_componentid_00159 - 2.1.9
>>> aborting update...
>>>
>>> The error message from the low-level command was:
>>>
>>> Could not parse output, bad xml for package:
>>> dell_dup_componentid_00159
>>>
>>>
>>> Does someone know how to solve that problems?
>>
>> I reported the same problem in August:
>>
>> http://lists.us.dell.com/pipermail/linux-poweredge/2010-August/042956.html
>>
>> I'm still seeing it.
>>
>> R.
>> --
>> "Feed that ego and you starve the soul" - Colonel J.D. Wilkes
>> http://www.theshackshakers.com/
>>
>> _______________________________________________
>> Linux-PowerEdge mailing list
>> Linux-PowerEdge at dell.com
>> https://lists.us.dell.com/mailman/listinfo/linux-poweredge
>> Please read the FAQ at http://lists.us.dell.com/faq
>
> _______________________________________________
> Linux-PowerEdge mailing list
> Linux-PowerEdge at dell.com
> https://lists.us.dell.com/mailman/listinfo/linux-poweredge
> Please read the FAQ at http://lists.us.dell.com/faq



More information about the Linux-PowerEdge mailing list