Issues with OpenManage + CentOs 5.4

Chris Szilagyi chris at apex-internet.com
Fri Sep 17 17:20:50 CDT 2010


Wayne,

Thank you for your help.  I know this is an older version of OpenManage, but
I am pretty sure we must run this version for the PowerEdge 2400, correct? 
I didn't see the 2400 listed as supported for newer versions of OpenManage.

The other services start OK.  To be honest, all we really want is the main
web interface to view server health, and maybe set up a couple of alerts. 
However, most of the information in the web interface is missing.  If we
click on "Health", it doesn't list any of the server components, it's empty.
 And, in the left pane, there are only a couple of items listed there too
(System / MainChassis, and Software / Operating System), and that's it.

I just assumed that the service/process that was failing had something to do
with the missing information?  Right now, the main installer shows the
following:

Installed Components:
    [x] Server Administrator CLI
    [x] Server Administrator Web Server

  Add Components
    [ ] 1. Diagnostic Service
    [ ] 2. Storage Management
    [ ] 3. Remote Access
    [ ] 4. All

I am guessing that "Server Administrator Web Server" is all that we need. 
The RPMs that it generated and currently installed are:

srvadmin-iws-4.5.0-335.i386.rpm
srvadmin-cm-4.5.0-335.i386.rpm
srvadmin-jre-4.5.0-335.i386.rpm
srvadmin-deng-4.5.0-335.i386.rpm
srvadmin-omacore-4.5.0-335.i386.rpm
srvadmin-hapi-4.5.0-335.i386.rpm
srvadmin-omhip-4.5.0-335.i386.rpm
srvadmin-isvc-4.5.0-335.i386.rpm
srvadmin-omilcore-4.5.0-335.i386.rpm

Any suggestions you might have would be greatly appreciated.  These servers
are 9 years old however they have given us no issues over the years and are
great machines.  Just getting them updated/upgraded with newer software and
re-deployed.  I've seen other posts out there with this same issue, without
solutions, so maybe this will also help others if we can get it working.

Thank you!!

--
Chris


> Chris,
> The inventory collector is used to collect firmware and bios revision
> information and expose it through snmp and a few other interfaces.  IT
> Assistant was the primary tool that makes use of the data provided by
> inventory collector.  Are all of the other services still running and
> providing the data you are interested in?  If so, you may just want to
> ignore this error.
>
> I'm asking around to see if anybody has any ideas on the underlying cause,
> but the release you are using is quite old.  The underlying issue may be an
> incompatibility between your distro version and OM.  If you were using a
> version of Cent that was current at the time of 4.5 you might have better
> luck.  (And I realize you probably would not want to do that....)
>
> It is a nice testament to know that some of our 10 year old servers are
> still able to meet customer needs.
>
> Wayne Weilnau
> Systems Management Technologist
> Dell | OpenManage Software Development
>
> Please consider the environment before printing this email.
>
> Confidentiality Notice | This e-mail message, including any attachments, is
> for the sole use of the intended recipient(s) and may contain confidential
> or proprietary information. Any unauthorized review, use, disclosure or
> distribution is prohibited. If you are not the intended recipient,
> immediately contact the sender by reply e-mail and destroy all copies of the
> original message.
>
> -----Original Message-----
> From: linux-poweredge-bounces-Lists On Behalf Of Chris Szilagyi
> Sent: Friday, September 17, 2010 1:29 PM
> To: José Mª Martínez G.
> Cc: linux-poweredge-Lists
> Subject: Re: Issues with OpenManage + CentOs 5.4
>
> Hi and thanks for the response.
>
>> Which uid is running the process, root?
>
> Yes, I am starting the services as root.  The process never starts though,
> because of the error.
>
>>
>> If user is different from root, maybe the message:
>>
>> "Unable to create temporary files."
>>
>> is because it tries to overwrite an existing files and the process "is
>> not to authorizer to overwrite then"
>>
>
> Permissions are 0777 (write for all), on /tmp.
>
>>
>> Another suggestion, remove all the content from /tmp and try to reboot...
>> or better (good practice) create /tmp in another partition different
>> from / partition
>>
>
> I have tried removing everything from /tmp, and still the same error.  I
> have not tried putting /tmp in another partition yet.
>
> Thanks for the help so far...
>
>
>>
>> Al 17/09/10 15:38, En/na Chris Szilagyi ha escrit:
>>> Hello:
>>>
>>> /tmp is just on the default root filesystem (/) on this server, and it
>>> has
>>> plenty free:
>>>
>>> Filesystem            Inodes   IUsed   IFree IUse% Mounted on
>>> /dev/sda2            3074176  136227 2937949    5% /
>>>
>>> It's the EXT3 filesystem, if that makes any difference.  Please let me
>>> know
>>> if there are any other suggestions you can think of.
>>>
>>> Thank you for the help!
>>>
>>>
>>>
>>>> Check available inodes.  df -i
>>>>
>>>> On Thu, Sep 16, 2010 at 10:29 PM, Chris Szilagyi
>>>> <chris at apex-internet.com>wrote:
>>>>
>>>>
>>>>> Hello:
>>>>>
>>>>> I recently set up a PowerEdge 2400 server running CentOS 5.4.  I'm
>>>>> trying
>>>>> to
>>>>> get OpenManage 4.5 installed (last version that I could find, that
>>>>> supports
>>>>> the PowerEdge 2400).  I installed everything using the supplied
>>>>> scripts,
>>>>> however when I try to start the services with "srvadmin-services.sh
>>>>> start",
>>>>> I get the following:
>>>>>
>>>>> Starting Systems Management Device Drivers:
>>>>> Starting dcdbas device driver:                             [  OK  ]
>>>>> Starting Systems Management Data Engine:
>>>>> Starting dcstor32d:                                        [  OK  ]
>>>>> Starting dcevt32d:                                         [  OK  ]
>>>>> Starting OM Common Services:                               [  OK  ]
>>>>> invcol Error: extract(): Unable to create temporary files. Please
>>>>> ensure
>>>>> that there is enough space in the
>>>>> tmp folder.
>>>>> Starting Secure Port Server:                               [  OK  ]
>>>>>
>>>>> The disk has over 7 GB of free space, and permissions look OK on /tmp.
>>>>> Has
>>>>> anybody seen this problem or know of a solution?  So far I'm stumped.
>>>>>
>>>>> Thank you !!
>>>>> --
>>>>> Chris
>>>>>
>>>>> _______________________________________________
>>>>> Linux-PowerEdge mailing list
>>>>> Linux-PowerEdge at dell.com
>>>>> https://lists.us.dell.com/mailman/listinfo/linux-poweredge
>>>>> Please read the FAQ at http://lists.us.dell.com/faq
>>>>>
>>>>>
>>>>
>>>
>>>
>> _______________________________________________
>> Linux-PowerEdge mailing list
>> Linux-PowerEdge at dell.com
>> https://lists.us.dell.com/mailman/listinfo/linux-poweredge
>> Please read the FAQ at http://lists.us.dell.com/faq
>
>
>
> _______________________________________________
> Linux-PowerEdge mailing list
> Linux-PowerEdge at dell.com
> https://lists.us.dell.com/mailman/listinfo/linux-poweredge
> Please read the FAQ at http://lists.us.dell.com/faq
>




More information about the Linux-PowerEdge mailing list