How to send sysrq command when external serial port used in a R710?

Frank Wang wg at yarbs.cn
Thu Sep 2 03:33:20 CDT 2010


> services. Now I have two options left, one is from the ssh/telnet
> 'console com2' session, the other is the java virtual console. The
> break key working in ipmitool won't do for the former, and the Sysrq
> or Alt-sysrq macro in the virtual console doesn't work either.

I tried the virtual console from the Win7 professional and the SysRq
command works there in the full screen mode virtual console. I need to
press Alt-Fn-SysRq, Release Fn-SysRq, press command character in my Dell
Precision M2400 though.
The same key sequence doesn't work in the Ubuntu Lucid with
sun-java6-jdk-6.20dlj-1ubuntu3 installed. The OS itself accept SysRq
command by Ctrl-Alt-Fn-SysRq, Release Fn-SysRq, press command, after print
screen grab keyboard shortcuts disabled. I also disabled the SysRq command
trap from the OS later and tried the same key sequence in virtual console.
It always triggers remote server reboot just when Ctrl-Alt-Fn-SysRq
pressed, no matter in window or full screen mode. It's just like the
Ctrl-Alt-Delete was sent to the remote server. Recall the fact that I have
to press Fn-8 to get UP, and Fn-2 for DOWN arrow in the virtual console,
it's likely the culprit is that the sun jdk doesn't fully respect the key
map in the OS.
I'm not familiar with Java. Is it possible to make it agree OS keyboard
layout?
Thanks in advance.

Regard,
Frank Wang



More information about the Linux-PowerEdge mailing list