libsmbios.x86_64 0:2.2.21-3.1.el5 set to be updated - failure

Rainer Traut tr.ml at gmx.de
Fri May 28 08:40:47 CDT 2010


Am 28.05.2010 15:09, schrieb Matt Domsch:
> On Fri, May 28, 2010 at 09:36:42AM +0200, Rainer Traut wrote:

>> It seems the dell-community repo is missing the new i386 version of
>> libsmbios?
>
> You can't have multiple versions on 2 different architectures.  You
> can have the same version on 2 architectures (multilib).  Either
> upgrade libsmbios.i386 first, then install libsmbios.x86_64, or remove
> either that you don't need.
>

I don't want "multiple versions on 2 different architectures". I want to 
update both to the same new version.

The problem I guess is, the i386 update is missing from the repo so I 
cannot update it:

# yum list libsmbios*
Installed Packages
libsmbios.i386 
2.2.19-10.1.el5                                       installed
libsmbios.x86_64 
2.2.19-10.1.el5                                       installed
Available Packages
libsmbios.x86_64 
2.2.21-3.1.el5                                        dell-community
libsmbios-devel.x86_64 
2.2.21-3.1.el5                                        dell-community

and I cannot uninstall the i386 nor the x86_64 version:

# rpm -e libsmbios.i386 --test
Fehler: Fehlgeschlagende Abhängigkeiten:
         libsmbios.so.2 wird benötigt von (installiert) 
srvadmin-storage-populator-6.2.0-1.25.el3.i386
# rpm -e libsmbios.x86_64 --test
Fehler: Fehlgeschlagende Abhängigkeiten:
         libsmbios.so.2()(64bit) wird benötigt von (installiert) 
smbios-utils-bin-2.2.19-10.1.el5.x86_64
         libsmbios_c.so.2()(64bit) wird benötigt von (installiert) 
smbios-utils-bin-2.2.19-10.1.el5.x86_64

Rainer



More information about the Linux-PowerEdge mailing list