bash4 breaks firmware update scripts (buildVer.sh: file not found)

Dominik L. Borkowski dom at vbi.vt.edu
Wed Mar 3 10:32:52 CST 2010


On Wednesday 03 March 2010 10:58:38 Jeffrey_L_Mendoza at dell.com wrote:

> Which next SLES or RHEL will have bash4?

Oops, by accident I didn't include my response to the mailing list:

I can only guess that future versions of SLES may have it, considering 
OpenSUSE 11.2 has it. 

On a side note, while trying to upgrade firmware on a set of PV220s from 
OpenSUSE 11.2 machine, I was getting the following message [besides the 
previously mentioned buildVer.sh not fount]:

"Running validation...                               

This Update Package is not compatible with your system configuration.
"

All of the above problems were fixed by downgrading to bash3, used by the 
previous release of OpenSUSE. 

While SLES11 used OpenSUSE 11.0, I know they've diverged a bit since then. I 
can't answer with any authority as to wheter very next release of SLES or RHEL 
will be using bash4. I'm just hoping this information will be useful to other 
folks who run into the same problem, and maybe to prepare those scripts for 
eventual use of bash4 in RHEL/SLES.

Cheers!
-- 
Dominik L. Borkowski - Senior Systems Administrator
Virginia Bioinformatics Institute - www.vbi.vt.edu


-- 
Dominik L. Borkowski - Senior Systems Administrator
Virginia Bioinformatics Institute - www.vbi.vt.edu



More information about the Linux-PowerEdge mailing list