OpenManage 6.4 yum repository posted

Cooper, Trevor tcooper at ucsd.edu
Mon Dec 27 22:33:52 CST 2010


On Dec 27, 2010, at 6:17 AM, Stephan van Hienen wrote:

From: linux-poweredge-bounces at dell.com<mailto:linux-poweredge-bounces at dell.com> [mailto:linux-poweredge-bounces at dell.com] On Behalf Of
Santosh_Gore at dell.com<mailto:Santosh_Gore at dell.com>
Sent: Thursday, December 23, 2010 3:59 AM
To: linux-poweredge at lists.us.dell.com<mailto:linux-poweredge at lists.us.dell.com>
Subject: OpenManage 6.4 yum repository posted


Hi All,

The OpenManage 6.4 yum repository has been posted and latest symbolic link is updated:
http://linux.dell.com/repo/hardware/latest/


Any hints how to upgrade an existing rhel 5.5 (x64) with openmange 6.3 installed ?
I now get conflicts :

Transaction Check Error:
 file /usr/share/locale/de/LC_MESSAGES/libsmbios-2.2-x86_64.mo from install of libsmbios-2.2.26-6.2.el5.i386 conflicts with file from package libsmbios-2.2.19-10.1.el5.x86_64
 file /usr/share/locale/en/LC_MESSAGES/libsmbios-2.2-x86_64.mo from install of libsmbios-2.2.26-6.2.el5.i386 conflicts with file from package libsmbios-2.2.19-10.1.el5.x86_64
 file /usr/share/locale/en at boldquot/LC_MESSAGES/libsmbios-2.2-x86_64.mo from install of libsmbios-2.2.26-6.2.el5.i386 conflicts with file from package libsmbios-2.2.19-10.1.el5.x86_64
[..]

Stephan


How about (ymmv)...

  # stop/remove OMSA
  sudo /opt/dell/srvadmin/sbin/srvadmin-services.sh stop
  sudo /opt/dell/srvadmin/sbin/srvadmin-uninstall.sh
  sudo rm -rfv /opt/dell/
  # remove libsmbios and dependencies
  sudo yum -y remove libsmbios
  # remove dell-omsa-repository if installed
  yum whatprovides /etc/yum.repos.d/dell-omsa-repository.repo
  # remove the package that is returned... in my case...
  sudo yum -y remove dell-omsa-repository-2-5.noarch
  sudo yum -y remove dell-omsa-indep
  sudo rm /etc/yum.repos.d/dell-omsa-repository.repo
  sudo yum clean all
  # install new dell repository
  sudo su -
  wget -q -O - http://linux.dell.com/repo/hardware/latest/bootstrap.cgi | bash
  # install OMSA
  yum -y install srvadmin-all
  exit
  # verify OMSA
  omreport chassis info

This worked for me.

Good luck...
Trevor





More information about the Linux-PowerEdge mailing list