How to restore all of /boot/?

Zembower, Kevin kzembowe at jhuccp.org
Mon Aug 25 10:18:22 CDT 2008


Just to bring this saga to a close, for anyone reading the archives: I was completely resigned to reinstalling a fresh CentOS 5 on this server. However, as I began this with the CentOS 5 CD ROMs, I got a choice of installing a fresh copy or updating the version that it found. It correctly found the old root at /dev/VolGroup00, so I thought that this might work. Later, it identified that it couldn't find a bootloader, and asked if I wanted to install grub. I said yes, and it went on to install grub, update the programs and rebooted correctly.

I guess I should have thought that this would be a possibility a couple of weeks ago, and saved myself a lot of time. Oh, well. Next time...

Thanks, again, for all who offered help and suggestions.

-Kevin

-----Original Message-----
From: linux-poweredge-bounces at dell.com [mailto:linux-poweredge-bounces at dell.com] On Behalf Of Zembower, Kevin
Sent: Monday, August 25, 2008 10:06 AM
To: Dell Linux Poweredge List
Subject: RE: How to restore all of /boot/?

Bryan and Kevin, thank, again, for your help. However, I think I'm going to go with my plan B, to install CentOS 5 fresh and rsync. I wasn't able to do 'device (hd0) /dev/sda'; there's no 'device' command in my version of grub. I don't think that I have a /dev/sdb. All I could find was:
  /dev/sda1, ext3, used for /boot
  /dev/mapper/VolGroup00-LogVol00, ext3, used for /
  /dev/VolGroup00/LogVol01, used for swap

I'm intimidated by the task of trying to create a boot partition in the second disk (if I understand your advice correctly) without disturbing the existing data in this container.

I was careful to run 'root (hd0,0); setup (hd0)' and at first I was hopeful.  I got a message "Running 'embed /grub/e2fs-stage1_5 (hd0)'... 15 sections are embedded" that I don't remember seeing before. However, the system still just boots into grub.

Thank you, again, for your patience and efforts to help me. I really appreciate all your suggestions and advice.

-Kevin

-----Original Message-----
From: linux-poweredge-bounces at dell.com [mailto:linux-poweredge-bounces at dell.com] On Behalf Of Bryan Miller
Sent: Friday, August 22, 2008 6:30 PM
To: Landreth, Kevin
Cc: Dell Linux Poweredge List
Subject: Re: How to restore all of /boot/?

Okay. Since you have several disks, the system could be booting from
the other one. What I usually do is have two boot partitions in a dual
HDD raid setup--one boot part each. I'll use this as an example. You
seem to know what you're doing, so I'm going to assume you can apply
my example to your setup.

I have sda and sdb as drives in the raid setup.

The first part is always boot:

/dev/sda1 & /dev/sdb1

After I could get the system to boot, I would login as root and then run grub:

# grub
>device (hd0) /devv/sda
>root (hd0,0)
>setup (hd0)
>device (hd0) /dev/sdb
>root (hd0,0)
>setup (hd0)

This would always solve any grub related boot problem for my setup.

Apply steps to your setup accordingly. :)

If your setup only has a boot part on one drive, my guess would be
that the system is not booting from that drive?

If you do have to resort to rsync'ing stuff, my advice would be to
boot into single mode by putting "single" at the end of the kernel
line in grub (press e upon grub menu, then e again on the kernel
line). From there, bring up the network via service or init.d, and
then sync files. Nothing should be running in single mode that would
prevent this from completing successfully.

Hope this helps.

-Bryan


On Fri, Aug 22, 2008 at 2:10 PM, Landreth, Kevin
<klandreth at theplanet.com> wrote:
>> I also tried 'root (hd0,0)' and 'setup (hd0,0)'
>
> I should be
> # Grub
>> root (hd0,0)
>> setup (hd0)
>
> Not (hd0,0)
>
>
>
> -----Original Message-----
> From: linux-poweredge-bounces at dell.com
> [mailto:linux-poweredge-bounces at dell.com] On Behalf Of Zembower, Kevin
> Sent: Friday, August 22, 2008 3:28 PM
> To: linux-poweredge at dell.com
> Subject: RE: How to restore all of /boot/?
>
> Bryan and Kevin, thanks so much for your suggestions. Bryan, I ended up
> following your directions, but it still didn't help me and now I'm at a
> standstill. As far as I can tell, /boot/ and /boot/grub/ are fully
> populated. /boot/contains files System.map, config, initrd, sysvers and
> vmlinuz, all for 2.6.18-92.1.1.el5. /boot/grub/device.map looks
> identical to another of my systems that uses GRUB and LVM. I tried both
> '/sbin/grub-install /dev/sda1' and '/sbin/grub-install /dev/sda' after
> booting the CentOS 5 rescue mode and 'chroot /mnt/sysimage'. Neither one
> reported an error, but neither one fixed the problem. I also tried 'root
> (hd0,0)' and 'setup (hd0,0)' from the grub prompt. Again, reported
> 'success' but didn't fix the problem.
>
> I'm at a loss for what to do next. Are there any diagnostics or logs in
> grub? Any way to tell what's going on just before it goes to the grub>
> prompt? The word 'GRUB...' flashes by, but that's all I can read before
> it clears the screen and goes to the grub> prompt.
>
> If I can't get this working, I think I can still recover the system by
> installing CentOS 5 normally, then rsyncing with the files on the other
> server. I was avoiding this because I don't know what files and
> directories changed, and I don't think I'll be successful just rsyncing
> the whole /td/ directory, because of open and in-use files. However, I
> can't think of an alternative at this time. Any suggestions?
>
> Thanks, again, for all your help and advice. Have a good weekend.
>
> -Kevin
>

_______________________________________________
Linux-PowerEdge mailing list
Linux-PowerEdge at dell.com
http://lists.us.dell.com/mailman/listinfo/linux-poweredge
Please read the FAQ at http://lists.us.dell.com/faq

_______________________________________________
Linux-PowerEdge mailing list
Linux-PowerEdge at dell.com
http://lists.us.dell.com/mailman/listinfo/linux-poweredge
Please read the FAQ at http://lists.us.dell.com/faq



More information about the Linux-PowerEdge mailing list