Restoring grub MBR

Davis Phillips davis.phillips at rackspace.com
Mon Aug 18 11:14:18 CDT 2008


Yes, the boot partition needs to be on a non-lvm partition so that the
module can be packed into an initrd image. 

Article here:

http://kbase.redhat.com/faq/FAQ_35_647.shtm


Regards,
Davis Phillips
Lead Technician
Intensive Hosting(tm)
* US Free: 1-800-961-4454
* Intl.: +1-512-539-1143


-----Original Message-----
From: linux-poweredge-bounces at dell.com
[mailto:linux-poweredge-bounces at dell.com] On Behalf Of Paul M. Dyer
Sent: Monday, August 18, 2008 11:07 AM
To: linux-poweredge at dell.com
Subject: Re: Restoring grub MBR

As far as I know,  /boot cannot be an LVM volume.  It needs to be a real
and primary partition.

Paul


----- Original Message -----
From: "Kevin Zembower" <kzembowe at jhuccp.org>
To: "linux-poweredge at dell.com" <linux-poweredge at dell.com>
Sent: Monday, August 18, 2008 10:14:40 AM (GMT-0600) America/Chicago
Subject: Restoring grub MBR

In the continuing saga of trying to restore an old PE 2450 (see
http://lists.us.dell.com/pipermail/linux-poweredge/2008-August/037019.ht
ml), I was able to restore the server 'td' by booting the system with a
Knoppix 5.1.1 CD. I had to run these commands, because the system uses
the Linux Volume Manager:
  /etc/init.d/lvm start
  vgscan --mknodes
  vgchange -ay
  lvscan
  mkdir /mnt/logvol00
  mount /dev/VolGroup00/LogVol00 /mnt/logvol00
  mount /dev/sda1 /mnt/logvol00/boot
  cd /mnt/logvol00
  rsync -azv root at t:/td/ ./

This restored the system from the host 't' and the directory '/td/',
where the developers had continued their work.

My problem now is that the system refuses to boot, and instead, drops
into the grub prompt. I've tried to boot it in CentOS5 'linux rescue'
mode, where it finds the root directory and mounts it in /mnt/sysimage.
Then, I 'chroot /mnt/sysimage; grub-install /dev/sda', but this errored,
if I remember correctly. It didn't fix the problem. I then rebooted and
got the grub prompt and tried:
  root (hd0,0)
  setup (hd0,0)
This seemed to work correctly (I got the two failures that it said were
not significant), but it still booted into grub. I changed the second
command to 'setup (hd0,1)' but got the same result.

Any suggestions on what I can try next? Any ideas what's going on?

Thanks, as always, for your advice, suggestions and help.

-Kevin

Kevin Zembower
Internet Services Group manager
Center for Communication Programs
Bloomberg School of Public Health
Johns Hopkins University
111 Market Place, Suite 310
Baltimore, Maryland  21202
410-659-6139


_______________________________________________
Linux-PowerEdge mailing list
Linux-PowerEdge at dell.com
http://lists.us.dell.com/mailman/listinfo/linux-poweredge
Please read the FAQ at http://lists.us.dell.com/faq

_______________________________________________
Linux-PowerEdge mailing list
Linux-PowerEdge at dell.com
http://lists.us.dell.com/mailman/listinfo/linux-poweredge
Please read the FAQ at http://lists.us.dell.com/faq


Confidentiality Notice: This e-mail message (including any attached or
embedded documents) is intended for the exclusive and confidential use of the
individual or entity to which this message is addressed, and unless otherwise
expressly indicated, is confidential and privileged information of Rackspace. 
Any dissemination, distribution or copying of the enclosed material is prohibited.
If you receive this transmission in error, please notify us immediately by e-mail
at abuse at rackspace.com, and delete the original message. 
Your cooperation is appreciated.




More information about the Linux-PowerEdge mailing list