RHEL5 and PERC 4 monitoring (PE1750) (solved)

Matthias Saou thias at spam.spam.spam.spam.spam.spam.spam.egg.and.spam.freshrpms.net
Wed May 23 12:30:06 CDT 2007


Reid Wightman wrote :

> Matthias Saou wrote:
> > 
> > open("/dev/megadev0", O_RDONLY)         = -1 ENODEV (No such device)
> > 
> > As you can see, the /dev entry seems to not interface the hardware
> > anymore (it's not "No such file or directory", the device node is
> > present and hasn't changed).
> 
> Any chance that there is an selinux avc error in /var/log/messages when 
> you run megarc?

Nope. All selinux related policies are removed, and "SELinux:  Disabled
at runtime." according to the kernel ;-)

The only possibly unusual thing about the host is that it's running a
Xen kernel. But "lspci" does see the device, and I'm running "megarc"
from the host itself, obviously.

I was thinking that maybe /dev/megadev0 was now supposed to be
something a bit more sane than a "254, 0" character device...

Oh, I found it!!!! I just came across this :
http://lists.us.dell.com/pipermail/linux-poweredge/2006-December/028656.html

Then I tried :
# grep -w megadev /proc/devices
253 megadev

So the correct major changed from 254 to 253... go figure. So I changed
the megadev0 node and now it works.

Thanks anyway, I hope this might be useful for others to know too ;-)

Matthias

-- 
Clean custom Red Hat Linux rpm packages : http://freshrpms.net/
Fedora Core release 6 (Zod) - Linux kernel 2.6.20-1.2948.fc6
Load : 0.57 0.51 0.68



More information about the Linux-PowerEdge mailing list