OM / snmpd / smux conflict??

Larsen, Peter PLarsen at CIBER.com
Sun Jun 24 20:21:49 CDT 2007


>Larsen, Peter wrote:
>> Well, I wasn't able to compile :(  Is there any specific parameters 
>> I need to supply to ./configure ??
>> 
>> My error:
>> grep: /usr/lib/libbeecrypt.la: No such file or directory
>> /bin/sed: can't read /usr/lib/libbeecrypt.la: No such file or directory
>> libtool: link: `/usr/lib/libbeecrypt.la' is not a valid libtool archive

>http://www.net-snmp.org/wiki/index.php/FAQ:Compiling_02

Hmmm - that's what ./configure usually deals with?? It didn't complain.

>> Here's what I get with the read_config:
>> 
>> read_config: reading premib configuration tokens
>> read_config: config path 
>> used:/etc/snmp:/usr/share/snmp:/usr/lib/snmp:/var/net-snmp
>> read_config: /etc/snmp/snmpd.conf: Permission denied

>Please run the agent as root to give it a chance to read
>/etc/snmp/snmpd.conf. Then again, post the output with
>"-Dread_config,smux,smux_conf,smux_init".

Well - that did it!! It was running as root, but as usual, SELINUX was killing me. Strangely, I didn't see any SELINUX errors, but I ran restorecon on /etc/snmp and that fixed it. I assume the issue has been, from the get go, that snmpd never was able to read the /etc/snmp/snmpd.conf. Good catch.

>> Warning: no access control information configured.
>>   It's unlikely this agent can serve any useful purpose in this state.

>As long as you get this, the warning message really applies.

Yup! I agree. Looks much better now.

Regards
  Peter Larsen



More information about the Linux-PowerEdge mailing list