PE 1855 / QLogic 2312 / RHEL 5

Youssef Ghorbal youssef.ghorbal at netplus.fr
Thu Jun 21 08:12:58 CDT 2007


On Jun 21, 2007, at 1:25 PM, <Harald_Jensas at Dell.com>  
<Harald_Jensas at Dell.com> wrote:

>> -----Original Message-----
>> From: linux-poweredge-bounces at dell.com [mailto:linux-poweredge-
>> bounces at dell.com] On Behalf Of Youssef Ghorbal
>> Sent: 21 June 2007 12:56
>> To: linux-poweredge-Lists
>> Subject: PE 1855 / QLogic 2312 / RHEL 5
>>
>> Hi All,
>>
>> 	We have two PE 1855 witch Qlogic 2312 HBAs and RHEL 5.
>> 	The Gold support is arguing that this configuration is not
>> supported
>> yet (No Dell drivers for Qlogic HBAs)
>>
>> 	They propose two solutions:
>>
>> 	- Reinstall servers with RHEL 4 (renegociate with RedHat to
>> change
>> licences...)
>> 	- Change Qlogic HBAs with Emulex ones (that seems to be supported
>> under RHEL 5)
>>
>> 	The support engeneer is telling me that the generic Qlogic driver
>> (shipped with RedHat) does not seem to work with the Qlogic 2312.
>>
>> 	Is there any way I can test to let the generic driver work with
>> these Qlogics.
>>
>
> The driver that Dell support for QLogic 2342M was embedded in RHEL  
> 4 U4. I do not know if it is still in the RHEL 5 release...
> Does the system load the driver? Does it detect the HBA? You should  
> see this in dmesg. Since you know that it is using the ISP2312 ASIC  
> I guess it does?
>
> Best way to check if it works is to try to use it.
>
>
> Also, the driver package available on support.dell.com includes the  
> source code for the RHEL 4 and SLES 9 driver. You could try to  
> compile and load it on RHEL 5.
>
> Fibre Channel: QLogic Dell 2342M - FC HBA, Dell 2362M FC HBA,  
> Driver, Enterprise Linux 4, English, PowerEdge 1855, 1955, 6850, v. 
> 8.01.04b3, A00
>
> http://ftp.us.dell.com/fibre-channel/qlafc-linux-8.01.04-3-install.tgz
>
>
> But remember, if you get it to work. You will still be running a  
> non supported solution, and if you need support you might very well  
> end up in an argumentation with support...
>
>
> Regards
> Harald Jensås

Hi,

	Thanks for the quick answer.
	The driver is correctly loaded by the kernel and the dmesg shows the  
two HBAs.
	But the Gold support is looking for some files in /proc/scsi  
directory that does not exist and refuse to continue the San  
Integration :(

	I'll try to compile the Driver

Youssef



More information about the Linux-PowerEdge mailing list