SC1435 RAID monitoring under Gentoo

John Heim jheim at math.wisc.edu
Wed Jun 20 11:46:10 CDT 2007


From: "Ian P. Christian" <pookey at gmail.com>


> lspci shows the RAID card in the SC1435 as:
>    LSI Logic / Symbios Logic SAS1068 PCI-X Fusion-MPT SAS (rev 01)
> >  [...]
> I've tried downloading several tools, however they are all RPM based and
> have dependencies that can't be met on my system.  Can anyone suggest how 
> I
> can monitor my RAID on my server under Gentoo?
>

There's a debian package called mpt-tools that seems to work. Have you tried 
that? I don't know much about gen2 so I don't know if you can use .debs.

The debian testing (lenny) version of mpt-tools recognizes the SAS1068 in my 
1435s. In fact, I had installed the stable (etch) version of mpt-tools and I 
got a series of email messages from the mpt daemon saying there was 
something wrong with my RAID. But the messages said no controller could be 
found. I installed the testing version and it was able to see the 
controller. But that gave me hope that if there actually was something wrong 
with the array, mpt-status would email me.

But that's all I know. I really should do some research about RAID 
monitoring. We have 5 of these servers but just having them report degraded 
RAID events would probably be enough for us.

If you find out anything. let me know. 



More information about the Linux-PowerEdge mailing list