ipmitool bootdev pxe

Matt Domsch Matt_Domsch at dell.com
Sun Jun 3 22:13:24 CDT 2007


On Wed, May 30, 2007 at 10:27:17PM -0700, Chance Reschke wrote:
> Hi,
> 
> I've tried the same thing with the same results.   It looks like  
> Dell's IPMI implementation is incomplete.  It claims the bootdev has  
> been changed when, in fact, nothing was done.
> 
>    # ipmitool -U root -P foobar -H nodename chassis bootdev pxe
>    Set Boot Device to pxe
> 
> But when I reboot, the system boots from whatever boot device it was  
> set to use before issuing the ipmi command.  I've tried the <clear- 
> cmos=yes|no> variations with no effect.
> 
> This was on a Dell 1435 node.  Does this work on any Dell systems?   

I believe it does not work on any Dell systems to date.


> Can Dell change the response returned from the BMC so at least the  
> response isn't so misleading?

I'll bring it up with our BMC firmware team.

Let me also point out the Deployment Toolkit tools, which can do a lot
of nifty magic like this.

ftp://ftp.dell.com/sysman/

Files named DTK_* (version 2.3 being the latest available as of this
note) are what you're looking for.

Thanks,
Matt

-- 
Matt Domsch
Software Architect
Dell Linux Solutions linux.dell.com & www.dell.com/linux
Linux on Dell mailing lists @ http://lists.us.dell.com



More information about the Linux-PowerEdge mailing list