OMSA 5.1 Debian Troubles

Brian E. Seppanen seppy at chartermi.net
Sun Feb 25 11:42:57 CST 2007


Hi Folks:

I'm running debian 3.1 (stable aka sarge) on a Dell 1650 Poweredge. 
Kernel version is 2.6.19 custom.   I've included dcdbas as kernel module.


uname -a
Linux host 2.6.19.01032007 #1 SMP Wed Jan 3 22:36:39 EST 2007 i686 
GNU/Linux

dmesg | grep dcdbas
dcdbas dcdbas: Dell Systems Management Base Driver (version 
5.6.0-3.2)

lsmod output
dcdbas                  8416  0
ipmi_watchdog          18080  0
ipmi_devintf            9256  0
ipmi_poweroff           8804  0
ipmi_si                37060  2
ipmi_msghandler        35872  4 
ipmi_watchdog,ipmi_devintf,ipmi_poweroff,ipmi_si

lrwxrwxrwx  1 root src 39 Jan 10 11:08 /usr/src/linux-2.6 -> /usr/src/kernel-headers-2.6.19.01032007

I installed the openipmi, libopenipmi0 packages
ii  openipmi                    2.0.7-1                     Intelligent Platform Management Interface (for servers)
ii  libopenipmi0                2.0.7-1                     Intelligent Platform Management Interface - runtime
ii  dellomsa                    5.1.0-4                     Dell OpenManage Server Administrator 5.


I've tried many things, and the daemons necessary for gathering 
statistics, events, etc.. refuse to start.   I see references as these 
being the proper daemons and they will not start using 
/etc/init.d/instsvcdrv.   They say they start but the process never 
begin.

/opt/dell/srvadmin/dataeng/bin/dsm_sa_datamgr32d
root     11183     1  0 15:32 ?        00:00:00
/opt/dell/srvadmin/dataeng/bin/dsm_sa_eventmgr32d
root     11193     1  0 15:32 ?        00:00:00
/opt/dell/srvadmin/dataeng/bin/dsm_sa_snmp32d

I don't know if it matters, but on this host I'm running udev which is the 
hotplug/devfs replacement.   Note:  It matters insomuch as /dev/afa0 is 
not created automatically by udev, which is another hurdle to cross.

none of the sensors seems to return any data, with saying that there are 
no probes, but ealier omsa 4.4 worked just fine

# /opt/dell/srvadmin/oma/bin/omreport chassis fans
Error! No fan probes found on this system.

What the hell am I missing?  the omsa pulls very little data seemingly 
from the system?    It formerly worked so nicely.

I can start the processes by hand without any problems.

I see very little output as to any reason for failures to start these 
applications.

Anyone have any ideas on how I could go about tracking down the reasons 
that the sensors don't appear to be working, and the helper applications 
refusing to start, or stay running?    Are there specific omsa log files I 
can look at?  I don't see anything out of the ordinary in syslog.

Any help greatly appreciated.   I hate to have a system where I can't 
quickly and in a standard fashion gather statistics (I'm not going to 
license RH ES x to do it).

Thanks...



More information about the Linux-PowerEdge mailing list