LILO issues

Greg Gilmour greg at g-3.org
Tue Feb 6 17:44:20 CST 2007


Have a PE 1800 with a PERC 4/SC running Debian Sarge 3.1 and LILO
22.6.1.  I was in the process of installing a new 2.6.20 kernel when I
ran into an error that LILO failed because it was unable to find the
VolumeID on /dev/sdb.  We use two external USB drives for our backups,
one being /dev/sdb1 and the other /dev/sdc1, which are only on for the
backups and otherwise off when not in use.  The only partitions
continually mounted (and hence listed in /etc/fstab) are on /dev/sda
(/dev/sda1 and /dev/sda2 specifically).

I've had no problems with LILO up until this point, even getting an
earlier 2.6.x kernel to boot, but this one is new to me.  I'm not sure
what the issue is to why LILO refuses to load the new kernel (I even tried
reverting to an un-edited version of /etc/lilo.conf and re-ran LILO only
to get the same error).  Additionally since LILO is failing I'm
reluctant to reboot the machine in case the MBR is totally FUBAR and
won't boot anymore.  Am I correct in assuming that if LILO fails for
whatever reason, the existing MBR isn't touched?

Additional information can be found in another forum I posted to:

http://community.livejournal.com/linux/1586657.html

Any insight into this and a fix is greatly appreciated.  If anyone needs
more information on the setup, let me know.  Thanks again.

-- 
~~~~~~~~~                                                                     
- greg                     
"hrmmm - a Beowulf cluster of Dreamcasts and PS2s..."
                        -Slashdot.org post



More information about the Linux-PowerEdge mailing list