PE 2950 snmp

Niklas Larsson rinolf2 at gmail.com
Tue Apr 24 04:58:53 CDT 2007


Thanks for trying to help me. Dsm_sa_snmp32d was not running, I thought:

/etc/init.d/dataeng start
/etc/init.d/dsm_sa_ipmi start

should start every needed process. I started dsm_sa_snmp32d with:

sudo /opt/dell/srvadmin/dataeng/bin/dsm_sa_snmp32d start

So now dsm_sa_snmp32d running but still no success (same error).

I give it a last try because this mailing list seems to be my last 
option to solve this.

Are there any missing processes?

 > ps -e | grep dsm                                  
 4620 ?        00:00:08 dsm_sa_datamgr3
 4654 ?        00:00:00 dsm_sa_eventmgr
 4907 ?        00:00:00 dsm_sa_datamgr3
 8168 ?        00:00:08 dsm_sa_snmp32d

Which processes have to run beside dsm*?

This is my snmpd.conf without all comments:

======== Start of snmpd.conf =========

com2sec local     127.0.0.1         public
com2sec local     10.42.0.0/24      public
 
group MyRWGroup v1         local
group MyRWGroup v2c        local
group MyRWGroup usm        local
group MyROGroup v1         local
group MyROGroup v2c        local
group MyROGroup usm        local
 
view all    included  .1                               80
 
access MyROGroup ""      any       noauth    exact  all    none   none
access MyRWGroup ""      any       noauth    exact  all    all    none
 
syslocation Right here, right now.
syscontact Me <me at somewhere.org>
 
proc mountd
 
proc ntalkd 4
 
proc sendmail 10 1
 
exec echotest /bin/echo hello world
 
disk / 10000
 
load 12 14 14
 
rouser snmp_user
 
smuxpeer .1.3.6.1.4.1.674.10892.1

===========  End of  snmpd.conf ============

Not many changes from the example file.

To show that omsa is installed (I hope this verify this):

 > sudo omreport chassis
Health
 
Main System Chassis
 
SEVERITY : COMPONENT
Ok       : Fans
Ok       : Intrusion
Ok       : Memory
Ok       : Power Supplies
Ok       : Processors
Ok       : Temperatures
Ok       : Voltages
Ok       : Hardware Log
Ok       : Batteries

I have the following Dell MIBs in /usr/share/snmp/mibs/:

10892.mib
baspCfg.mib
baspStat.mib
baspTrap.mib
DcAsfSrv.mib
dcs3rmt.mib
dcstorag.mib
dellcm.mib
ITassist.mib
rac_host.mib

The server run zsh and not bash if that make any differens.

I don't know if there is any thing else to check. But i really hope this 
info will help.


Patrick_Boyd at Dell.com wrote:
> Ok then make sure the dsm_sa_snmp32d process is running. That is all
> that I know to check.
>
> -----Original Message-----
> From: Niklas Larsson [mailto:rinolf2 at gmail.com] 
> Sent: Monday, April 23, 2007 10:09 AM
> To: Boyd, Patrick
> Cc: linux-poweredge-Lists
> Subject: Re: PE 2950 snmp
>
> Thanks for the reply.
>
> Sorry, forgot that my snmpd.conf already contain (at the end of the file
>
> if it matters) :
>
> smuxpeer .1.3.6.1.4.1.674.10892.1
>
> I'm not shore if:
>
> snmpget localhost -c public -m ALL .1.3.6.1.4.1.674 -v2c
> or
> sudo snmpwalk localhost -c public -m ALL .1.3.6.1.4.1.674.10892.1 -v2c
>
> are the right commands to see if it works but they give almost the same 
> output any way.
>
>
>
> Patrick_Boyd at Dell.com wrote:
>   
>> Your snmpd.conf file should contain the following line:
>>
>> smuxpeer .1.3.6.1.4.1.674.10892.1
>>
>> That is also the root OID for OMSA.
>>
>> -----Original Message-----
>> From: linux-poweredge-bounces at dell.com
>> [mailto:linux-poweredge-bounces at dell.com] On Behalf Of Niklas Larsson
>> Sent: Monday, April 23, 2007 4:24 AM
>> To: linux-poweredge-Lists
>> Subject: PE 2950 snmp
>>
>> Hi, we got three PowerEdge 2950 servers we want to monitor with snmp
>>     
> but
>   
>> can't get it to work. The servers are running Debian with kernel 
>> 2.6.18-3. Net-snmp and omsa 5.1 (used dellomsa_5.1.0-2_i386.deb) are 
>> installed and the command:
>>
>> sudo snmpwalk -c public localhost -v2c
>>
>> Gives a lot of information but no Dell specific. The command:
>>
>> snmpget localhost -c public -m ALL .1.3.6.1.4.1.674 -v2c
>>
>> Is giving this output:
>>
>> MIB-Dell-10900::dell = No Such Object available on this agent at this
>> OID
>>
>> This is my first time working with snmp so I'm probably missing 
>> something basic. Is there any special modules or something needed to
>>     
> be 
>   
>> compiled in to the kernel or do I need to install some version of 
>> dellomsa-drivers? Which version of dellomsa-drivers do I need in that
>> case?
>>
>> Thanks
>> Niklas Larsson
>>
>> _______________________________________________
>> Linux-PowerEdge mailing list
>> Linux-PowerEdge at dell.com
>> http://lists.us.dell.com/mailman/listinfo/linux-poweredge
>> Please read the FAQ at http://lists.us.dell.com/faq
>>
>>   
>>     
>
>   



More information about the Linux-PowerEdge mailing list