Broadcom NetXtreme on-board NIC won't show up in CentOS 4.4, Dell SC440

Fred Skrotzki fskrotzki at textwise.com
Mon Apr 23 15:32:21 CDT 2007


 Edit the /etc/sysconfig/network-scripts/ifcfg-eth0 file and remove the
mac address that is in the file. 

-----Original Message-----
From: linux-poweredge-bounces at dell.com
[mailto:linux-poweredge-bounces at dell.com] On Behalf Of Iain Young
Sent: Monday, April 23, 2007 3:54 PM
To: linux-poweredge at dell.com
Subject: Broadcom NetXtreme on-board NIC won't show up in CentOS
4.4,Dell SC440

Hi there,

I am a newbie to Linux. Would appreciate any comment! I know this
problem looks dumb....
I tried to install a CentOS 4.4 on a new Dell SC440 server. Everything
seems to be fine but except the on-board Broadcom NetXtreme 1000 NIC.
I noticed there is an
error during installation: The Eth0 device has a different MAC address
than expected. Ignoring...
After the system is ready, of course the NIC won't show up.
# uname -a
The result is # 2.6.9-34.0.2.ELsmp
# lspci
....
The result is: 05:00.0 Ethernet controller: Broadcom Corp NetXtreme
BCM5754 Gigabit Ethernet PCI Express (rev02) ....
Then I tried # ifconfig.
There's only
lo ........inet addr=127.0.0.1......
I run
# netconfig
# service network restart
to use the dynamic IP address. This time I got:
Bringing up interface eth0: tg3 device does not seem to be present,
delaying initialization.
What's more, I can't upgrade the kernel. Otherwise I have to deal with
more module re-installation. Ironically, if I throw in an old PCI 10/100
NIC and disable the on-board BCM5754, no problem at all!
I tried drivers from HP (tg3-3.71b-1.src.rpm), Broadcom
(tg3-3.71b.tar.gz) or even Dell
(Bcom_LAN_10_30_Linux_DKMS_A00.tar.gz). All stopped when I tried to
compile them # make && make install The error is something like: a file
or directory does not exist....
Well, as root, I know they do exist! 8-((

This problem drives me nuts. Could you help? Thank you in advance!!

Iain

_______________________________________________
Linux-PowerEdge mailing list
Linux-PowerEdge at dell.com
http://lists.us.dell.com/mailman/listinfo/linux-poweredge
Please read the FAQ at http://lists.us.dell.com/faq



More information about the Linux-PowerEdge mailing list