racadm password bug

Diego Brito Veiga - b04917 diego.veiga at freescale.com
Wed Apr 18 13:19:09 CDT 2007


Hi,

I found a note on the web regarding the usage of special character on 
user/passwd. Maybe that's why you can change the passwd but I can't.

* The version 2.0 firmware does not support passwords with special characters 
  (nonalphanumeric) only for RAC user IDs logging in using the Web-based 
  interface (with LocalRAC Authentication). If you created 
  RAC user IDs using previous versions of the firmware or if you created 
  user IDs using Server Administrator that is running version 2.0 firmware 
  on the managed system, you cannot log in to the RAC.

http://support.dell.com/support/edocs/software/smdrac3/RAC/en/readme/racread_333.txt

Any issue reseting the racadm by racadm racresetcfg?

Tks
Diego

Linux PowerEdge wrote:
> Diego,
>
>
> Hope this helps.
>
> --------------------
> # racadm -r 1.2.3.4 -u root -p calvin config -g cfgUserAdmin -o
> cfgUserAdminPassword -i 1 't=e=s=t'
> Object value successfully modified
>
> # racadm -r 1.2.3.4 -u root -p 't=e=s=t' config -g cfgUserAdmin -o
> cfgUserAdminPassword -i 1 'p=a=s=s'
> Object value successfully modified
>
> # racadm -r 1.2.3.4 -i config -g cfgUserAdmin -o cfgUserAdminPassword
> -i 1 calvin
> username: root
> password: p=a=s=s
> Object value successfully modified
>
> # racadm -r 1.2.3.4 -i getsysinfo
> username: root
> password: calvin
>
> RAC Information:
> RAC Date/Time         = Wed, 18 Apr 2007 11:58:24
> Firmware Version      = 1.33 (Build 08.04)
> Firmware Updated      = Sat, 01 Oct 2005 16:07:41
> ...
> --------------------
>
>
> Seems to work ok for me.  I am using a DRAC4 on a PowerEdge 1850.
>
>
>
>
>
> On 4/16/07, Diego Brito Veiga - b04917 <diego.veiga at freescale.com> wrote:
>> Hi,
>>
>> The old passwd has the special-character  =
>> Could you please set to try setting your password using this one.
>>
>> My Version:
>> Remote Access Controller (RAC)
>> Version 2.50
>>
>>
>> Linux PowerEdge wrote:
>> > Diego,
>> >
>> > If the special character is something other than "!" please let me
>> > know.  I had no problems with changing the password when using the
>> > example in your email when quoting the passwords.
>> >
>> > --------------------
>> > #racadm -r 1.2.3.4 -u root -p calvin config -g cfgUserAdmin -o
>> > cfgUserAdminPassword -i 1 'a!b!c!d!'
>> >
>> > #racadm -r 1.2.3.4 -u root -p 'a!b!c!d!' config -g cfgUserAdmin -o
>> > cfgUserAdminPassword -i 1 'e!f!g!h!'
>> >
>> > #racadm -r 1.2.3.4 -i getsysinfo
>> > username: root
>> > password: e!f!g!h!
>> >
>> > RAC Information:
>> > RAC Date/Time         = Sat, 14 Apr 2007 01:07:43
>> > ...
>> >
>> > --------------------
>> >
>> > Does this happen on all generations of DRACs (3,4,5) or just one
>> > particular generation?
>> > If you have not already, you may also want to apply the latest
>> > firmware for the DRAC.
>> >
>> > I'll gladly try setting the password using a different
>> > special-character if you have a problem with one other than ! as
>> > exampled.
>> >
>> >
>> >
>> >
>> > On 4/9/07, Diego Brito Veiga - b04917 <diego.veiga at freescale.com> 
>> wrote:
>> >> Hi guys,
>> >>
>> >> I found on list a posted message regarding a bug at the racadm to 
>> change
>> >> the root passwd with special characters. Seems that the old 
>> password has
>> >> a special character that the racadm don't recognize.
>> >> I tried to contact the sender but his email isn't valid anymore. Did
>> >> someone already see it? Is there a workaround?
>> >>
>> >> Linux server 2.4.21-32.0.1.ELsmp
>> >> Remote Access Controller (RAC)
>> >> Version 2.50
>> >> Power Edge 2650
>> >>
>> >> PS: I tried to put the \<special character> but it still didn't work.
>> >> The command:
>> >> # /usr/sbin/racadm -r IP -i config -g cfgUserAdmin -o
>> >> cfgUserAdminPassword -i 1 <new password>
>> >> username: root
>> >> password: <old password>
>> >>
>> >> Regards,
>> >> Diego
>> >>
>> >> ------------------------------------------
>> >> Reference to the posted message:
>> >>
>> >>
>> >>   racadm password issue/bug?
>> >>
>> >> *Mark Jorgensen* markj at primustel.ca
>> >> 
>> <mailto:linux-poweredge%40dell.com?Subject=racadm%20password%20issue/bug%3F&In-Reply-To=> 
>>
>> >>
>> >> /Wed May 4 10:06:07 CDT 2005/
>> >>
>> >>     * Previous message: PE750 aacraid CERC SATA 1.5/6ch driver 
>> disk not
>> >>       working on FC3 ?
>> >>
>> >> 
>> <http://lists.us.dell.com/pipermail/linux-poweredge/2005-May/020509.html> 
>>
>> >>
>> >>     * Next message: HBA card recommendation
>> >>
>> >> 
>> <http://lists.us.dell.com/pipermail/linux-poweredge/2005-May/020512.html> 
>>
>> >>
>> >>     * *Messages sorted by:* [ date ]
>> >>
>> >> 
>> <http://lists.us.dell.com/pipermail/linux-poweredge/2005-May/date.html#20510> 
>>
>> >>
>> >>       [ thread ]
>> >>
>> >> 
>> <http://lists.us.dell.com/pipermail/linux-poweredge/2005-May/thread.html#20510> 
>>
>> >>
>> >>       [ subject ]
>> >>
>> >> 
>> <http://lists.us.dell.com/pipermail/linux-poweredge/2005-May/subject.html#20510> 
>>
>> >>
>> >>       [ author ]
>> >>
>> >> 
>> <http://lists.us.dell.com/pipermail/linux-poweredge/2005-May/author.html#20510> 
>>
>> >>
>> >>
>> >>
>> >> 
>> ------------------------------------------------------------------------
>> >>
>> >> Hey folks,
>> >>
>> >> We are having an interesting problem with a password change on our 
>> Dell
>> >> console cards.
>> >>
>> >> We use the following command:
>> >> racadm -r $IP -u root -p $OLDPASS config -g cfgUserAdmin -o
>> >> cfgUserAdminPassword -i 1 $NEWPASS
>> >>
>> >> $OLDPASS contains an 8 character password with special characters 
>> in it
>> >> (for example, a!b!c!d!).  We cannot change this to a new 
>> password.  We
>> >> have tried escaping the "!"'s.  We CAN currently login to the console
>> >> card
>> >> with the $OLDPASS.
>> >>
>> >> We get the following error when trying it by escaping the characters:
>> >>
>> >> authentication failed.
>> >>
>> >> racadm config: Transport: ERROR: objectIdGet. RC=14
>> >>
>> >> Funny thing is, the last password change we did, we obviously 
>> managed to
>> >> change the password to the one with the special characters.
>> >>
>> >> It seems the racadm is having trouble with special characters with 
>> the
>> >> $OLDPASS, but will accept them in the $NEWPASS field.
>> >>
>> >> Is this a known bug?
>> >> Is there a workaround for this?
>> >>
>> >> Thanks!
>> >> Mark
>> >> Primus Canada
>> >>
>> >> _______________________________________________
>> >> Linux-PowerEdge mailing list
>> >> Linux-PowerEdge at dell.com
>> >> http://lists.us.dell.com/mailman/listinfo/linux-poweredge
>> >> Please read the FAQ at http://lists.us.dell.com/faq
>> >>
>>
>>

-- 
Diego Brito Veiga
Freescale Semiconductors
EDA/CAD Support Group - Brazil
Phone: +55 19 3847-6368
Fax:   +55 19 3847-8203

The information contained in this communication has been classified as:
[ ] Freescale Semiconductor - Public Information
[x] Freescale Semiconductor - Internal Information
[ ] Freescale Semiconductor - Confidential Information



More information about the Linux-PowerEdge mailing list